]> git.pld-linux.org Git - packages/lcms.git/blob - lcms.spec
- updated to 1.16, added python patch
[packages/lcms.git] / lcms.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # don't build python bindings
4 #
5 Summary:        Little CMS - a library to transform between colour profiles
6 Summary(pl):    Little CMS - biblioteka do konwersji miêdzy profilami kolorów
7 Name:           lcms
8 Version:        1.16
9 Release:        1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/lcms/%{name}-%{version}.tar.gz
13 # Source0-md5:  b07b623f3e712373ff713fb32cf23651
14 Patch0:         %{name}-python.patch
15 URL:            http://www.littlecms.com/
16 BuildRequires:  autoconf >= 2.57
17 BuildRequires:  automake >= 1:1.7.2
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  sed >= 4.0
23 %if %{with python}
24 BuildRequires:  python-devel >= 2.2
25 BuildRequires:  swig-python >= 1.3.30
26 %endif
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # There is no pretty description in source archive... use these.
31
32 %description
33 lcms does not allow to write profiles, and profile manipulation is not
34 its goal. Instead, lcms focus on implement fast transforms between
35 profiles.
36
37 %description -l pl
38 lcms nie pozwala na tworzenie profili i obróbka profili nie jest celem
39 tej biblioteki. Natomiast lcms skupia siê na implementacji szybkiej
40 konwersji miêdzy profilami.
41
42 %package devel
43 Summary:        Little CMS - header files and developer's documentation
44 Summary(pl):    Little CMS - pliki nag³ówkowe i dokumentacja
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files needed to compile programs with liblcms and some
50 documentation useful for programmers.
51
52 %description devel -l pl
53 Pliki nag³ówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
54 dla programistów.
55
56 %package static
57 Summary:        Little CMS - static library
58 Summary(pl):    Little CMS - biblioteka statyczna
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static version of liblcms.
64
65 %description static -l pl
66 Statyczna biblioteka liblcms.
67
68 %package progs
69 Summary:        Example and demonstration programs for Little CMS
70 Summary(pl):    Programy przyk³adowe i demonstracyjne do Little CMS
71 Group:          Applications/Graphics
72 Requires:       %{name} = %{version}-%{release}
73
74 %description progs
75 Example and demonstration programs for Little CMS.
76
77 %description progs -l pl
78 Programy przyk³adowe i demonstracyjne do Little CMS.
79
80 %package -n python-lcms
81 Summary:        Little CMS module for Python
82 Summary(pl):    Modu³ Little CMS dla Pythona
83 Group:          Libraries/Python
84 Requires:       %{name} = %{version}-%{release}
85 %pyrequires_eq  python
86
87 %description -n python-lcms
88 Little CMS module for Python.
89
90 %description -n python-lcms -l pl
91 Modu³ Little CMS dla Pythona.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96
97 %build
98 # rebuild using newer swig (needed for g++ 4/python 2.5)
99 cd python
100 rm -f lcms.py lcms_wrap.cxx
101 swig -python -c++ -I../include lcms.i
102 cd ..
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__automake}
107 %configure \
108         --with%{!?with_python:out}-python
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
119
120 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS NEWS README.1ST
131 %attr(755,root,root) %{_libdir}/liblcms.so.*.*.*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %doc doc/*
136 %attr(755,root,root) %{_libdir}/liblcms.so
137 %{_libdir}/liblcms.la
138 %{_includedir}/*.h
139 %{_pkgconfigdir}/lcms.pc
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/liblcms.a
144
145 %files progs
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/*
148 %{_mandir}/man1/*.1*
149
150 %if %{with python}
151 %files -n python-lcms
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{py_sitedir}/_lcms.so
154 %{py_sitedir}/lcms.py
155 %endif
This page took 0.274947 seconds and 4 git commands to generate.