]> git.pld-linux.org Git - packages/lcms.git/blob - lcms.spec
96073ce16f1846193ecac438592e7d7df89aba73
[packages/lcms.git] / lcms.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # don't build python bindings
4 #
5 Summary:        Little CMS - a library to transform between colour profiles
6 Summary(pl.UTF-8):      Little CMS - biblioteka do konwersji między profilami kolorów
7 Name:           lcms
8 Version:        1.18
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 # corrupted
13 #Source0:       http://dl.sourceforge.net/lcms/%{name}-%{version}.tar.gz
14 Source0:        http://www.littlecms.com/%{name}-%{version}.tar.gz
15 # Source0-md5:  9f908e2dc48f76db77ac35a382e394c7
16 Patch0:         %{name}-python.patch
17 URL:            http://www.littlecms.com/
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake >= 1:1.7.2
20 BuildRequires:  libjpeg-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtiff-devel
23 BuildRequires:  libtool >= 1:1.4.2-9
24 BuildRequires:  sed >= 4.0
25 %if %{with python}
26 BuildRequires:  python-devel >= 2.2
27 BuildRequires:  swig-python >= 1.3.30
28 %endif
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 # There is no pretty description in source archive... use these.
33
34 %description
35 lcms does not allow to write profiles, and profile manipulation is not
36 its goal. Instead, lcms focus on implement fast transforms between
37 profiles.
38
39 %description -l pl.UTF-8
40 lcms nie pozwala na tworzenie profili i obróbka profili nie jest celem
41 tej biblioteki. Natomiast lcms skupia się na implementacji szybkiej
42 konwersji między profilami.
43
44 %package devel
45 Summary:        Little CMS - header files and developer's documentation
46 Summary(pl.UTF-8):      Little CMS - pliki nagłówkowe i dokumentacja
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files needed to compile programs with liblcms and some
52 documentation useful for programmers.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
56 dla programistów.
57
58 %package static
59 Summary:        Little CMS - static library
60 Summary(pl.UTF-8):      Little CMS - biblioteka statyczna
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static version of liblcms.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka liblcms.
69
70 %package progs
71 Summary:        Example and demonstration programs for Little CMS
72 Summary(pl.UTF-8):      Programy przykładowe i demonstracyjne do Little CMS
73 Group:          Applications/Graphics
74 Requires:       %{name} = %{version}-%{release}
75
76 %description progs
77 Example and demonstration programs for Little CMS.
78
79 %description progs -l pl.UTF-8
80 Programy przykładowe i demonstracyjne do Little CMS.
81
82 %package -n python-lcms
83 Summary:        Little CMS module for Python
84 Summary(pl.UTF-8):      Moduł Little CMS dla Pythona
85 Group:          Libraries/Python
86 Requires:       %{name} = %{version}-%{release}
87 %pyrequires_eq  python
88
89 %description -n python-lcms
90 Little CMS module for Python.
91
92 %description -n python-lcms -l pl.UTF-8
93 Moduł Little CMS dla Pythona.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 # rebuild using newer swig (needed for g++ 4/python 2.5)
101 cd python
102 rm -f lcms.py lcms_wrap.cxx
103 swig -python -c++ -I../include lcms.i
104 cd ..
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__automake}
109 %configure \
110         --with%{!?with_python:out}-python
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
121
122 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS COPYING NEWS README.1ST
133 %attr(755,root,root) %{_libdir}/liblcms.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/liblcms.so.1
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc doc/*
139 %attr(755,root,root) %{_libdir}/liblcms.so
140 %{_libdir}/liblcms.la
141 %{_includedir}/*.h
142 %{_pkgconfigdir}/lcms.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/liblcms.a
147
148 %files progs
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/*
151 %{_mandir}/man1/*.1*
152
153 %if %{with python}
154 %files -n python-lcms
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{py_sitedir}/_lcms.so
157 %{py_sitedir}/lcms.py
158 %endif
This page took 0.03564 seconds and 2 git commands to generate.