]> git.pld-linux.org Git - packages/lcms.git/blob - lcms.spec
- x32 rebuild
[packages/lcms.git] / lcms.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # don't build python bindings
4 #
5 Summary:        Little CMS - a library to transform between colour profiles
6 Summary(pl.UTF-8):      Little CMS - biblioteka do konwersji między profilami kolorów
7 Name:           lcms
8 Version:        1.19
9 Release:        4
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/lcms/%{name}-%{version}.tar.gz
13 # Source0-md5:  8af94611baf20d9646c7c2c285859818
14 Patch0:         %{name}-python.patch
15 URL:            http://www.littlecms.com/
16 BuildRequires:  autoconf >= 2.57
17 BuildRequires:  automake >= 1:1.7.2
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  sed >= 4.0
23 %if %{with python}
24 BuildRequires:  python-devel >= 2.2
25 BuildRequires:  python-modules
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.566
28 BuildRequires:  swig-python >= 1.3.30
29 %endif
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Little CMS intends to be a small-footprint color management engine,
35 with special focus on accuracy and performance. It uses the
36 International Color Consortium standard (ICC), which is the modern
37 standard when regarding to color management.
38
39 Little CMS 1.x supports ICC profile specification v3.4.
40
41 %description -l pl.UTF-8
42 Little CMS jest lekkim silnikiem zarządzania kolorami, tworzonym
43 przede wszystkim z myślą o dokładności i wydajności. Wykorzystuje
44 standard International Color Consortium (ICC), będący współczesnym
45 standardem zarządzania kolorami.
46
47 Little CMS 1.x obsługuje specyfikację profili ICC w wersji 3.4.
48
49 %package devel
50 Summary:        Little CMS - header files and developer's documentation
51 Summary(pl.UTF-8):      Little CMS - pliki nagłówkowe i dokumentacja
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 Header files needed to compile programs with liblcms and some
57 documentation useful for programmers.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
61 dla programistów.
62
63 %package static
64 Summary:        Little CMS - static library
65 Summary(pl.UTF-8):      Little CMS - biblioteka statyczna
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static version of liblcms.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka liblcms.
74
75 %package progs
76 Summary:        Example and demonstration programs for Little CMS
77 Summary(pl.UTF-8):      Programy przykładowe i demonstracyjne do Little CMS
78 Group:          Applications/Graphics
79 Requires:       %{name} = %{version}-%{release}
80
81 %description progs
82 Example and demonstration programs for Little CMS.
83
84 %description progs -l pl.UTF-8
85 Programy przykładowe i demonstracyjne do Little CMS.
86
87 %package -n python-lcms
88 Summary:        Little CMS module for Python
89 Summary(pl.UTF-8):      Moduł Little CMS dla Pythona
90 Group:          Libraries/Python
91 Requires:       %{name} = %{version}-%{release}
92 %pyrequires_eq  python
93
94 %description -n python-lcms
95 Little CMS module for Python.
96
97 %description -n python-lcms -l pl.UTF-8
98 Moduł Little CMS dla Pythona.
99
100 %prep
101 %setup -q
102 %undos configure.ac
103 %patch0 -p1
104
105 %build
106 # rebuild using newer swig (needed for g++ 4/python 2.5)
107 cd python
108 rm -f lcms.py lcms_wrap.cxx
109 swig -python -c++ -I../include lcms.i
110 cd ..
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoconf}
114 %{__automake}
115 %configure \
116         --with%{!?with_python:out}-python
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
127
128 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS COPYING NEWS README.1ST
139 %attr(755,root,root) %{_libdir}/liblcms.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/liblcms.so.1
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc doc/*
145 %attr(755,root,root) %{_libdir}/liblcms.so
146 %{_libdir}/liblcms.la
147 %{_includedir}/icc34.h
148 %{_includedir}/lcms.h
149 %{_pkgconfigdir}/lcms.pc
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/liblcms.a
154
155 %files progs
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/icc2ps
158 %attr(755,root,root) %{_bindir}/icclink
159 %attr(755,root,root) %{_bindir}/icctrans
160 %attr(755,root,root) %{_bindir}/jpegicc
161 %attr(755,root,root) %{_bindir}/tiffdiff
162 %attr(755,root,root) %{_bindir}/tifficc
163 %attr(755,root,root) %{_bindir}/wtpt
164 %{_mandir}/man1/icc2ps.1*
165 %{_mandir}/man1/icclink.1*
166 %{_mandir}/man1/jpegicc.1*
167 %{_mandir}/man1/tifficc.1*
168 %{_mandir}/man1/wtpt.1*
169
170 %if %{with python}
171 %files -n python-lcms
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{py_sitedir}/_lcms.so
174 %{py_sitedir}/lcms.py
175 %endif
This page took 0.299355 seconds and 3 git commands to generate.