]> git.pld-linux.org Git - packages/lcms2.git/blob - lcms.spec
- fix paths
[packages/lcms2.git] / lcms.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # don't build python bindings
4 #
5 Summary:        Little CMS - a library to transform between colour profiles
6 Summary(pl):    Little CMS - biblioteka do konwersji miêdzy profilami kolorów
7 Name:           lcms
8 Version:        1.15
9 Release:        2
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/lcms/%{name}-%{version}.tar.gz
13 # Source0-md5:  76c921973fdea4f880944a024197f924
14 URL:            http://www.littlecms.com/
15 BuildRequires:  autoconf >= 2.57
16 BuildRequires:  automake >= 1:1.7.2
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtiff-devel
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  sed >= 4.0
22 %if %{with python}
23 BuildRequires:  python-devel >= 1.5
24 BuildRequires:  swig-python >= 1.3.25
25 %endif
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # There is no pretty description in source archive... use these.
30
31 %description
32 lcms does not allow to write profiles, and profile manipulation is not
33 its goal. Instead, lcms focus on implement fast transforms between
34 profiles.
35
36 %description -l pl
37 lcms nie pozwala na tworzenie profili i obróbka profili nie jest celem
38 tej biblioteki. Natomiast lcms skupia siê na implementacji szybkiej
39 konwersji miêdzy profilami.
40
41 %package devel
42 Summary:        Little CMS - header files and developer's documentation
43 Summary(pl):    Little CMS - pliki nag³ówkowe i dokumentacja
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files needed to compile programs with liblcms and some
49 documentation useful for programmers.
50
51 %description devel -l pl
52 Pliki nag³ówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
53 dla programistów.
54
55 %package static
56 Summary:        Little CMS - static library
57 Summary(pl):    Little CMS - biblioteka statyczna
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static version of liblcms.
63
64 %description static -l pl
65 Statyczna biblioteka liblcms.
66
67 %package progs
68 Summary:        Example and demonstration programs for Little CMS
69 Summary(pl):    Programy przyk³adowe i demonstracyjne do Little CMS
70 Group:          Applications/Graphics
71 Requires:       %{name} = %{version}-%{release}
72
73 %description progs
74 Example and demonstration programs for Little CMS.
75
76 %description progs -l pl
77 Programy przyk³adowe i demonstracyjne do Little CMS.
78
79 %package -n python-lcms
80 Summary:        Little CMS module for Python
81 Summary(pl):    Modu³ Little CMS dla Pythona
82 Group:          Libraries/Python
83 Requires:       %{name} = %{version}-%{release}
84 %pyrequires_eq  python
85
86 %description -n python-lcms
87 Little CMS module for Python.
88
89 %description -n python-lcms -l pl
90 Modu³ Little CMS dla Pythona.
91
92 %prep
93 %setup -q
94 # http://www.mail-archive.com/lcms-user@lists.sourceforge.net/msg01261.html
95 sed -i s/SWIGTYPE_LPGAMMATABLE/SWIGTYPE_p_GAMMATABLE/g python/lcms*
96
97 %build
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %{__automake}
102 %configure \
103         --with%{!?with_python:out}-python
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
114
115 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS NEWS README.1ST
126 %attr(755,root,root) %{_libdir}/lib*.so.*.*
127
128 %files devel
129 %defattr(644,root,root,755)
130 %doc doc/*
131 %attr(755,root,root) %{_libdir}/lib*.so
132 %{_libdir}/lib*.la
133 %{_includedir}/*.h
134 %{_pkgconfigdir}/*.pc
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/lib*.a
139
140 %files progs
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/*
143 %{_mandir}/man1/*.1*
144
145 %if %{with python}
146 %files -n python-lcms
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{py_sitedir}/_lcms.so
149 %{py_sitedir}/lcms.py
150 %endif
This page took 0.082429 seconds and 3 git commands to generate.