]> git.pld-linux.org Git - packages/lcms.git/blob - lcms.spec
- undos configure.ac
[packages/lcms.git] / lcms.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # don't build python bindings
4 #
5 Summary:        Little CMS - a library to transform between colour profiles
6 Summary(pl.UTF-8):      Little CMS - biblioteka do konwersji między profilami kolorów
7 Name:           lcms
8 Version:        1.18
9 Release:        2
10 License:        MIT
11 Group:          Libraries
12 # corrupted
13 #Source0:       http://dl.sourceforge.net/lcms/%{name}-%{version}.tar.gz
14 Source0:        http://www.littlecms.com/%{name}-%{version}.tar.gz
15 # Source0-md5:  9f908e2dc48f76db77ac35a382e394c7
16 Patch0:         %{name}-python.patch
17 URL:            http://www.littlecms.com/
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake >= 1:1.7.2
20 BuildRequires:  dos2unix
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtiff-devel
24 BuildRequires:  libtool >= 1:1.4.2-9
25 BuildRequires:  sed >= 4.0
26 %if %{with python}
27 BuildRequires:  python-devel >= 2.2
28 BuildRequires:  swig-python >= 1.3.30
29 %endif
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 # There is no pretty description in source archive... use these.
34
35 %description
36 lcms does not allow to write profiles, and profile manipulation is not
37 its goal. Instead, lcms focus on implement fast transforms between
38 profiles.
39
40 %description -l pl.UTF-8
41 lcms nie pozwala na tworzenie profili i obróbka profili nie jest celem
42 tej biblioteki. Natomiast lcms skupia się na implementacji szybkiej
43 konwersji między profilami.
44
45 %package devel
46 Summary:        Little CMS - header files and developer's documentation
47 Summary(pl.UTF-8):      Little CMS - pliki nagłówkowe i dokumentacja
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files needed to compile programs with liblcms and some
53 documentation useful for programmers.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
57 dla programistów.
58
59 %package static
60 Summary:        Little CMS - static library
61 Summary(pl.UTF-8):      Little CMS - biblioteka statyczna
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static version of liblcms.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka liblcms.
70
71 %package progs
72 Summary:        Example and demonstration programs for Little CMS
73 Summary(pl.UTF-8):      Programy przykładowe i demonstracyjne do Little CMS
74 Group:          Applications/Graphics
75 Requires:       %{name} = %{version}-%{release}
76
77 %description progs
78 Example and demonstration programs for Little CMS.
79
80 %description progs -l pl.UTF-8
81 Programy przykładowe i demonstracyjne do Little CMS.
82
83 %package -n python-lcms
84 Summary:        Little CMS module for Python
85 Summary(pl.UTF-8):      Moduł Little CMS dla Pythona
86 Group:          Libraries/Python
87 Requires:       %{name} = %{version}-%{release}
88 %pyrequires_eq  python
89
90 %description -n python-lcms
91 Little CMS module for Python.
92
93 %description -n python-lcms -l pl.UTF-8
94 Moduł Little CMS dla Pythona.
95
96 %prep
97 %setup -q
98 dos2unix configure.ac
99 %patch0 -p1
100
101 %build
102 # rebuild using newer swig (needed for g++ 4/python 2.5)
103 cd python
104 rm -f lcms.py lcms_wrap.cxx
105 swig -python -c++ -I../include lcms.i
106 cd ..
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__automake}
111 %configure \
112         --with%{!?with_python:out}-python
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
123
124 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS COPYING NEWS README.1ST
135 %attr(755,root,root) %{_libdir}/liblcms.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/liblcms.so.1
137
138 %files devel
139 %defattr(644,root,root,755)
140 %doc doc/*
141 %attr(755,root,root) %{_libdir}/liblcms.so
142 %{_libdir}/liblcms.la
143 %{_includedir}/*.h
144 %{_pkgconfigdir}/lcms.pc
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/liblcms.a
149
150 %files progs
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/*
153 %{_mandir}/man1/*.1*
154
155 %if %{with python}
156 %files -n python-lcms
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{py_sitedir}/_lcms.so
159 %{py_sitedir}/lcms.py
160 %endif
This page took 0.047256 seconds and 3 git commands to generate.