]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
- removed config.h.in manual creation (it is autoheader's job)
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra.
2 Name:           lapack
3 Version:        3.0
4 Release:        1
5 Copyright:      Freely distributable
6 Group:          Development/Libraries
7 Group(fr):      Development/Librairies
8 Group(pl):      Programowanie/Biblioteki
9 Source0:        http://www.netlib.org/lapack/%{name}.tar.bz2
10 Source1:        http://www.netlib.org/lapack/manpages.tar.bz2
11 #Source2:       Makefile.blas
12 #Source3:       Makefile.lapack
13 Patch0:         %{name}-automake_support.patch
14 URL:            http://www.netlib.org/lapack/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16 Requires:       blas
17
18 %description
19 LAPACK (Linear Algebra PACKage) is a standard library for numerical
20 linear algebra. LAPACK provides routines for solving systems of
21 simultaneous linear equations, least-squares solutions of linear
22 systems of equations, eigenvalue problems, and singular value
23 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
24 Schur, and generalized Schur) and related computations (i.e.,
25 reordering of Schur factorizations and estimating condition numbers)
26 are also included. LAPACK can handle dense and banded matrices, but
27 not general sparse matrices. Similar functionality is provided for
28 real and complex matrices in both single and double precision. LAPACK
29 is coded in Fortran77 and is built with egcs.
30
31 %package devel
32 Summary:        %{name} header files
33 Summary(pl):    Pliki nag³ówkowe %{name}
34 Group:          Development/Libraries
35 Group(fr):      Development/Librairies
36 Group(pl):      Programowanie/Biblioteki
37 Requires:       %{name} = %{version}
38
39 %description devel
40 %{name} header files.
41
42 %description -l pl devel
43 Pliki nag³ówkowe %{name}.
44
45 %package static
46 Summary:        Static %{name} libraries
47 Summary(pl):    Biblioteki statyczne %{name}
48 Group:          Development/Libraries
49 Group(fr):      Development/Librairies
50 Group(pl):      Programowanie/Biblioteki
51 Requires:       %{name}-devel = %{version}
52
53 %description static
54 Static %{name} libraries.
55
56 %description -l pl static
57 Biblioteki statyczne %{name}.
58
59
60 %package -n blas
61 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux.
62 Group:          Development/Libraries
63 Group(fr):      Development/Librairies
64 Group(pl):      Programowanie/Biblioteki
65 Obsoletes:      lapack-blas
66
67 %description -n blas
68 BLAS (Basic Linear Algebra Subprograms) is a standard library for
69 numerical algebra. BLAS provides a number of basic algorithms for
70 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
71 77 and build with egcs. BLAS manual pages are available in the
72 blas-man package.
73
74 %package -n blas-devel
75 Summary:        %{name} header files
76 Summary(pl):    Pliki nag³ówkowe %{name}
77 Group:          Development/Libraries
78 Group(fr):      Development/Librairies
79 Group(pl):      Programowanie/Biblioteki
80 Requires:       blas = %{version}
81
82 %description -n blas-devel
83 %{name} header files.
84
85 %description -l pl -n blas-devel
86 Pliki nag³ówkowe %{name}.
87
88 %package -n blas-static
89 Summary:        Static %{name} libraries
90 Summary(pl):    Biblioteki statyczne %{name}
91 Group:          Development/Libraries
92 Group(fr):      Development/Librairies
93 Group(pl):      Programowanie/Biblioteki
94 Requires:       blas-devel = %{version}
95
96 %description -n blas-static
97 Static %{name} libraries.
98
99 %description -l pl -n blas-static
100 Biblioteki statyczne %{name}.
101
102 %package -n blas-man
103 Summary:        Man pages for BLAS (Basic Linear Algebra Subprograms) routines.
104 Group:          Documentation
105 Group(pl):      Dokumentacja
106 Obsoletes:      lapack-blas-man
107
108 %description -n blas-man
109 The blas-man package contains documentation for BLAS (Basic Linear
110 Algebra Subprograms) routines, in the form of man pages.
111
112 %package man
113 Summary:        Documentation for the LAPACK numerical linear algebra libraries.
114 Group:          Documentation
115 Group(pl):      Dokumentacja
116
117 %description man
118 Documentation, in the form of man pages, for the LAPACK numerical
119 linear algebra libraries.
120
121
122 %prep
123 %setup -q -a1 -n LAPACK
124 %patch0 -p1
125 # directory INSTALL conflicts with file INSTALL needed by automake
126 mv -f INSTALL install
127 >INSTALL
128 >AUTHORS
129 >ChangeLog
130 >NEWS
131 >COPYING
132 #>config.h.in
133
134 %build
135 aclocal
136 autoheader
137 automake --add-missing
138 autoconf
139 %configure 
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 %{__make} install DESTDIR=$RPM_BUILD_ROOT
145
146 install -d $RPM_BUILD_ROOT%{_mandir}/manl
147 gzip -9nf blas/man/manl/*.l man/manl/*.l
148 install blas/man/manl/* man/manl/* $RPM_BUILD_ROOT%{_mandir}/manl
149
150 echo "%defattr(644, root, root, 755)" > blasmans.list
151 find blas/man/manl -name "*.gz" -printf "%{_mandir}/manl/%%f\n" >> blasmans.list
152 echo "%defattr(644, root, root, 755)" > mans.list
153 find man/manl -name "*.gz" -printf "%{_mandir}/manl/%%f\n" >> mans.list
154
155 gzip -9nf README
156
157 %post           -p /sbin/ldconfig
158 %postun         -p /sbin/ldconfig
159 %post   -n blas -p /sbin/ldconfig
160 %postun -n blas -p /sbin/ldconfig
161
162 %clean
163 rm -fr $RPM_BUILD_ROOT
164
165
166 %files
167 %defattr(644,root,root,755)
168 %doc README*
169 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %{_libdir}/liblapack.so
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/liblapack.a
178
179 %files -n blas 
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
182
183 %files -n blas-devel
184 %defattr(644,root,root,755)
185 %{_libdir}/libblas.so
186
187 %files -n blas-static
188 %defattr(644,root,root,755)
189 %{_libdir}/libblas.a
190
191
192 %files -n blas-man -f blasmans.list
193 %defattr(644,root,root,755)
194
195 %files man -f mans.list
196 %defattr(644,root,root,755)
This page took 0.058801 seconds and 4 git commands to generate.