]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
perl -pi -e "s/^automake -a -c -f --foreing/\%\{__automake\}/; \
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra
2 Summary(pl):    Biblioteki numeryczne LAPACK do algebry liniowej
3 Name:           lapack
4 Version:        3.0
5 Release:        13
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/lapack/%{name}.tgz
9 Source1:        http://www.netlib.org/lapack/manpages.tgz
10 Patch0:         %{name}-automake_support.patch
11 Patch1:         %{name}-20010525.patch
12 URL:            http://www.netlib.org/lapack/
13 BuildRequires:  gcc-g77
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  ed
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Requires:       blas
20
21 %description
22 LAPACK (Linear Algebra PACKage) is a standard library for numerical
23 linear algebra. LAPACK provides routines for solving systems of
24 simultaneous linear equations, least-squares solutions of linear
25 systems of equations, eigenvalue problems, and singular value
26 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
27 Schur, and generalized Schur) and related computations (i.e.,
28 reordering of Schur factorizations and estimating condition numbers)
29 are also included. LAPACK can handle dense and banded matrices, but
30 not general sparse matrices. Similar functionality is provided for
31 real and complex matrices in both single and double precision. LAPACK
32 is coded in Fortran77.
33
34 %description -l pl
35 LAPACK (Linear Algebra PACKage) jest standardow± bibliotek± numeryczn±
36 do algebry liniowej. Dostarcza funkcje rozwi±zywania: uk³adów równañ
37 liniowych, uk³adów równañ metod± najmniejszych kwadratów, problemów
38 w³asnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
39 QR, SVD, Schura, uogólnion± Schura) i zwi±zanych z tym obliczeñ (np.
40 przenumerowywanie w faktoryzacji Schura i estymacjê uwarunkowania).
41 LAPACK mo¿e obs³ugiwaæ macierze blokowe i pasmowe, ale nie rzadkie w
42 ogólnym przypadku. Zapewnia funkcjonalno¶æ dla macierzy rzeczywistych
43 i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
44 napisany w Fortranie 77.
45
46 %package devel
47 Summary:        LAPACK header files
48 Summary(pl):    Pliki nag³ówkowe LAPACK
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}
51 Obsoletes:      lapack-man
52
53 %description devel
54 LAPACK header files.
55
56 %description devel -l pl
57 Pliki nag³ówkowe LAPACK.
58
59 %package static
60 Summary:        Static LAPACK libraries
61 Summary(pl):    Biblioteki statyczne LAPACK
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}
64
65 %description static
66 Static LAPACK libraries.
67
68 %description static -l pl
69 Biblioteki statyczne LAPACK.
70
71 %package -n blas
72 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
73 Summary(pl):    Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
74 Group:          Development/Libraries
75 Obsoletes:      lapack-blas
76
77 %description -n blas
78 BLAS (Basic Linear Algebra Subprograms) is a standard library for
79 numerical algebra. BLAS provides a number of basic algorithms for
80 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
81 77.
82
83 %description -n blas -l pl
84 BLAS (Basic Linear Algebra Subprograms) jest standardow± bibliotek±
85 numeryczn± algebry. Dostarcza wiele podstawowych algorytmów dla
86 algebry liniowej. Jest szybka i dobrze przetestowana, zosta³a napisana
87 w Fortranie 77.
88
89 %package -n blas-devel
90 Summary:        BLAS header files
91 Summary(pl):    Pliki nag³ówkowe BLAS
92 Group:          Development/Libraries
93 Requires:       blas = %{version}
94 Obsoletes:      blas-man
95
96 %description -n blas-devel
97 BLAS header files.
98
99 %description -n blas-devel -l pl
100 Pliki nag³ówkowe BLAS.
101
102 %package -n blas-static
103 Summary:        Static BLAS libraries
104 Summary(pl):    Biblioteki statyczne BLAS
105 Group:          Development/Libraries
106 Requires:       blas-devel = %{version}
107
108 %description -n blas-static
109 Static BLAS libraries.
110
111 %description -n blas-static -l pl
112 Biblioteki statyczne BLAS.
113
114 %prep
115 %setup -q -a1 -n LAPACK
116 %patch0 -p1
117 %patch1 -p1
118 # directory INSTALL conflicts with file INSTALL needed by automake
119 mv -f INSTALL install
120 >INSTALL
121 >AUTHORS
122 >ChangeLog
123 >NEWS
124 >COPYING
125 #>config.h.in
126
127 %build
128 rm -f ltmain.sh
129 libtoolize --copy --force
130 aclocal
131 autoheader
132 automake --add-missing
133 %{__autoconf}
134 %configure
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 #workaround libtool
140 ed SRC/liblapack.la <<EOF
141 s/relink_command=.*/relink_command=''/
142 w
143 q
144 EOF
145 %{__make} install DESTDIR=$RPM_BUILD_ROOT
146
147 install -d $RPM_BUILD_ROOT%{_mandir}/man3
148 for d in man/manl/*.l blas/man/manl/*.l ; do
149         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
150 done
151
152 echo "%defattr(644, root, root, 755)" > blasmans.list
153 find blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
154 echo "%defattr(644, root, root, 755)" > mans.list
155 find man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
156
157 gzip -9nf README
158
159 %clean
160 rm -fr $RPM_BUILD_ROOT
161
162 %post           -p /sbin/ldconfig
163 %postun         -p /sbin/ldconfig
164
165 %post   -n blas -p /sbin/ldconfig
166 %postun -n blas -p /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %doc README*
171 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
172
173 %files devel -f mans.list
174 %defattr(644,root,root,755)
175 %{_libdir}/liblapack.so
176
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/liblapack.a
180
181 %files -n blas
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
184
185 %files -n blas-devel -f blasmans.list
186 %defattr(644,root,root,755)
187 %{_libdir}/libblas.so
188
189 %files -n blas-static
190 %defattr(644,root,root,755)
191 %{_libdir}/libblas.a
This page took 0.101561 seconds and 4 git commands to generate.