]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
- added blas-nan patch (disable "0*x=0" optimizations not respecting NaN)
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra
2 Summary(pl.UTF-8):      Biblioteki numeryczne LAPACK do algebry liniowej
3 Name:           lapack
4 Version:        3.2.2
5 %define man_ver 3.2.0
6 Release:        2
7 License:        freely distributable
8 Group:          Libraries
9 Source0:        http://www.netlib.org/lapack/%{name}-%{version}.tgz
10 # Source0-md5:  10832891c9e8100f81108c1ec7da0da4
11 Source1:        http://www.netlib.org/lapack/manpages-%{man_ver}.tgz
12 # Source1-md5:  145007cab915504caec382289462a166
13 Patch0:         %{name}-automake_support.patch
14 Patch1:         blas-nan.patch
15 URL:            http://www.netlib.org/lapack/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gcc-fortran
19 BuildRequires:  libtool >= 2:1.5
20 Requires:       blas = %{version}-%{release}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 LAPACK (Linear Algebra PACKage) is a standard library for numerical
25 linear algebra. LAPACK provides routines for solving systems of
26 simultaneous linear equations, least-squares solutions of linear
27 systems of equations, eigenvalue problems, and singular value
28 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
29 Schur, and generalized Schur) and related computations (i.e.,
30 reordering of Schur factorizations and estimating condition numbers)
31 are also included. LAPACK can handle dense and banded matrices, but
32 not general sparse matrices. Similar functionality is provided for
33 real and complex matrices in both single and double precision. LAPACK
34 is coded in Fortran77.
35
36 %description -l pl.UTF-8
37 LAPACK (Linear Algebra PACKage) jest standardową biblioteką numeryczną
38 do algebry liniowej. Dostarcza funkcje rozwiązywania: układów równań
39 liniowych, układów równań metodą najmniejszych kwadratów, problemów
40 własnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
41 QR, SVD, Schura, uogólnioną Schura) i związanych z tym obliczeń (np.
42 przenumerowywanie w faktoryzacji Schura i estymację uwarunkowania).
43 LAPACK może obsługiwać macierze blokowe i pasmowe, ale nie rzadkie w
44 ogólnym przypadku. Zapewnia funkcjonalność dla macierzy rzeczywistych
45 i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
46 napisany w Fortranie 77.
47
48 %package devel
49 Summary:        LAPACK development files
50 Summary(pl.UTF-8):      Pliki programistyczne LAPACK
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       blas-devel = %{version}-%{release}
54 Obsoletes:      lapack-man
55
56 %description devel
57 LAPACK development files.
58
59 %description devel -l pl.UTF-8
60 Pliki programistyczne LAPACK.
61
62 %package static
63 Summary:        Static LAPACK libraries
64 Summary(pl.UTF-8):      Biblioteki statyczne LAPACK
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static LAPACK libraries.
70
71 %description static -l pl.UTF-8
72 Biblioteki statyczne LAPACK.
73
74 %package -n blas
75 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
76 Summary(pl.UTF-8):      Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
77 Group:          Libraries
78 Obsoletes:      lapack-blas
79
80 %description -n blas
81 BLAS (Basic Linear Algebra Subprograms) is a standard library for
82 numerical algebra. BLAS provides a number of basic algorithms for
83 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
84 77.
85
86 Warning: this is a reference implementation from Netlib. If possible,
87 use version optimized for your architecture instead.
88
89 %description -n blas -l pl.UTF-8
90 BLAS (Basic Linear Algebra Subprograms) jest standardową biblioteką
91 numeryczną algebry. Dostarcza wiele podstawowych algorytmów dla
92 algebry liniowej. Jest szybka i dobrze przetestowana, została napisana
93 w Fortranie 77.
94
95 Ostrzeżenie: to jest implementacja przykładowa z repozytorium Netlib.
96 Jeżeli to możliwe, należy używać zamiast niej wersji zoptymalizowanej
97 pod daną architekturę.
98
99 %package -n blas-devel
100 Summary:        BLAS development files
101 Summary(pl.UTF-8):      Pliki programistyczne BLAS
102 Group:          Development/Libraries
103 Requires:       blas = %{version}-%{release}
104 Obsoletes:      blas-man
105
106 %description -n blas-devel
107 BLAS development files.
108
109 %description -n blas-devel -l pl.UTF-8
110 Pliki programistyczne BLAS.
111
112 %package -n blas-static
113 Summary:        Static BLAS libraries
114 Summary(pl.UTF-8):      Biblioteki statyczne BLAS
115 Group:          Development/Libraries
116 Requires:       blas-devel = %{version}-%{release}
117
118 %description -n blas-static
119 Static BLAS libraries.
120
121 %description -n blas-static -l pl.UTF-8
122 Biblioteki statyczne BLAS.
123
124 %prep
125 %setup -q -a1
126 %patch0 -p1
127 %patch1 -p1
128 mv -f lapack-%{man_ver}/manpages .
129 # directory INSTALL conflicts with file INSTALL needed by automake
130 mv -f INSTALL INSTALLSRC
131 # copy selected routines; use INT_ETIME versions of second
132 cp -f INSTALLSRC/{ilaver,slamch,dlamch,second_INT_ETIME,dsecnd_INT_ETIME}.f SRC
133
134 %build
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoheader}
138 %{__autoconf}
139 %{__automake}
140 %configure
141
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 # present both in blas and lapack
151 %{__rm} manpages/man/manl/{lsame,xerbla,xerbla_array}.l
152
153 install -d $RPM_BUILD_ROOT%{_mandir}/man3
154 for d in manpages/man/manl/*.l manpages/blas/man/manl/*.l ; do
155         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
156 done
157
158 echo "%defattr(644,root,root,755)" > blasmans.list
159 find manpages/blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
160 echo "%defattr(644,root,root,755)" > mans.list
161 find manpages/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
162
163 %clean
164 rm -fr $RPM_BUILD_ROOT
165
166 %post   -p /sbin/ldconfig
167 %postun -p /sbin/ldconfig
168
169 %post   -n blas -p /sbin/ldconfig
170 %postun -n blas -p /sbin/ldconfig
171
172 %files
173 %defattr(644,root,root,755)
174 %doc README
175 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/liblapack.so.2
177
178 %files devel -f mans.list
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/liblapack.so
181 %{_libdir}/liblapack.la
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/liblapack.a
186
187 %files -n blas
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libblas.so.2
191
192 %files -n blas-devel -f blasmans.list
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libblas.so
195 %{_libdir}/libblas.la
196
197 %files -n blas-static
198 %defattr(644,root,root,755)
199 %{_libdir}/libblas.a
This page took 0.058532 seconds and 4 git commands to generate.