]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
- added missing lapack symbols
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra
2 Summary(pl.UTF-8):      Biblioteki numeryczne LAPACK do algebry liniowej
3 Name:           lapack
4 Version:        3.1.1
5 Release:        3
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/lapack/%{name}-%{version}.tgz
9 # Source0-md5:  00b21551a899bcfbaa7b8443e1faeef9
10 Source1:        http://www.netlib.org/lapack/manpages-%{version}.tgz
11 # Source1-md5:  e5b46d8915f7cc8a1e50aa3e70c9f86e
12 Patch0:         %{name}-automake_support.patch
13 URL:            http://www.netlib.org/lapack/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gcc-fortran
17 BuildRequires:  libtool >= 2:1.5
18 Requires:       blas = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 LAPACK (Linear Algebra PACKage) is a standard library for numerical
23 linear algebra. LAPACK provides routines for solving systems of
24 simultaneous linear equations, least-squares solutions of linear
25 systems of equations, eigenvalue problems, and singular value
26 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
27 Schur, and generalized Schur) and related computations (i.e.,
28 reordering of Schur factorizations and estimating condition numbers)
29 are also included. LAPACK can handle dense and banded matrices, but
30 not general sparse matrices. Similar functionality is provided for
31 real and complex matrices in both single and double precision. LAPACK
32 is coded in Fortran77.
33
34 %description -l pl.UTF-8
35 LAPACK (Linear Algebra PACKage) jest standardową biblioteką numeryczną
36 do algebry liniowej. Dostarcza funkcje rozwiązywania: układów równań
37 liniowych, układów równań metodą najmniejszych kwadratów, problemów
38 własnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
39 QR, SVD, Schura, uogólnioną Schura) i związanych z tym obliczeń (np.
40 przenumerowywanie w faktoryzacji Schura i estymację uwarunkowania).
41 LAPACK może obsługiwać macierze blokowe i pasmowe, ale nie rzadkie w
42 ogólnym przypadku. Zapewnia funkcjonalność dla macierzy rzeczywistych
43 i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
44 napisany w Fortranie 77.
45
46 %package devel
47 Summary:        LAPACK header files
48 Summary(pl.UTF-8):      Pliki nagłówkowe LAPACK
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       blas-devel = %{version}-%{release}
52 Obsoletes:      lapack-man
53
54 %description devel
55 LAPACK header files.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe LAPACK.
59
60 %package static
61 Summary:        Static LAPACK libraries
62 Summary(pl.UTF-8):      Biblioteki statyczne LAPACK
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static LAPACK libraries.
68
69 %description static -l pl.UTF-8
70 Biblioteki statyczne LAPACK.
71
72 %package -n blas
73 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
74 Summary(pl.UTF-8):      Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
75 Group:          Development/Libraries
76 Obsoletes:      lapack-blas
77
78 %description -n blas
79 BLAS (Basic Linear Algebra Subprograms) is a standard library for
80 numerical algebra. BLAS provides a number of basic algorithms for
81 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
82 77.
83
84 Warning: this is a reference implementation from Netlib. If possible,
85 use version optimized for your architecture instead.
86
87 %description -n blas -l pl.UTF-8
88 BLAS (Basic Linear Algebra Subprograms) jest standardową biblioteką
89 numeryczną algebry. Dostarcza wiele podstawowych algorytmów dla
90 algebry liniowej. Jest szybka i dobrze przetestowana, została napisana
91 w Fortranie 77.
92
93 Ostrzeżenie: to jest implementacja przykładowa z repozytorium Netlib.
94 Jeżeli to możliwe, należy używać zamiast niej wersji zoptymalizowanej
95 pod daną architekturę.
96
97 %package -n blas-devel
98 Summary:        BLAS header files
99 Summary(pl.UTF-8):      Pliki nagłówkowe BLAS
100 Group:          Development/Libraries
101 Requires:       blas = %{version}-%{release}
102 Obsoletes:      blas-man
103
104 %description -n blas-devel
105 BLAS header files.
106
107 %description -n blas-devel -l pl.UTF-8
108 Pliki nagłówkowe BLAS.
109
110 %package -n blas-static
111 Summary:        Static BLAS libraries
112 Summary(pl.UTF-8):      Biblioteki statyczne BLAS
113 Group:          Development/Libraries
114 Requires:       blas-devel = %{version}-%{release}
115
116 %description -n blas-static
117 Static BLAS libraries.
118
119 %description -n blas-static -l pl.UTF-8
120 Biblioteki statyczne BLAS.
121
122 %prep
123 %setup -q -a1
124 %patch0 -p1
125 # directory INSTALL conflicts with file INSTALL needed by automake
126 mv -f INSTALL install
127 # or maybe it should fail while trying to overwrite a file?
128 cp -f install/*.f SRC/
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoheader}
134 %{__autoconf}
135 %{__automake}
136 %configure
137
138 %{__make} \
139         LTTAG="--tag=F77"
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 # present both in blas and lapack
148 rm -f man/manl/{lsame,xerbla}.l
149
150 install -d $RPM_BUILD_ROOT%{_mandir}/man3
151 for d in manpages/man/manl/*.l manpages/blas/man/manl/*.l ; do
152         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
153 done
154
155 echo "%defattr(644, root, root, 755)" > blasmans.list
156 find manpages/blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
157 echo "%defattr(644, root, root, 755)" > mans.list
158 find manpages/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
159
160 %clean
161 rm -fr $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %post   -n blas -p /sbin/ldconfig
167 %postun -n blas -p /sbin/ldconfig
168
169 %files
170 %defattr(644,root,root,755)
171 %doc README
172 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
173
174 %files devel -f mans.list
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/liblapack.so
177 %{_libdir}/liblapack.la
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/liblapack.a
182
183 %files -n blas
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
186
187 %files -n blas-devel -f blasmans.list
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libblas.so
190 %{_libdir}/libblas.la
191
192 %files -n blas-static
193 %defattr(644,root,root,755)
194 %{_libdir}/libblas.a
This page took 0.056431 seconds and 4 git commands to generate.