]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
- switch optimilization off, see http://www.netlib.org/lapack/faq.html#1.13
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra
2 Summary(pl.UTF-8):      Biblioteki numeryczne LAPACK do algebry liniowej
3 Name:           lapack
4 Version:        3.1.1
5 Release:        4
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/lapack/%{name}-%{version}.tgz
9 # Source0-md5:  00b21551a899bcfbaa7b8443e1faeef9
10 Source1:        http://www.netlib.org/lapack/manpages-%{version}.tgz
11 # Source1-md5:  e5b46d8915f7cc8a1e50aa3e70c9f86e
12 Patch0:         %{name}-automake_support.patch
13 URL:            http://www.netlib.org/lapack/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gcc-fortran
17 BuildRequires:  libtool >= 2:1.5
18 Requires:       blas = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 # see http://www.netlib.org/lapack/faq.html#1.13
22 %define       rpmcflags -O0
23
24 %description
25 LAPACK (Linear Algebra PACKage) is a standard library for numerical
26 linear algebra. LAPACK provides routines for solving systems of
27 simultaneous linear equations, least-squares solutions of linear
28 systems of equations, eigenvalue problems, and singular value
29 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
30 Schur, and generalized Schur) and related computations (i.e.,
31 reordering of Schur factorizations and estimating condition numbers)
32 are also included. LAPACK can handle dense and banded matrices, but
33 not general sparse matrices. Similar functionality is provided for
34 real and complex matrices in both single and double precision. LAPACK
35 is coded in Fortran77.
36
37 %description -l pl.UTF-8
38 LAPACK (Linear Algebra PACKage) jest standardową biblioteką numeryczną
39 do algebry liniowej. Dostarcza funkcje rozwiązywania: układów równań
40 liniowych, układów równań metodą najmniejszych kwadratów, problemów
41 własnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
42 QR, SVD, Schura, uogólnioną Schura) i związanych z tym obliczeń (np.
43 przenumerowywanie w faktoryzacji Schura i estymację uwarunkowania).
44 LAPACK może obsługiwać macierze blokowe i pasmowe, ale nie rzadkie w
45 ogólnym przypadku. Zapewnia funkcjonalność dla macierzy rzeczywistych
46 i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
47 napisany w Fortranie 77.
48
49 %package devel
50 Summary:        LAPACK header files
51 Summary(pl.UTF-8):      Pliki nagłówkowe LAPACK
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       blas-devel = %{version}-%{release}
55 Obsoletes:      lapack-man
56
57 %description devel
58 LAPACK header files.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe LAPACK.
62
63 %package static
64 Summary:        Static LAPACK libraries
65 Summary(pl.UTF-8):      Biblioteki statyczne LAPACK
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static LAPACK libraries.
71
72 %description static -l pl.UTF-8
73 Biblioteki statyczne LAPACK.
74
75 %package -n blas
76 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
77 Summary(pl.UTF-8):      Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
78 Group:          Development/Libraries
79 Obsoletes:      lapack-blas
80
81 %description -n blas
82 BLAS (Basic Linear Algebra Subprograms) is a standard library for
83 numerical algebra. BLAS provides a number of basic algorithms for
84 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
85 77.
86
87 Warning: this is a reference implementation from Netlib. If possible,
88 use version optimized for your architecture instead.
89
90 %description -n blas -l pl.UTF-8
91 BLAS (Basic Linear Algebra Subprograms) jest standardową biblioteką
92 numeryczną algebry. Dostarcza wiele podstawowych algorytmów dla
93 algebry liniowej. Jest szybka i dobrze przetestowana, została napisana
94 w Fortranie 77.
95
96 Ostrzeżenie: to jest implementacja przykładowa z repozytorium Netlib.
97 Jeżeli to możliwe, należy używać zamiast niej wersji zoptymalizowanej
98 pod daną architekturę.
99
100 %package -n blas-devel
101 Summary:        BLAS header files
102 Summary(pl.UTF-8):      Pliki nagłówkowe BLAS
103 Group:          Development/Libraries
104 Requires:       blas = %{version}-%{release}
105 Obsoletes:      blas-man
106
107 %description -n blas-devel
108 BLAS header files.
109
110 %description -n blas-devel -l pl.UTF-8
111 Pliki nagłówkowe BLAS.
112
113 %package -n blas-static
114 Summary:        Static BLAS libraries
115 Summary(pl.UTF-8):      Biblioteki statyczne BLAS
116 Group:          Development/Libraries
117 Requires:       blas-devel = %{version}-%{release}
118
119 %description -n blas-static
120 Static BLAS libraries.
121
122 %description -n blas-static -l pl.UTF-8
123 Biblioteki statyczne BLAS.
124
125 %prep
126 %setup -q -a1
127 %patch0 -p1
128 # directory INSTALL conflicts with file INSTALL needed by automake
129 mv -f INSTALL install
130 # or maybe it should fail while trying to overwrite a file?
131 cp -f install/*.f SRC/
132
133 %build
134 %{__libtoolize}
135 %{__aclocal}
136 %{__autoheader}
137 %{__autoconf}
138 %{__automake}
139 %configure
140
141 %{__make} \
142         LTTAG="--tag=F77"
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 # present both in blas and lapack
151 rm -f man/manl/{lsame,xerbla}.l
152
153 install -d $RPM_BUILD_ROOT%{_mandir}/man3
154 for d in manpages/man/manl/*.l manpages/blas/man/manl/*.l ; do
155         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
156 done
157
158 echo "%defattr(644, root, root, 755)" > blasmans.list
159 find manpages/blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
160 echo "%defattr(644, root, root, 755)" > mans.list
161 find manpages/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
162
163 %clean
164 rm -fr $RPM_BUILD_ROOT
165
166 %post   -p /sbin/ldconfig
167 %postun -p /sbin/ldconfig
168
169 %post   -n blas -p /sbin/ldconfig
170 %postun -n blas -p /sbin/ldconfig
171
172 %files
173 %defattr(644,root,root,755)
174 %doc README
175 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
176
177 %files devel -f mans.list
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/liblapack.so
180 %{_libdir}/liblapack.la
181
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/liblapack.a
185
186 %files -n blas
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
189
190 %files -n blas-devel -f blasmans.list
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libblas.so
193 %{_libdir}/libblas.la
194
195 %files -n blas-static
196 %defattr(644,root,root,755)
197 %{_libdir}/libblas.a
This page took 0.104222 seconds and 4 git commands to generate.