]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
f6a32a02aeb55b7228425d7b4e6064724d2e781f
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra
2 Summary(pl):    Biblioteki numeryczne LAPACK do algebry liniowej
3 Name:           lapack
4 Version:        3.0
5 Release:        18
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/lapack/%{name}.tgz
9 # Source0-md5:  a24f59304f87b78cdc7da2ae59c98664
10 Source1:        http://www.netlib.org/lapack/manpages.tgz
11 # Source1-md5:  50efab6cd73a9429584f7f1537f1727f
12 Patch0:         %{name}-automake_support.patch
13 Patch1:         %{name}-20010525.patch
14 URL:            http://www.netlib.org/lapack/
15 BuildRequires:  gcc-g77
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool >= 1:1.4.2-9
19 Requires:       blas = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 LAPACK (Linear Algebra PACKage) is a standard library for numerical
24 linear algebra. LAPACK provides routines for solving systems of
25 simultaneous linear equations, least-squares solutions of linear
26 systems of equations, eigenvalue problems, and singular value
27 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
28 Schur, and generalized Schur) and related computations (i.e.,
29 reordering of Schur factorizations and estimating condition numbers)
30 are also included. LAPACK can handle dense and banded matrices, but
31 not general sparse matrices. Similar functionality is provided for
32 real and complex matrices in both single and double precision. LAPACK
33 is coded in Fortran77.
34
35 %description -l pl
36 LAPACK (Linear Algebra PACKage) jest standardow± bibliotek± numeryczn±
37 do algebry liniowej. Dostarcza funkcje rozwi±zywania: uk³adów równañ
38 liniowych, uk³adów równañ metod± najmniejszych kwadratów, problemów
39 w³asnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
40 QR, SVD, Schura, uogólnion± Schura) i zwi±zanych z tym obliczeñ (np.
41 przenumerowywanie w faktoryzacji Schura i estymacjê uwarunkowania).
42 LAPACK mo¿e obs³ugiwaæ macierze blokowe i pasmowe, ale nie rzadkie w
43 ogólnym przypadku. Zapewnia funkcjonalno¶æ dla macierzy rzeczywistych
44 i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
45 napisany w Fortranie 77.
46
47 %package devel
48 Summary:        LAPACK header files
49 Summary(pl):    Pliki nag³ówkowe LAPACK
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}
52 Requires:       blas-devel = %{version}
53 Obsoletes:      lapack-man
54
55 %description devel
56 LAPACK header files.
57
58 %description devel -l pl
59 Pliki nag³ówkowe LAPACK.
60
61 %package static
62 Summary:        Static LAPACK libraries
63 Summary(pl):    Biblioteki statyczne LAPACK
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}
66
67 %description static
68 Static LAPACK libraries.
69
70 %description static -l pl
71 Biblioteki statyczne LAPACK.
72
73 %package -n blas
74 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
75 Summary(pl):    Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
76 Group:          Development/Libraries
77 Obsoletes:      lapack-blas
78
79 %description -n blas
80 BLAS (Basic Linear Algebra Subprograms) is a standard library for
81 numerical algebra. BLAS provides a number of basic algorithms for
82 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
83 77.
84
85 %description -n blas -l pl
86 BLAS (Basic Linear Algebra Subprograms) jest standardow± bibliotek±
87 numeryczn± algebry. Dostarcza wiele podstawowych algorytmów dla
88 algebry liniowej. Jest szybka i dobrze przetestowana, zosta³a napisana
89 w Fortranie 77.
90
91 %package -n blas-devel
92 Summary:        BLAS header files
93 Summary(pl):    Pliki nag³ówkowe BLAS
94 Group:          Development/Libraries
95 Requires:       blas = %{version}
96 Obsoletes:      blas-man
97
98 %description -n blas-devel
99 BLAS header files.
100
101 %description -n blas-devel -l pl
102 Pliki nag³ówkowe BLAS.
103
104 %package -n blas-static
105 Summary:        Static BLAS libraries
106 Summary(pl):    Biblioteki statyczne BLAS
107 Group:          Development/Libraries
108 Requires:       blas-devel = %{version}
109
110 %description -n blas-static
111 Static BLAS libraries.
112
113 %description -n blas-static -l pl
114 Biblioteki statyczne BLAS.
115
116 %prep
117 %setup -q -a1 -n LAPACK
118 %patch0 -p1
119 %patch1 -p1
120 # directory INSTALL conflicts with file INSTALL needed by automake
121 mv -f INSTALL install
122
123 %build
124 rm -f ltmain.sh missing
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoheader}
128 %{__autoconf}
129 %{__automake}
130 %configure
131
132 # libtool 1.4d requires --tag for g77, libtool 1.4.2 fails when --tag is passed
133 LTTAG=""
134 grep -q -e '--tag' `which libtool` && LTTAG="--tag=F77"
135
136 %{__make} LTTAG="$LTTAG"
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install DESTDIR=$RPM_BUILD_ROOT
142
143 # present both in blas and lapack
144 rm -f man/manl/{lsame,xerbla}.l
145
146 install -d $RPM_BUILD_ROOT%{_mandir}/man3
147 for d in man/manl/*.l blas/man/manl/*.l ; do
148         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
149 done
150
151 echo "%defattr(644, root, root, 755)" > blasmans.list
152 find blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
153 echo "%defattr(644, root, root, 755)" > mans.list
154 find man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
155
156 %clean
157 rm -fr $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %post   -n blas -p /sbin/ldconfig
163 %postun -n blas -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc README
168 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
169
170 %files devel -f mans.list
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/liblapack.so
173 %{_libdir}/liblapack.la
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/liblapack.a
178
179 %files -n blas
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
182
183 %files -n blas-devel -f blasmans.list
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libblas.so
186 %{_libdir}/libblas.la
187
188 %files -n blas-static
189 %defattr(644,root,root,755)
190 %{_libdir}/libblas.a
This page took 0.096893 seconds and 3 git commands to generate.