]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
libtool 1.4b workarounds
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra.
2 Name:           lapack
3 Version:        3.0
4 Release:        2
5 Copyright:      Freely distributable
6 Group:          Development/Libraries
7 Group(fr):      Development/Librairies
8 Group(pl):      Programowanie/Biblioteki
9 Source0:        http://www.netlib.org/lapack/%{name}.tgz
10 Source1:        http://www.netlib.org/lapack/manpages.tgz
11 #Source2:       Makefile.blas
12 #Source3:       Makefile.lapack
13 Patch0:         %{name}-automake_support.patch
14 URL:            http://www.netlib.org/lapack/
15 BuildRequires:  gcc-g77
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17 Requires:       blas
18
19 %description
20 LAPACK (Linear Algebra PACKage) is a standard library for numerical
21 linear algebra. LAPACK provides routines for solving systems of
22 simultaneous linear equations, least-squares solutions of linear
23 systems of equations, eigenvalue problems, and singular value
24 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
25 Schur, and generalized Schur) and related computations (i.e.,
26 reordering of Schur factorizations and estimating condition numbers)
27 are also included. LAPACK can handle dense and banded matrices, but
28 not general sparse matrices. Similar functionality is provided for
29 real and complex matrices in both single and double precision. LAPACK
30 is coded in Fortran77 and is built with egcs.
31
32 %package devel
33 Summary:        %{name} header files
34 Summary(pl):    Pliki nag³ówkowe %{name}
35 Group:          Development/Libraries
36 Group(fr):      Development/Librairies
37 Group(pl):      Programowanie/Biblioteki
38 Requires:       %{name} = %{version}
39
40 %description devel
41 %{name} header files.
42
43 %description -l pl devel
44 Pliki nag³ówkowe %{name}.
45
46 %package static
47 Summary:        Static %{name} libraries
48 Summary(pl):    Biblioteki statyczne %{name}
49 Group:          Development/Libraries
50 Group(fr):      Development/Librairies
51 Group(pl):      Programowanie/Biblioteki
52 Requires:       %{name}-devel = %{version}
53
54 %description static
55 Static %{name} libraries.
56
57 %description -l pl static
58 Biblioteki statyczne %{name}.
59
60
61 %package -n blas
62 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux.
63 Group:          Development/Libraries
64 Group(fr):      Development/Librairies
65 Group(pl):      Programowanie/Biblioteki
66 Obsoletes:      lapack-blas
67
68 %description -n blas
69 BLAS (Basic Linear Algebra Subprograms) is a standard library for
70 numerical algebra. BLAS provides a number of basic algorithms for
71 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
72 77 and build with egcs. BLAS manual pages are available in the
73 blas-man package.
74
75 %package -n blas-devel
76 Summary:        %{name} header files
77 Summary(pl):    Pliki nag³ówkowe %{name}
78 Group:          Development/Libraries
79 Group(fr):      Development/Librairies
80 Group(pl):      Programowanie/Biblioteki
81 Requires:       blas = %{version}
82
83 %description -n blas-devel
84 %{name} header files.
85
86 %description -l pl -n blas-devel
87 Pliki nag³ówkowe %{name}.
88
89 %package -n blas-static
90 Summary:        Static %{name} libraries
91 Summary(pl):    Biblioteki statyczne %{name}
92 Group:          Development/Libraries
93 Group(fr):      Development/Librairies
94 Group(pl):      Programowanie/Biblioteki
95 Requires:       blas-devel = %{version}
96
97 %description -n blas-static
98 Static %{name} libraries.
99
100 %description -l pl -n blas-static
101 Biblioteki statyczne %{name}.
102
103 %package -n blas-man
104 Summary:        Man pages for BLAS (Basic Linear Algebra Subprograms) routines.
105 Group:          Documentation
106 Group(pl):      Dokumentacja
107 Obsoletes:      lapack-blas-man
108
109 %description -n blas-man
110 The blas-man package contains documentation for BLAS (Basic Linear
111 Algebra Subprograms) routines, in the form of man pages.
112
113 %package man
114 Summary:        Documentation for the LAPACK numerical linear algebra libraries.
115 Group:          Documentation
116 Group(pl):      Dokumentacja
117
118 %description man
119 Documentation, in the form of man pages, for the LAPACK numerical
120 linear algebra libraries.
121
122
123 %prep
124 %setup -q -a1 -n LAPACK
125 %patch0 -p1
126 # directory INSTALL conflicts with file INSTALL needed by automake
127 mv -f INSTALL install
128 >INSTALL
129 >AUTHORS
130 >ChangeLog
131 >NEWS
132 >COPYING
133 #>config.h.in
134
135 %build
136 rm -f ltmain.sh
137 libtoolize --copy --force
138 aclocal
139 autoheader
140 automake --add-missing
141 autoconf
142 %configure 
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 #workaround libtool
148 ed SRC/liblapack.la <<EOF
149 s/relink_command=.*/relink_command=''/
150 w
151 q
152 EOF
153 %{__make} install DESTDIR=$RPM_BUILD_ROOT
154
155 install -d $RPM_BUILD_ROOT%{_mandir}/manl
156 gzip -9nf blas/man/manl/*.l man/manl/*.l
157 install blas/man/manl/* man/manl/* $RPM_BUILD_ROOT%{_mandir}/manl
158
159 echo "%defattr(644, root, root, 755)" > blasmans.list
160 find blas/man/manl -name "*.gz" -printf "%{_mandir}/manl/%%f\n" >> blasmans.list
161 echo "%defattr(644, root, root, 755)" > mans.list
162 find man/manl -name "*.gz" -printf "%{_mandir}/manl/%%f\n" >> mans.list
163
164 gzip -9nf README
165
166 %post           -p /sbin/ldconfig
167 %postun         -p /sbin/ldconfig
168 %post   -n blas -p /sbin/ldconfig
169 %postun -n blas -p /sbin/ldconfig
170
171 %clean
172 rm -fr $RPM_BUILD_ROOT
173
174
175 %files
176 %defattr(644,root,root,755)
177 %doc README*
178 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
179
180 %files devel
181 %defattr(644,root,root,755)
182 %{_libdir}/liblapack.so
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/liblapack.a
187
188 %files -n blas 
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
191
192 %files -n blas-devel
193 %defattr(644,root,root,755)
194 %{_libdir}/libblas.so
195
196 %files -n blas-static
197 %defattr(644,root,root,755)
198 %{_libdir}/libblas.a
199
200
201 %files -n blas-man -f blasmans.list
202 %defattr(644,root,root,755)
203
204 %files man -f mans.list
205 %defattr(644,root,root,755)
This page took 0.044675 seconds and 3 git commands to generate.