]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
378c17a140c20a16f95292c7fb23a3898955ec84
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra
2 Summary(pl):    Biblioteki numeryczne LAPACK do algebry liniowej
3 Name:           lapack
4 Version:        3.0
5 Release:        14
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/lapack/%{name}.tgz
9 Source1:        http://www.netlib.org/lapack/manpages.tgz
10 Patch0:         %{name}-automake_support.patch
11 Patch1:         %{name}-20010525.patch
12 URL:            http://www.netlib.org/lapack/
13 BuildRequires:  gcc-g77
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  ed
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Requires:       blas = %{version}
20
21 %description
22 LAPACK (Linear Algebra PACKage) is a standard library for numerical
23 linear algebra. LAPACK provides routines for solving systems of
24 simultaneous linear equations, least-squares solutions of linear
25 systems of equations, eigenvalue problems, and singular value
26 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
27 Schur, and generalized Schur) and related computations (i.e.,
28 reordering of Schur factorizations and estimating condition numbers)
29 are also included. LAPACK can handle dense and banded matrices, but
30 not general sparse matrices. Similar functionality is provided for
31 real and complex matrices in both single and double precision. LAPACK
32 is coded in Fortran77.
33
34 %description -l pl
35 LAPACK (Linear Algebra PACKage) jest standardow± bibliotek± numeryczn±
36 do algebry liniowej. Dostarcza funkcje rozwi±zywania: uk³adów równañ
37 liniowych, uk³adów równañ metod± najmniejszych kwadratów, problemów
38 w³asnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
39 QR, SVD, Schura, uogólnion± Schura) i zwi±zanych z tym obliczeñ (np.
40 przenumerowywanie w faktoryzacji Schura i estymacjê uwarunkowania).
41 LAPACK mo¿e obs³ugiwaæ macierze blokowe i pasmowe, ale nie rzadkie w
42 ogólnym przypadku. Zapewnia funkcjonalno¶æ dla macierzy rzeczywistych
43 i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
44 napisany w Fortranie 77.
45
46 %package devel
47 Summary:        LAPACK header files
48 Summary(pl):    Pliki nag³ówkowe LAPACK
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}
51 Requires:       blas-devel = %{version}
52 Obsoletes:      lapack-man
53
54 %description devel
55 LAPACK header files.
56
57 %description devel -l pl
58 Pliki nag³ówkowe LAPACK.
59
60 %package static
61 Summary:        Static LAPACK libraries
62 Summary(pl):    Biblioteki statyczne LAPACK
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}
65
66 %description static
67 Static LAPACK libraries.
68
69 %description static -l pl
70 Biblioteki statyczne LAPACK.
71
72 %package -n blas
73 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
74 Summary(pl):    Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
75 Group:          Development/Libraries
76 Obsoletes:      lapack-blas
77
78 %description -n blas
79 BLAS (Basic Linear Algebra Subprograms) is a standard library for
80 numerical algebra. BLAS provides a number of basic algorithms for
81 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
82 77.
83
84 %description -n blas -l pl
85 BLAS (Basic Linear Algebra Subprograms) jest standardow± bibliotek±
86 numeryczn± algebry. Dostarcza wiele podstawowych algorytmów dla
87 algebry liniowej. Jest szybka i dobrze przetestowana, zosta³a napisana
88 w Fortranie 77.
89
90 %package -n blas-devel
91 Summary:        BLAS header files
92 Summary(pl):    Pliki nag³ówkowe BLAS
93 Group:          Development/Libraries
94 Requires:       blas = %{version}
95 Obsoletes:      blas-man
96
97 %description -n blas-devel
98 BLAS header files.
99
100 %description -n blas-devel -l pl
101 Pliki nag³ówkowe BLAS.
102
103 %package -n blas-static
104 Summary:        Static BLAS libraries
105 Summary(pl):    Biblioteki statyczne BLAS
106 Group:          Development/Libraries
107 Requires:       blas-devel = %{version}
108
109 %description -n blas-static
110 Static BLAS libraries.
111
112 %description -n blas-static -l pl
113 Biblioteki statyczne BLAS.
114
115 %prep
116 %setup -q -a1 -n LAPACK
117 %patch0 -p1
118 %patch1 -p1
119 # directory INSTALL conflicts with file INSTALL needed by automake
120 mv -f INSTALL install
121
122 %build
123 rm -f ltmain.sh
124 %{__libtoolize}
125 aclocal
126 autoheader
127 %{__autoconf}
128 %{__automake}
129 %configure
130
131 # libtool 1.4d requires --tag for g77, libtool 1.4.2 fails when --tag is passed
132 LTTAG=""
133 grep -q -e '--tag' `which libtool` && LTTAG="--tag=F77"
134
135 %{__make} LTTAG="$LTTAG"
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 #workaround libtool
140 ed SRC/liblapack.la <<EOF
141 s/relink_command=.*/relink_command=''/
142 w
143 q
144 EOF
145 %{__make} install DESTDIR=$RPM_BUILD_ROOT
146
147 # present both in blas and lapack
148 rm -f man/manl/{lsame,xerbla}.l
149
150 install -d $RPM_BUILD_ROOT%{_mandir}/man3
151 for d in man/manl/*.l blas/man/manl/*.l ; do
152         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
153 done
154
155 echo "%defattr(644, root, root, 755)" > blasmans.list
156 find blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
157 echo "%defattr(644, root, root, 755)" > mans.list
158 find man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
159
160 %clean
161 rm -fr $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %post   -n blas -p /sbin/ldconfig
167 %postun -n blas -p /sbin/ldconfig
168
169 %files
170 %defattr(644,root,root,755)
171 %doc README
172 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
173
174 %files devel -f mans.list
175 %defattr(644,root,root,755)
176 %{_libdir}/liblapack.so
177
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/liblapack.a
181
182 %files -n blas
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
185
186 %files -n blas-devel -f blasmans.list
187 %defattr(644,root,root,755)
188 %{_libdir}/libblas.so
189
190 %files -n blas-static
191 %defattr(644,root,root,755)
192 %{_libdir}/libblas.a
This page took 0.062155 seconds and 3 git commands to generate.