]> git.pld-linux.org Git - SPECS.git/blob - lam.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / lam.spec
1 Summary:        LAM/MPI (Local Area Multicomputer) programming environment
2 Summary(es.UTF-8):      LAM MPI
3 Summary(pl.UTF-8):      Środowisko programistyczne LAM/MPI
4 Summary(pt_BR.UTF-8):   LAM MPI
5 Name:           lam
6 Version:        7.1.3
7 Release:        7
8 Epoch:          2
9 License:        BSD
10 Group:          Development/Libraries
11 Source0:        http://www.lam-mpi.org/download/files/%{name}-%{version}.tar.bz2
12 # Source0-md5:  dccca92409654f4f822b1d343ca75be6
13 Patch0:         %{name}-m4.patch
14 Patch1:         %{name}-install.patch
15 URL:            http://www.lam-mpi.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gcc-fortran
19 BuildRequires:  libtool
20 Provides:       mpi
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 LAM (Local Area Multicomputer) is an MPI programming environment and
25 development system for heterogeneous computers on a network. With
26 LAM/MPI, a dedicated cluster or an existing network computing
27 infrastructure can act as a single parallel computer. LAM/MPI is
28 considered to be "cluster friendly", in that it offers daemon-based
29 process startup/control as well as fast client-to-client message
30 passing protocols. LAM/MPI can use TCP/IP and/or shared memory for
31 message passing.
32
33 LAM features a full implementation of MPI-1 (with the exception that
34 LAM does not support cancelling of sends), and much of MPI-2.
35 Compliant applications are source code portable between LAM/MPI and
36 any other implementation of MPI. In addition to providing a
37 high-quality implementation of the MPI standard, LAM/MPI offers
38 extensive monitoring capabilities to support debugging. Monitoring
39 happens on two levels. First, LAM/MPI has the hooks to allow a
40 snapshot of process and message status to be taken at any time during
41 an application run. This snapshot includes all aspects of
42 synchronization plus datatype maps/signatures, communicator group
43 membership, and message contents (see the XMPI application on the main
44 LAM web site). On the second level, the MPI library is instrumented to
45 produce a cummulative record of communication, which can be visualized
46 either at runtime or post-mortem.
47
48 %description -l es.UTF-8
49 LAM (Local Area Multicomputer) es un ambiente de desarrollo MPI para
50 computadores heterogéneos en una red. Con LAM, un cluster permanente o
51 una red ya existente pueden servir como un computador paralelo.
52
53 LAM tiene entre sus ventajas el soporte extensivo a la depuración
54 durante el ciclo de desarrollo de los aplicativos y un óptimo
55 desarrollo en el ambiente de ejecución. LAM implementa completamente
56 el patrón MPI.
57
58 %description -l pl.UTF-8
59 LAM (Local Area Multicomputer) jest środowiskiem programistycznym MPI
60 dla heterogenicznych komputerów w sieci. Z użyciem LAM/MPI dedykowany
61 klaster lub istniejąca infrastruktura obliczająca może się zachowywać
62 jak pojedynczy, równoległy komputer. LAM/MPI jest uważana za
63 "przyjazne dla klastrów" - oferuje bazującą na demonie kontrolę i
64 uruchamianie procesów oraz protokoły szybkiego przesyłania
65 komunikatów. LAM/MPI może używać TCP/IP lub dzielonej pamięci do
66 przesyłania komunikatów.
67
68 Możliwości LAM to pełna implementacja MPI-1 (z wyjątkiem tego, że LAM
69 nie obsługuje anulowania wysyłania) i dużej części MPI-2. Kompatybilne
70 aplikacje są przenośne na poziomie źródeł pomiędzy LAM/MPI i innymi
71 implementacjami standardu MPI. Oprócz implementacji standardu, LAM/MPI
72 oferuje rozszerzone możliwości monitorowania na potrzeby
73 odpluskwiania. Monitorowanie występuje na dwóch poziomach. Po
74 pierwsze, LAM/MPI pozwala na zrzut procesu i stanu komunikatu w
75 dowolnej chwili. Ten zrzut zawiera wszystko, co związane z
76 synchronizacją, plus mapy/sygnatury typów danych, członkowstwo w
77 grupach komunikacyjnych i zawartości komunikatów. Po drugie,
78 biblioteka MPI może zapisywać całą komunikację, która może być
79 wizualizowana na bieżąco lub post-mortem.
80
81 %description -l pt_BR.UTF-8
82 LAM (Local Area Multicomputer) é um ambiente de desenvolvimento MPI
83 para computadores heterogêneos em uma rede. Com LAM, um cluster
84 dedicado ou uma rede já existentes podem servir como um computador
85 paralelo.
86
87 LAM tem como vantagens o suporte extensivo a depuração durante o ciclo
88 de desenvolvimento dos aplicativos e ótima performance em ambiente de
89 execução. LAM implementa totalmente o padrão MPI.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95
96 # Rename the ROMIO doc files so that we can install them in the same
97 # doc root later, and not overwrite LAM's doc files.
98 for file in README README_LAM COPYRIGHT; do
99         mv romio/$file romio/romio-$file
100 done
101 mv romio/doc/users-guide.ps.gz romio/doc/romio-users-guide.ps.gz
102
103 %build
104 chmod -R u+w .
105 touch config/lam_check_fd_setsize.m4
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__automake}
110 for i in $(find -name config.sub); do
111         cp -f /usr/share/automake/config.sub $i
112 done
113
114 %configure \
115         --with-pic \
116         --with-rpi \
117         --with-rsh="%{_bindir}/ssh -x" \
118         --with-fc=gfortran
119
120 %{__make} all
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
129 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
130
131 mv $RPM_BUILD_ROOT%{_mandir}/man{s,7}/mpi.share*
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %doc LICENSE HISTORY INSTALL README
139 %doc doc/*.pdf romio/doc/* romio/romio-{README*,COPYRIGHT}
140 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lam-bhost.def
141 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lam-conf.lamd
142 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lam-helpfile
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lam-hostmap.txt
144 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lam-ssi-boot-globus-helpfile
145 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lam-ssi-boot-slurm-helpfile
146 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lam-ssi-crlam-self-helpfile
147 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lam-ssi-crmpi-self-helpfile
148 %attr(755,root,root) %{_bindir}/*
149 %{_mandir}/man[1357]/*
150 %{_libdir}/liblam.a
151 %{_libdir}/liblamf77mpi.a
152 %{_libdir}/liblammpi++.a
153 %{_libdir}/libmpi.a
154 %{_libdir}/liblam.la
155 %{_libdir}/liblamf77mpi.la
156 %{_libdir}/liblammpi++.la
157 %{_libdir}/libmpi.la
158 # not libtool lib
159 %{_libdir}/liblammpio.a
160 %{_libdir}/lam
161 %{_includedir}/lam_config*.h
162 %{_includedir}/mpi*.h
163 %{_includedir}/mpi2cxx
164 %{_examplesdir}/%{name}-%{version}
This page took 0.1337 seconds and 3 git commands to generate.