]> git.pld-linux.org Git - SPECS.git/blob - ladspa.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ladspa.spec
1 Summary:        LADSPA SDK example plugins
2 Summary(pl.UTF-8):      Przykładowe wtyczki z LADSPA SDK
3 Name:           ladspa
4 Version:        1.15
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://www.ladspa.org/download/%{name}_sdk_%{version}.tgz
9 # Source0-md5:  5824922ad4ae6aeb2910d302191e7afd
10 URL:            http://www.ladspa.org/
11 BuildRequires:  libstdc++-devel
12 BuildRequires:  sed >= 4.0
13 Requires:       %{name}-common = %{version}-%{release}
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _noautoprovfiles        %{_libdir}/ladspa
17
18 %description
19 There is a large number of synthesis packages in use or development on
20 the Linux platform at this time. The Linux Audio Developer's Simple
21 Plugin API (LADSPA) attempts to give programmers the ability to write
22 simple `plugin' audio processors in C/C++ and link them dynamically
23 against a range of host applications.
24
25 This package contains the example plugins from the LADSPA SDK.
26
27 %description -l pl.UTF-8
28 Istnieje wiele pakietów do syntezy używanych lub rozwijanych na
29 platformie linuksowej. LADSPA (Linux Audio Developer's Simple Plugin
30 API - proste API wtyczek dla programistów dźwięku pod Linuksem) to
31 próba udostępnienia programistom możliwości pisania prostych "wtyczek"
32 procesorów dźwięku w C/C++ i ich dynamicznej konsolidacji z wieloma
33 aplikacjami.
34
35 Ten pakiet zawiera przykładowe wtyczki z LADSPA SDK.
36
37 %package common
38 Summary:        Common environment for LADSPA plugins
39 Summary(pl.UTF-8):      Środowisko wspólne dla wtyczek LADSPA
40 Group:          Libraries
41
42 %description common
43 Common environment for LADSPA plugins. Currently it contains only
44 appropriate directory trees.
45
46 %description common -l pl.UTF-8
47 Środowisko wspólne dla wtyczek LADSPA. Aktualnie zawiera tylko
48 odpowiednie drzewa katalogów.
49
50 %package devel
51 Summary:        Linux Audio Developer's Simple Plugin API
52 Summary(pl.UTF-8):      Pakiet programistyczny LADSPA (Linux Audio Developer's Simple Plugin API)
53 Group:          Development/Libraries
54 # doesn't require base or common
55
56 %description devel
57 There is a large number of synthesis packages in use or development on
58 the Linux platform at this time. The Linux Audio Developer's Simple
59 Plugin API (LADSPA) attempts to give programmers the ability to write
60 simple `plugin' audio processors in C/C++ and link them dynamically
61 against a range of host applications.
62
63 Definitive technical documentation on LADSPA plugins for both the host
64 and plugin is contained within copious comments within the ladspa.h
65 header file.
66
67 %description devel -l pl.UTF-8
68 Istnieje wiele pakietów do syntezy używanych lub rozwijanych na
69 platformie linuksowej. LADSPA (Linux Audio Developer's Simple Plugin
70 API - proste API wtyczek dla programistów dźwięku pod Linuksem) to
71 próba udostępnienia programistom możliwości pisania prostych "wtyczek"
72 procesorów dźwięku w C/C++ i ich dynamicznej konsolidacji z wieloma
73 aplikacjami.
74
75 Techniczna dokumentacja do wtyczek LADSPA dotycząca zarówno samych
76 wtyczek jak i korzystania z nich w programach znajduje się w
77 komentarzach pliku nagłówkowego ladspa.h.
78
79 %prep
80 %setup -q -n %{name}_sdk_%{version}
81
82 %{__sed} -i -e 's!HREF="ladspa\.h\.txt"!HREF="file:///usr/include/ladpsa.h"!' doc/*.html
83
84 %build
85 %{__make} -C src targets \
86         CC="%{__cc}" \
87         CPP="%{__cxx}" \
88         CFLAGS="-I. -Wall -Werror %{rpmcflags} %{rpmcppflags} -fPIC -DDEFAULT_LADSPA_PATH=%{_libdir}/ladspa" \
89         CXXFLAGS="-I. -Wall -Werror %{rpmcxxflags} %{rpmcppflags} -fPIC -DDEFAULT_LADSPA_PATH=%{_libdir}/ladspa"
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_datadir}/ladspa/rdf
94
95 %{__make} -C src install \
96         INSTALL_PLUGINS_DIR=$RPM_BUILD_ROOT%{_libdir}/ladspa \
97         INSTALL_INCLUDE_DIR=$RPM_BUILD_ROOT%{_includedir} \
98         INSTALL_BINARY_DIR=$RPM_BUILD_ROOT%{_bindir}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/analyseplugin
106 %attr(755,root,root) %{_bindir}/applyplugin
107 %attr(755,root,root) %{_bindir}/listplugins
108 %attr(755,root,root) %{_libdir}/ladspa/amp.so
109 %attr(755,root,root) %{_libdir}/ladspa/delay.so
110 %attr(755,root,root) %{_libdir}/ladspa/filter.so
111 %attr(755,root,root) %{_libdir}/ladspa/noise.so
112 %attr(755,root,root) %{_libdir}/ladspa/sine.so
113
114 %files common
115 %defattr(644,root,root,755)
116 %dir %{_libdir}/ladspa
117 %dir %{_datadir}/ladspa
118 %dir %{_datadir}/ladspa/rdf
119
120 %files devel
121 %defattr(644,root,root,755)
122 %doc doc/*.html
123 %{_includedir}/ladspa.h
This page took 0.041578 seconds and 3 git commands to generate.