]> git.pld-linux.org Git - SPECS.git/blob - krecipes.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / krecipes.spec
1 #
2 # Conditional build:
3 %bcond_without  sqlite  # SQLite support
4 %bcond_with     mysql   # MySQL support
5 %bcond_with     pgsql   # PostgreSQL support
6 #
7 Summary:        KDE Recipe Tool
8 Summary(pl.UTF-8):      Zarządzanie przepisami w KDE
9 Name:           krecipes
10 Version:        0.9.1
11 Release:        0.1
12 License:        GPL v2+
13 Group:          X11/Applications
14 Source0:        http://downloads.sourceforge.net/krecipes/%{name}-%{version}.tar.gz
15 # Source0-md5:  7414fd5210561801ba04ee3dad6561d9
16 URL:            http://krecipes.sourceforge.net/
17 BuildRequires:  kdelibs-devel >= 3.1
18 %{?with_mysql:BuildRequires:    mysql-devel}
19 %{?with_pgsql:BuildRequires:    postgresql-devel}
20 %{?with_sqlite:BuildRequires:   sqlite3-devel >= 3}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The goal of this projects was to create a KDE Recipe Tool that:
25  - Can manage a recipe database with an easy to use interface
26  - Allows creation/removal of new ingredients and units
27  - Helps with diets, calculating amount of calories, vitamines,
28    carbohydrates... per recipe
29  - Creates shopping lists, and daily suggestions for a given diet type
30  - Is based on MySQL so it could be possible to generate a KSN
31  - Should be as flexible as possible to have the possibility to extend
32    it in future.
33
34 %description -l pl.UTF-8
35 Celem tego projektu było stworzenie programu KDE do przepisów, który:
36  - potrafi zarządzać bazą danych przepisów z łatwym w użyciu
37    interfejsem
38  - pozwala tworzyć i usuwać nowe składniki i jednostki
39  - pomaga przy dietach, obliczaniu ilości kalorii, witamin,
40    węglowodanów itp. dla każdego przepisu
41  - tworzy listy zakupów i codzienne sugestie dla zadanego rodzaju
42    diety
43  - jest oparty na MySQL-u, dzięki czmu można generować KSN
44  - powinien być elastyczny i mieć możliwość rozszerzania w
45    przyszłości.
46
47 %prep
48 %setup -q
49
50 %build
51 %configure \
52         --enable-pch \
53         --with%{!?with_sqlite:out}-sqlite \
54         --with%{!?with_mysql:out}-mysql \
55         --with%{!?with_pgsql:out}-postgresql \
56
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT \
64         appsdir=%{_desktopdir}/kde \
65         k3bsetup2dir=%{_desktopdir}/kde \
66         kde_htmldir=%{_kdedocdir}
67
68 %{__mv} $RPM_BUILD_ROOT%{_datadir}/applnk/Utilities $RPM_BUILD_ROOT%{_datadir}/applnk/.hidden
69
70 %find_lang %{name} --all-name --with-kde
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files -f %{name}.lang
76 %defattr(644,root,root,755)
77 %doc ChangeLog AUTHORS README TODO
78 %attr(755,root,root) %{_bindir}/%{name}
79 %{_datadir}/applnk/.hidden/*.desktop
80 %dir %{_datadir}/apps/krecipes
81 %{_datadir}/apps/krecipes/data
82 %{_datadir}/apps/krecipes/icons
83 %{_datadir}/apps/krecipes/layouts
84 %{_datadir}/apps/krecipes/pics
85 %{_datadir}/apps/krecipes/*.rc
86 %{_datadir}/mimelnk/application/*.desktop
87 %{_iconsdir}/*/*/mimetypes/*
88 %{_iconsdir}/*/*/apps/*
This page took 0.125138 seconds and 3 git commands to generate.