]> git.pld-linux.org Git - SPECS.git/blob - kp6-plymouth-kcm.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / kp6-plymouth-kcm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    6.0.4
5 %define         qtver           5.15.2
6 %define         kpname          plymouth-kcm
7
8 Summary:        KDE Config Module for Plyouth
9 Name:           kp6-%{kpname}
10 Version:        6.0.4
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  ee92c60d4e715862308e258bacb2de3e
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt6Core-devel >= 5.15.0
18 BuildRequires:  Qt6Gui-devel >= 5.15.0
19 BuildRequires:  Qt6Network-devel >= 5.15.0
20 BuildRequires:  Qt6Qml-devel >= 5.15.2
21 BuildRequires:  Qt6Quick-devel >= 5.15.0
22 BuildRequires:  cmake >= 3.16.0
23 BuildRequires:  gettext-devel
24 BuildRequires:  kf6-extra-cmake-modules >= 5.82
25 BuildRequires:  kf6-karchive-devel >= 5.82
26 BuildRequires:  kf6-kconfig-devel >= 5.82
27 BuildRequires:  kf6-kdeclarative-devel >= 5.82
28 BuildRequires:  kf6-ki18n-devel >= 5.82
29 BuildRequires:  kf6-kio-devel >= 5.82
30 BuildRequires:  kf6-knewstuff-devel >= 5.82
31 BuildRequires:  ninja
32 BuildRequires:  plymouth-devel
33 BuildRequires:  rpmbuild(macros) >= 1.164
34 BuildRequires:  xz
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         qt6dir          %{_libdir}/qt6
38
39 %description
40 KDE Config Module for Plymouth.
41
42 %prep
43 %setup -q -n %{kpname}-%{version}
44
45 %build
46 %cmake -B build \
47         -G Ninja \
48         %{!?with_tests:-DBUILD_TESTING=OFF} \
49         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
50         -DKDE_INSTALL_DOCBUNDLEDIR=%{_kdedocdir}
51 %ninja_build -C build
52
53 %if %{with tests}
54 ctest
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %ninja_install -C build
60
61 %find_lang %{kpname} --all-name --with-kde
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post   -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files -f %{kpname}.lang
70 %defattr(644,root,root,755)
71 %attr(755,root,root) %{_bindir}/kplymouththemeinstaller
72 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmplymouth.service
73 %{_datadir}/dbus-1/system.d/org.kde.kcontrol.kcmplymouth.conf
74 %{_datadir}/knsrcfiles/plymouth.knsrc
75 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmplymouth.policy
76 %attr(755,root,root) %{_libdir}/qt6/plugins/plasma/kcms/systemsettings/kcm_plymouth.so
77 %{_desktopdir}/kcm_plymouth.desktop
78 %attr(755,root,root) %{_prefix}/libexec/kf6/kauth/plymouthhelper
This page took 1.203752 seconds and 3 git commands to generate.