]> git.pld-linux.org Git - SPECS.git/blob - kp6-ksshaskpass.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / kp6-ksshaskpass.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    6.0.4
5 %define         qtver           5.15.2
6 %define         kpname          ksshaskpass
7 Summary:        ssh-add helper that uses kwallet and kpassworddialog
8 Name:           kp6-%{kpname}
9 Version:        6.0.4
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  65cf2132c657083562fd9afb19a70035
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt6Core-devel >= %{qtver}
17 BuildRequires:  cmake >= 3.16.0
18 BuildRequires:  kf6-extra-cmake-modules >= 1.4.0
19 BuildRequires:  kf6-kcoreaddons-devel
20 BuildRequires:  kf6-ki18n-devel
21 BuildRequires:  kf6-kwallet-devel
22 BuildRequires:  kf6-kwidgetsaddons-devel
23 BuildRequires:  ninja
24 BuildRequires:  qt6-build >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Ssh-add helper that uses kwallet and kpassworddialog.
32
33 %prep
34 %setup -q -n %{kpname}-%{version}
35
36 %build
37 %cmake -B build \
38         -G Ninja \
39         %{!?with_tests:-DBUILD_TESTING=OFF} \
40         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
41         -DKDE_INSTALL_DOCBUNDLEDIR=%{_kdedocdir}
42 %ninja_build -C build
43
44 %if %{with tests}
45 ctest
46 %endif
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %ninja_install -C build
51
52 %find_lang %{kpname} --all-name --with-kde
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post   -p /sbin/ldconfig
58 %postun -p /sbin/ldconfig
59
60 %files -f %{kpname}.lang
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_bindir}/ksshaskpass
63 %{_mandir}/man1/ksshaskpass.1*
64
This page took 0.188949 seconds and 3 git commands to generate.