]> git.pld-linux.org Git - SPECS.git/blob - kp5-plasma-browser-integration.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / kp5-plasma-browser-integration.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.27.11
5 %define         qtver           5.15.2
6 %define         kpname          plasma-browser-integration
7
8 Summary:        KDE Plasma Browser Integration
9 Name:           kp5-%{kpname}
10 Version:        5.27.11
11 Release:        2
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  a8aa7c1ecb2b16e1851aaf20e503108c
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5DBus-devel
19 BuildRequires:  Qt5Gui-devel
20 BuildRequires:  Qt5Widgets-devel
21 BuildRequires:  cmake >= 3.16.0
22 BuildRequires:  gettext-devel
23 BuildRequires:  kf5-extra-cmake-modules
24 BuildRequires:  kf5-kactivities-devel
25 BuildRequires:  kf5-kauth-devel
26 BuildRequires:  kf5-kcodecs-devel
27 BuildRequires:  kf5-kcompletion-devel
28 BuildRequires:  kf5-kconfigwidgets-devel
29 BuildRequires:  kf5-kcoreaddons-devel
30 BuildRequires:  kf5-kcrash-devel
31 BuildRequires:  kf5-kdbusaddons-devel
32 BuildRequires:  kf5-kfilemetadata-devel
33 BuildRequires:  kf5-ki18n-devel
34 BuildRequires:  kf5-kio-devel
35 BuildRequires:  kf5-kitemviews-devel
36 BuildRequires:  kf5-kjobwidgets-devel
37 BuildRequires:  kf5-knotifications-devel
38 BuildRequires:  kf5-kpackage-devel
39 BuildRequires:  kf5-krunner-devel
40 BuildRequires:  kf5-kservice-devel
41 BuildRequires:  kf5-kwidgetsaddons-devel
42 BuildRequires:  kf5-kwindowsystem-devel
43 BuildRequires:  kf5-kxmlgui-devel
44 BuildRequires:  kf5-plasma-framework-devel
45 BuildRequires:  kf5-purpose-devel
46 BuildRequires:  kf5-solid-devel
47 BuildRequires:  kp5-plasma-workspace-devel >= %{kdeplasmaver}
48 BuildRequires:  ninja
49 BuildRequires:  rpmbuild(macros) >= 1.164
50 BuildRequires:  xz
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         qt5dir          %{_libdir}/qt5
54
55 %description
56 KDE Plasma Browser Integration.
57
58 %prep
59 %setup -q -n %{kpname}-%{version}
60
61 %build
62 %cmake -B build \
63         -G Ninja \
64         %{!?with_tests:-DBUILD_TESTING=OFF} \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         -DHTML_INSTALL_DIR=%{_kdedocdir}
67 %ninja_build -C build
68
69 %if %{with tests}
70 ctest
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %ninja_install -C build
76
77 %find_lang %{kpname} --all-name --with-kde
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files -f %{kpname}.lang
83 %defattr(644,root,root,755)
84 %dir %{_sysconfdir}/chromium
85 %dir %{_sysconfdir}/chromium/native-messaging-hosts
86 %{_sysconfdir}/chromium/native-messaging-hosts/org.kde.plasma.browser_integration.json
87 %dir %{_sysconfdir}/opt/chrome
88 %dir %{_sysconfdir}/opt/chrome/native-messaging-hosts
89 %{_sysconfdir}/opt/chrome/native-messaging-hosts/org.kde.plasma.browser_integration.json
90 %attr(755,root,root) %{_bindir}/plasma-browser-integration-host
91 %dir %{_prefix}/lib/mozilla
92 %dir %{_prefix}/lib/mozilla/native-messaging-hosts
93 %{_prefix}/lib/mozilla/native-messaging-hosts/org.kde.plasma.browser_integration.json
94 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/browserintegrationreminder.so
95 %dir %{_sysconfdir}/opt/edge
96 %dir %{_sysconfdir}/opt/edge/native-messaging-hosts
97 %{_sysconfdir}/opt/edge/native-messaging-hosts/org.kde.plasma.browser_integration.json
98 %{_datadir}/krunner/dbusplugins/plasma-runner-browserhistory.desktop
99 %{_datadir}/krunner/dbusplugins/plasma-runner-browsertabs.desktop
100 %{_desktopdir}/org.kde.plasma.browser_integration.host.desktop
This page took 1.090794 seconds and 3 git commands to generate.