]> git.pld-linux.org Git - packages/kp5-kwrited.git/blob - kp5-kwrited.spec
- 5.93.0
[packages/kp5-kwrited.git] / kp5-kwrited.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.93.0
5 %define         qtver           5.15.2
6 %define         kpname          kwrited
7 Summary:        kwrited
8 Name:           kp5-%{kpname}
9 Version:        5.93.0
10 Release:        0.1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          Base
13 Source0:        https://download.kde.org/unstable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  2c13aed7782dc3efe2846f80032e4a98
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt6Core-devel
17 BuildRequires:  Qt6Gui-devel >= %{qtver}
18 BuildRequires:  Qt6Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 3.16.0
20 BuildRequires:  gettext-devel
21 BuildRequires:  kf6-extra-cmake-modules >= 1.4.0
22 BuildRequires:  kf6-kcoreaddons-devel
23 BuildRequires:  kf6-kdbusaddons-devel
24 BuildRequires:  kf6-ki18n-devel
25 BuildRequires:  kf6-knotifications-devel
26 BuildRequires:  kf6-kpty-devel
27 BuildRequires:  ninja
28 BuildRequires:  qt6-build >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 KDE Plasma daemon listening for wall and write messages.
36
37 %prep
38 %setup -q -n %{kpname}-%{version}
39
40 %build
41 %cmake -B build \
42         -G Ninja \
43         %{!?with_tests:-DBUILD_TESTING=OFF} \
44         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
45         -DHTML_INSTALL_DIR=%{_kdedocdir}
46 %ninja_build -C build
47
48 %if %{with tests}
49 ctest
50 %endif
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %ninja_install -C build
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_libdir}/qt6/plugins/kf6/kded/kwrited.so
62 %{_datadir}/knotifications6/kwrited.notifyrc
This page took 0.089852 seconds and 3 git commands to generate.