]> git.pld-linux.org Git - packages/kmod.git/blob - kmod.spec
O: module-init-tools
[packages/kmod.git] / kmod.spec
1 Summary:        Linux kernel module handling
2 Summary(pl.UTF-8):      Obsługa modułów jądra Linuksa
3 Name:           kmod
4 Version:        4
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        http://packages.profusion.mobi/kmod/%{name}-%{version}.tar.xz
9 # Source0-md5:  e14450a066a48accd0af1995b3c0232d
10 URL:            http://git.profusion.mobi/cgit.cgi/kmod.git/
11 BuildRequires:  autoconf >= 2.60
12 BuildRequires:  automake >= 1:1.11
13 BuildRequires:  libtool >= 2:2.0
14 BuildRequires:  xz-devel >= 1:4.99
15 BuildRequires:  zlib-devel
16 # won't work on older kernels as these do not provide require information in /sys
17 Requires:       uname(release) >= 2.6.21
18 Obsoletes:      module-init-tools
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _exec_prefix    /
22 %define         _bindir         %{_sbindir}
23
24 %description
25 kmod is a set of tools to handle common tasks with Linux kernel
26 modules like insert, remove, list, check properties, resolve
27 dependencies and aliases.
28
29 These tools are designed on top of libkmod, a library that is shipped
30 with kmod. See libkmod/README for more details on this library and how
31 to use it. The aim is to be compatible with tools, configurations and
32 indexes from module-init-tools project.
33
34 %description -l pl.UTF-8
35 kmod to zestaw narzędzi do wykonywania typowych czynności związanych z
36 modułami jądra - ładowanie, usuwanie, listowanie, sprawdzanie
37 parametrów, rozwiązywanie zależności czy obsługa aliasów.
38
39 Narzędzia te zostały stworzone przy użyciu libkmod, biblioteki
40 dostarczanej wraz z kmod. Celem jest stworzenie narzędzi
41 kompatybilnych z programami, konfiguracją oraz indeksami z projektu
42 module-init-tools.
43
44 %package devel
45 Summary:        Header files for %{name} library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for %{name} library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki %{name}.
55
56 %prep
57 %setup -q
58
59 %build
60 %{__libtoolize}
61 %{__aclocal} -I m4
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         --disable-silent-rules \
67         --with-xz \
68         --with-zlib
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} install \
74         pkgconfigdir=%{_pkgconfigdir} \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 # install symlinks
78 for prog in lsmod rmmod insmod modinfo modprobe depmod; do
79         ln -s kmod $RPM_BUILD_ROOT%{_sbindir}/$prog
80 done
81
82 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libkmod.la
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc NEWS README TODO
93 %attr(755,root,root) %{_libdir}/libkmod.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libkmod.so.1
95 %attr(755,root,root) %{_sbindir}/kmod
96 %attr(755,root,root) %{_sbindir}/lsmod
97 %attr(755,root,root) %{_sbindir}/rmmod
98 %attr(755,root,root) %{_sbindir}/insmod
99 %attr(755,root,root) %{_sbindir}/modinfo
100 %attr(755,root,root) %{_sbindir}/modprobe
101 %attr(755,root,root) %{_sbindir}/depmod
102
103 %{_mandir}/man5/depmod.d.5*
104 %{_mandir}/man5/modprobe.d.5*
105 %{_mandir}/man5/modules.dep.5*
106 %{_mandir}/man8/depmod.8*
107 %{_mandir}/man8/insmod.8*
108 %{_mandir}/man8/lsmod.8*
109 %{_mandir}/man8/modinfo.8*
110 %{_mandir}/man8/modprobe.8*
111 %{_mandir}/man8/rmmod.8*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libkmod.so
116 %{_includedir}/libkmod.h
117 %{_pkgconfigdir}/libkmod.pc
This page took 0.056362 seconds and 4 git commands to generate.