]> git.pld-linux.org Git - packages/kismet.git/blob - kismet.spec
8bf704843c655c5f42bfd94d277706815a8f0a30
[packages/kismet.git] / kismet.spec
1 # TODO
2 #  - Anybody knows, why it will not build, when kernel-headers are installed?
3 #  - maybe subpkg server and add initscript to it? especially as kismet server
4 #    can be remote. kismet_capture would still be in client package?
5 #  - update ncurses patch for tinfo, make it detect wide versions as well
6 #
7 %define         tarver  %(echo %{version} | tr _ -)
8 Summary:        Wireless network sniffer
9 Summary(pl.UTF-8):      Sniffer sieci bezprzewodowych
10 Name:           kismet
11 Version:        2010_07_R1
12 Release:        0.3
13 License:        GPL
14 Group:          Networking/Utilities
15 Source0:        http://www.kismetwireless.net/code/%{name}-%{tarver}.tar.gz
16 # Source0-md5:  85e59186eb529889118b5635f35cf57d
17 Patch0:         config.patch
18 URL:            http://www.kismetwireless.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  bluez-libs-devel
22 BuildRequires:  gmp-devel
23 BuildRequires:  libcap-devel
24 BuildRequires:  libnl-devel
25 BuildRequires:  libpcap-devel >= 2:0.9.4-1
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  ncurses-ext-devel
28 BuildRequires:  openssl-devel
29 BuildRequires:  pcre-devel
30 BuildRequires:  pkgconfig
31 BuildRequires:  sed >= 4.0
32 # it uses internal structures - so strict deps
33 %requires_eq    libpcap
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         plugins plugin-autowep plugin-btscan plugin-ptw plugin-spectools
37
38 %description
39 Kismet is a 802.11b wireless network sniffer. It is capable of
40 sniffing using almost any wireless card supported in Linux, including
41 Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
42 Rangelan, etc), cards which support standard packet capture via
43 libpcap (Cisco), and limited support for cards without RF Monitor
44 support.
45
46 %description -l pl.UTF-8
47 Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
48 sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
49 w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
50 (Linksys, Dlink, Rangelan, etc), kart które umożliwiają
51 przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
52 wsparcie dla kart bez obsługi Monitora RF.
53
54 %prep
55 %setup -q -n %{name}-%{tarver}
56 %patch0 -p1
57
58 # make lib64 aware, include exec bits on install
59 %{__sed} -i -e 's!\$(prefix)/lib/!%_libdir/!g' plugin-*/Makefile
60 %{__sed} -i -e '/install/ s!-m644!-m755!' plugin-*/Makefile
61
62 # make %doc friendly
63 for a in plugin-*/README; do
64         mv $a README.${a%/README}
65 done
66
67 %build
68 cp -f /usr/share/automake/config.* .
69 %{__aclocal}
70 %{__autoconf}
71 %configure
72
73 %{__make} \
74         CLIENTLIBS="-ldl -lncurses -lpanel -ltinfo"  # hack to add -ltinfo
75
76 for plugin in %plugins; do
77         %{__make} -C $plugin \
78                 KIS_SRC_DIR=$PWD
79 done
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir},/var/lib/%{name}}
84 for dir in . %plugins; do
85         %{__make} -C $dir install \
86                 DESTDIR="$RPM_BUILD_ROOT" \
87                 KIS_SRC_DIR=$PWD \
88                 INSTUSR=%(id -un) \
89                 INSTGRP=%(id -gn) \
90                 MANGRP=%(id -gn)
91 done
92
93 # do what binsuidinstall would do
94 install -p kismet_capture $RPM_BUILD_ROOT%{_bindir}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc docs/* CHANGELOG README README.plugin-*
102 %attr(755,root,root) %{_bindir}/kismet
103 %attr(755,root,root) %{_bindir}/kismet_client
104 %attr(755,root,root) %{_bindir}/kismet_drone
105 %attr(755,root,root) %{_bindir}/kismet_server
106 # TODO: create kismet group instead
107 %attr(4750,root,adm) %{_bindir}/kismet_capture
108 %{_datadir}/%{name}
109 %{_mandir}/man1/kismet.1*
110 %{_mandir}/man1/kismet_drone.1*
111 %{_mandir}/man5/kismet.conf.5*
112 %{_mandir}/man5/kismet_drone.conf.5*
113 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet.conf
114 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_drone.conf
115 %dir %{_libdir}/kismet
116 %dir %{_libdir}/kismet_client
117 %attr(755,root,root) %{_libdir}/kismet/aircrack-kismet.so
118 %attr(755,root,root) %{_libdir}/kismet/autowep-kismet.so
119 %attr(755,root,root) %{_libdir}/kismet/btscan.so
120 %attr(755,root,root) %{_libdir}/kismet/spectool_net.so
121 %attr(755,root,root) %{_libdir}/kismet_client/btscan_ui.so
122 %attr(755,root,root) %{_libdir}/kismet_client/spectools_ui.so
123
124 %dir /var/lib/%{name}
This page took 0.116751 seconds and 3 git commands to generate.