]> git.pld-linux.org Git - packages/kicad.git/blob - kicad.spec
- more adjustements in sed hack
[packages/kicad.git] / kicad.spec
1 %define libver 1.0
2 %define docver 1.1
3 Summary:        KiCad - is a GPL'd suite of programs for EDA
4 Summary(pl.UTF-8):      KiCad - zestaw programów na licencji GPL zaliczany do kategorii EDA
5 Name:           kicad
6 Version:        20110429
7 Release:        0.1
8 License:        GPL v2+
9 Group:          X11/Applications
10 Source0:        http://iut-tice.ujf-grenoble.fr/cao/%{name}-sources_2011-04-29-BZR2986.zip
11 # Source0-md5:  e5d5311ad8a6387b1e96a9ee63088238
12 Source1:        http://downloads.sourceforge.net/kicad/%{name}-library-%{libver}.tar.bz2
13 # Source1-md5:  9c91940aa5f5563bb86c52ff07e8f99a
14 Source2:        http://downloads.sourceforge.net/kicad/%{name}-doc-%{docver}.tar.bz2
15 # Source2-md5:  fcfbc94f675a19db51370e97b88803b1
16 Source3:        %{name}.desktop
17 URL:            http://kicad.sourceforge.net/
18 BuildRequires:  boost-devel
19 BuildRequires:  cmake >= 2.6.4
20 BuildRequires:  rpmbuild(macros) >= 1.600
21 BuildRequires:  sed >= 4.0
22 BuildRequires:  which
23 BuildRequires:  wxGTK2-unicode-gl-devel >= 2.8.11
24 BuildRequires:  wxWidgets-devel >= 2.8.11
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 KiCad consists of a project manager and four main programs:
30 - kicad - the project manager.
31 - eeschema - the schematic editor.
32 - cvpcb - the footprint selector for components used in the circuit
33   design.
34 - pcbnew - the PCB layout program.
35 - gerbview - the Gerber (photoplotter documents) viewer.
36
37 %description -l pl.UTF-8
38 KiCad składa się z menadżera projektów oraz czterech głównych
39 programów:
40 - kicad - menadżer projektów.
41 - eeschema - edytor schematów.
42 - cvpcb - narzędzie do wybierania elementów używanych przy
43   projektowaniu płytek drukowanych.
44 - pcbnew - program do projektowania płytek drukowanych.
45 - gerbview - przeglądarka plików Gerber (dokumentów dla fotoplotera).
46
47 %prep
48 %setup -q  -n %{name}_sources
49
50 %if "%{_lib}" != "lib"
51         %{__sed} -i -e "s@lib/@%{_lib}/@g" CMakeLists.txt
52 %endif
53
54 %build
55 install -d build
56 cd build
57 %cmake \
58         -DKICAD_STABLE_VERSION=ON \
59         -DwxWidgets_USE_STATIC=OFF \
60         -DwxWidgets_CONFIG_EXECUTABLE="%{_bindir}/wx-gtk2-unicode-config" \
61         -DKICAD_MINIZIP=ON \
62         -DKICAD_GOST=ON \
63         ..
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build install \
71         KICAD_INTERNAT=$RPM_BUILD_ROOT%{_localedir} \
72         KICAD_PLUGINS=$RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
73         KICAD_DATA=$RPM_BUILD_ROOT%{_datadir}/%{name} \
74         KICAD_DOCS=$RPM_BUILD_ROOT%{_datadir}/%{name}/help \
75         DESTDIR=$RPM_BUILD_ROOT \
76         PREFIX=$RPM_BUILD_ROOT%{_prefix}
77
78 install -d $RPM_BUILD_ROOT%{_desktopdir}
79 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
80
81 #for loc in $RPM_BUILD_ROOT%{_localedir}/*; do
82 #       install -d $loc/LC_MESSAGES
83 #       mv $loc/*.mo $loc/LC_MESSAGES
84 #done
85
86 for loc in $RPM_BUILD_ROOT%{_datadir}/%{name}/help/*; do
87         rm -rf $loc/docs_src
88 done
89
90 #%%find_lang %{name}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 #%%files -f %{name}.lang
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS.txt CHANGELOG.txt Documentation
99 %attr(755,root,root) %{_bindir}/cvpcb
100 %attr(755,root,root) %{_bindir}/eeschema
101 %attr(755,root,root) %{_bindir}/gerbview
102 %dir %{_libdir}/%{name}
103 %dir %{_libdir}/%{name}/plugins
104 #%%attr(755,root,root) %{_libdir}/%{name}/plugins/netlist_form_pads-pcb
105 %{_datadir}/%{name}
106 %{_desktopdir}/%{name}.desktop
This page took 0.063516 seconds and 3 git commands to generate.