]> git.pld-linux.org Git - SPECS.git/blob - kgtk.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / kgtk.spec
1 #
2 # TODO: alternate qt4 build ("Cant compile Qt3/KDE3 at the same time as Qt4/KDE4")
3 #
4 %define _name   KGtk
5 Summary:        KGtk (Use KDE Dialogs in GTK+ Apps)
6 Summary(pl.UTF-8):      KGtk - wykorzystywanie okien dialogowych KDE w aplikacjach GTK+
7 Name:           kgtk
8 Version:        0.10.1
9 Release:        1
10 License:        GPL v2
11 Group:          Libraries
12 Source0:        http://home.freeuk.com/cpdrummond/%{_name}-%{version}.tar.bz2
13 # Source0-md5:  b456046727f0120734410573d75c47e0
14 URL:            http://www.kde-look.org/content/show.php?content=36077
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gtk+2-devel >= 2:2.4.0
18 BuildRequires:  kdelibs-devel >= 9:3.2.0
19 BuildRequires:  pkgconfig
20 BuildRequires:  rpmbuild(macros) >= 1.129
21 BuildRequires:  sed >= 4.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is an LD_PRELOAD library that allows GTK+ applications to use
26 KDE's file dialogs when run under KDE. This will only work under KDE,
27 as the KDE dialog portion is implemented as a KDED module that is
28 loaded at KDE startup. This creates a UNIX socket through which the
29 GTK+ apps communicate.
30
31 %description -l pl.UTF-8
32 To jest biblioteka wczytywana przez LD_PRELOAD pozwalająca aplikacjom
33 GTK+ korzystać z okien dialogowych wyboru plików z KDE w czasie
34 działania KDE. Działa to tylko pod KDE, jako że część dialogowa KDE
35 jest zaimplementowana jako moduł KDED wczytywany przy starcie KDE.
36 Tworzy gniazdo uniksowe, z którym komunikują się aplikacje GTK+.
37
38 %prep
39 %setup -q -n %{_name}-%{version}
40
41 %build
42 export kde_htmldir=%{_kdedocdir}
43 export kde_libs_htmldir=%{_kdedocdir}
44 export KDEDIR=%{_prefix}
45 export QTDIR=%{_prefix}
46 install -d build
47 cd build
48 %cmake \
49         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
50         -DLIB_INSTALL_DIR=%{_libdir} \
51         -DKGTK_QT3=true \
52         -DKGTK_QT4=false \
53 %if "%{_lib}" == "lib64"
54         -DLIB_SUFFIX=64 \
55 %endif 
56         ../
57
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_bindir}
63
64 %{__make} -C build install \
65         DESTDIR=$RPM_BUILD_ROOT \
66         kde_htmldir=%{_kdedocdir} \
67         kde_libs_htmldir=%{_kdedocdir}
68
69 %find_lang %{name} --with-kde --all-name
70                         
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files -f %{name}.lang
78 %defattr(644,root,root,755)
79 %doc AUTHORS ChangeLog README
80 %attr(755,root,root) %{_bindir}/*
81 %dir %{_libdir}/kgtk
82 %attr(755,root,root) %{_libdir}/kgtk/libkgtk2.so
83 %attr(755,root,root) %{_libdir}/kgtk/libkqt3.so
84                                         
This page took 0.159362 seconds and 3 git commands to generate.