]> git.pld-linux.org Git - packages/kf5-kwindowsystem.git/blob - kf5-kwindowsystem.spec
f7a5c3ae6d35e33aae30431812a32211e8722fe6
[packages/kf5-kwindowsystem.git] / kf5-kwindowsystem.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.114
5 %define         qtver           5.15.2
6 %define         kfname          kwindowsystem
7
8 Summary:        Access to the windowing system
9 Name:           kf5-%{kfname}
10 Version:        5.114.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  1f29f0749620d4aa8a4a5781af3f7e23
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
22 BuildRequires:  cmake >= 3.16
23 BuildRequires:  kf5-extra-cmake-modules >= %{version}
24 BuildRequires:  libxcb-devel
25 BuildRequires:  ninja
26 BuildRequires:  pkgconfig
27 BuildRequires:  qt5-linguist >= %{qtver}
28 BuildRequires:  rpmbuild(macros) >= 1.736
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xcb-util-keysyms-devel
31 BuildRequires:  xcb-util-wm-devel
32 BuildRequires:  xorg-lib-libX11-devel
33 BuildRequires:  xorg-lib-libXfixes-devel
34 BuildRequires:  xz
35 Requires:       Qt5Gui >= %{qtver}
36 Requires:       Qt5Widgets >= %{qtver}
37 Requires:       Qt5X11Extras >= %{qtver}
38 Requires:       kf5-dirs
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         qt5dir          %{_libdir}/qt5
42
43 %description
44 Convenience access to certain properties and features of the windowing
45 system.
46
47 KWindowSystem provides information about the windowing system and
48 allows interaction with the windowing system. It provides an high
49 level API which is windowing system independent and has platform
50 specific implementations. This API is inspired by X11 and thus not all
51 functionality is available on all windowing systems.
52
53 In addition to the high level API, this framework also provides
54 several more low level classes for interaction with the X Windowing
55 System.
56
57 %package devel
58 Summary:        Header files for %{kfname} development
59 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       Qt5Widgets-devel >= %{qtver}
63
64 %description devel
65 Header files for %{kfname} development.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe dla programistów używających %{kfname}.
69
70 %prep
71 %setup -q -n %{kfname}-%{version}
72
73 %build
74 %cmake -B build \
75         -G Ninja \
76         %{!?with_tests:-DBUILD_TESTING=OFF} \
77         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
78
79 %ninja_build -C build
80
81 %if %{with tests}
82 %ninja_build -C build test
83 %endif
84
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %ninja_install -C build
89
90 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files -f %{kfname}5_qt.lang
99 %defattr(644,root,root,755)
100 %doc README.md
101 %ghost %{_libdir}/libKF5WindowSystem.so.5
102 %attr(755,root,root) %{_libdir}/libKF5WindowSystem.so.*.*
103 %dir %{_libdir}/qt5/plugins/kf5/kwindowsystem
104 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kwindowsystem/KF5WindowSystemX11Plugin.so
105 %{_datadir}/qlogging-categories5/kwindowsystem.renamecategories
106 %{_datadir}/qlogging-categories5/kwindowsystem.categories
107
108 %files devel
109 %defattr(644,root,root,755)
110 %{_includedir}/KF5/KWindowSystem
111 %{_libdir}/cmake/KF5WindowSystem
112 %{_libdir}/libKF5WindowSystem.so
113 %{qt5dir}/mkspecs/modules/qt_KWindowSystem.pri
This page took 0.0515 seconds and 2 git commands to generate.