]> git.pld-linux.org Git - SPECS.git/blob - kf5-kwayland.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / kf5-kwayland.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.115
5 %define         qtver           5.15.2
6 %define         kfname          kwayland
7
8 Summary:        Qt-style API to interact with the wayland-client and wayland-server API
9 Summary(pl.UTF-8):      API w stylu Qt do interakcji z API wayland-client i wayland-server
10 Name:           kf5-%{kfname}
11 Version:        5.115.0
12 Release:        1
13 License:        LGPL v2.1 or KDE-accepted LGPL v3+
14 Group:          X11/Libraries
15 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
16 # Source0-md5:  5031ae48f5214293ca8484e719a78895
17 URL:            http://www.kde.org/
18 BuildRequires:  EGL-devel
19 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  Qt5WaylandClient-devel >= %{qtver}
24 BuildRequires:  Qt5Widgets-devel >= %{qtver}
25 BuildRequires:  Qt5XkbCommonSupport-devel >= %{qtver}
26 BuildRequires:  cmake >= 3.16
27 BuildRequires:  gettext-devel
28 BuildRequires:  kf5-extra-cmake-modules >= %{version}
29 BuildRequires:  kf5-plasma-wayland-protocols-devel >= 1.9.0
30 BuildRequires:  ninja
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.736
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  wayland-devel >= 1.15
35 BuildRequires:  wayland-protocols >= 1.15
36 BuildRequires:  xz
37 Requires:       Qt5Core >= %{qtver}
38 Requires:       Qt5Gui >= %{qtver}
39 Requires:       wayland >= 1.15
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 KWayland is a Qt-style API to interact with the wayland-client and
44 wayland-server API.
45
46 %description -l pl.UTF-8
47 KWayland to API w stylu Qt do interakcji z API wayland-client i
48 wayland-server.
49
50 %package devel
51 Summary:        Header files for %{kfname} development
52 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
53 Group:          X11/Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       Qt5Gui-devel >= %{qtver}
56
57 %description devel
58 Header files for %{kfname} development.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe dla programistów używających %{kfname}.
62
63 %prep
64 %setup -q -n %{kfname}-%{version}
65
66 %build
67 %cmake -B build \
68         -G Ninja \
69         %{!?with_tests:-DBUILD_TESTING=OFF} \
70         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
71
72 %ninja_build -C build
73
74 %if %{with tests}
75 %ninja_build -C build test
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %ninja_install -C build
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.md LICENSES/LicenseRef-KDE-Accepted-LGPL.txt
92 %ghost %{_libdir}/libKF5WaylandClient.so.5
93 %attr(755,root,root) %{_libdir}/libKF5WaylandClient.so.5.*.*
94 %ghost %{_libdir}/libKF5WaylandServer.so.5
95 %attr(755,root,root) %{_libdir}/libKF5WaylandServer.so.5.*.*
96 %attr(755,root,root) %{_libexecdir}/org-kde-kf5-kwayland-testserver
97 %{_datadir}/qlogging-categories5/kwayland.categories
98 %{_datadir}/qlogging-categories5/kwayland.renamecategories
99
100 %files devel
101 %defattr(644,root,root,755)
102 %{_libdir}/libKF5WaylandClient.so
103 %{_libdir}/libKF5WaylandServer.so
104 %{_includedir}/KF5/KWayland
105 %{_pkgconfigdir}/KF5WaylandClient.pc
106 %{_libdir}/cmake/KF5Wayland
107 %{_libdir}/qt5/mkspecs/modules/qt_KWaylandClient.pri
108 %{_libdir}/qt5/mkspecs/modules/qt_KWaylandServer.pri
This page took 0.918407 seconds and 3 git commands to generate.