]> git.pld-linux.org Git - packages/kf5-kpeople.git/blob - kf5-kpeople.spec
- updated to 5.109.0; cmake -B build
[packages/kf5-kpeople.git] / kf5-kpeople.spec
1 # Conditional build:
2 %bcond_with     tests           # build without tests
3 #
4 %define         kdeframever     5.109
5 %define         qtver           5.15.2
6 %define         kfname          kpeople
7 Summary:        Provides access to all contacts and the people who hold them
8 Name:           kf5-%{kfname}
9 Version:        5.109.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  e66ebdbc5547881e8562bab6a02ce8bb
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Network-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 %if %{with tests}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtver}
23 %endif
24 BuildRequires:  cmake >= 3.16
25 BuildRequires:  kf5-extra-cmake-modules >= %{version}
26 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
27 BuildRequires:  ninja
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 Requires:       kf5-dirs
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Provides access to all contacts and the people who hold them.
37
38 %package devel
39 Summary:        Header files for %{kfname} development
40 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{kfname} development.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe dla programistów używających %{kfname}.
49
50 %prep
51 %setup -q -n %{kfname}-%{version}
52
53 %build
54 %cmake -B build \
55         -G Ninja \
56         %{!?with_tests:-DBUILD_TESTING=OFF} \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
58
59 %ninja_build -C build
60
61 %{?with_tests:%ninja_build -C build test}
62
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %ninja_install -C build
67
68 %find_lang %{kfname}5 --all-name --with-kde
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files -f %{kfname}5.lang
77 %defattr(644,root,root,755)
78 %doc README.md
79 %{_datadir}/qlogging-categories5/kpeople.categories
80 %attr(755,root,root) %{_libdir}/libKF5People.so.*.*.*
81 %ghost %{_libdir}/libKF5People.so.5
82 %attr(755,root,root) %{_libdir}/libKF5PeopleBackend.so.*.*.*
83 %ghost %{_libdir}/libKF5PeopleBackend.so.5
84 %attr(755,root,root) %{_libdir}/libKF5PeopleWidgets.so.*.*.*
85 %ghost %{_libdir}/libKF5PeopleWidgets.so.5
86 %dir %{_libdir}/qt5/qml/org/kde/people
87 %{_libdir}/qt5/qml/org/kde/people/qmldir
88 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/people/libKF5PeopleDeclarative.so
89 %{_datadir}/qlogging-categories5/kpeople.renamecategories
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_libdir}/libKF5People.so
94 %{_libdir}/libKF5PeopleBackend.so
95 %{_libdir}/libKF5PeopleWidgets.so
96 %{_includedir}/KF5/KPeople
97 %{_libdir}/cmake/KF5People
98 %{_libdir}/qt5/mkspecs/modules/qt_KPeople*.pri
This page took 0.060229 seconds and 3 git commands to generate.