]> git.pld-linux.org Git - SPECS.git/blob - kf5-kpeople.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / kf5-kpeople.spec
1 # Conditional build:
2 %bcond_with     tests           # build without tests
3 #
4 %define         kdeframever     5.84
5 %define         qtver           5.9.0
6 %define         kfname          kpeople
7 Summary:        Provides access to all contacts and the people who hold them
8 Name:           kf5-%{kfname}
9 Version:        5.84.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  5e6141f6b2c8af0a251082f9ce2584ae
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Network-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 %if %{with tests}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtver}
23 %endif
24 BuildRequires:  cmake >= 2.8.12
25 BuildRequires:  kf5-extra-cmake-modules >= %{version}
26 BuildRequires:  ninja
27 BuildRequires:  qt5-build >= %{qtver}
28 BuildRequires:  rpmbuild(macros) >= 1.164
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       kf5-dirs
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Provides access to all contacts and the people who hold them.
36
37 %package devel
38 Summary:        Header files for %{kfname} development
39 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
40 Group:          X11/Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for %{kfname} development.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe dla programistów używających %{kfname}.
48
49 %prep
50 %setup -q -n %{kfname}-%{version}
51
52 %build
53 install -d build
54 cd build
55 %cmake -G Ninja \
56         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
57         ..
58 %ninja_build
59
60 %{?with_tests:%ninja_build test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 %find_lang %{kfname}5 --all-name --with-kde
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files -f %{kfname}5.lang
75 %defattr(644,root,root,755)
76 %doc README.md
77 %{_datadir}/qlogging-categories5/kpeople.categories
78 %attr(755,root,root) %{_libdir}/libKF5People.so.*.*.*
79 %ghost %{_libdir}/libKF5People.so.5
80 %attr(755,root,root) %{_libdir}/libKF5PeopleBackend.so.*.*.*
81 %ghost %{_libdir}/libKF5PeopleBackend.so.5
82 %attr(755,root,root) %{_libdir}/libKF5PeopleWidgets.so.*.*.*
83 %ghost %{_libdir}/libKF5PeopleWidgets.so.5
84 %dir %{_libdir}/qt5/qml/org/kde/people
85 %{_libdir}/qt5/qml/org/kde/people/qmldir
86 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/people/libKF5PeopleDeclarative.so
87 %{_datadir}/kservicetypes5/kpeople_data_source.desktop
88 %{_datadir}/kservicetypes5/kpeople_plugin.desktop
89 %{_datadir}/kservicetypes5/persondetailsplugin.desktop
90 %{_datadir}/qlogging-categories5/kpeople.renamecategories
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_libdir}/libKF5People.so
95 %{_libdir}/libKF5PeopleBackend.so
96 %{_libdir}/libKF5PeopleWidgets.so
97 %{_includedir}/KF5/KPeople
98 %{_libdir}/cmake/KF5People
99 %{_libdir}/qt5/mkspecs/modules/qt_KPeople*.pri
This page took 0.429364 seconds and 3 git commands to generate.