]> git.pld-linux.org Git - SPECS.git/blob - kf5-kdoctools.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / kf5-kdoctools.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # - runtime Requires if any
6 # - package manual pages
7 %define         kdeframever     5.115
8 %define         qtver           5.15.2
9 %define         kfname          kdoctools
10
11 Summary:        Create documentation from DocBook
12 Name:           kf5-%{kfname}
13 Version:        5.115.0
14 Release:        1
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  bb297f2112003546b94c89c705578316
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  cmake >= 3.16
22 BuildRequires:  docbook-dtd45-xml
23 BuildRequires:  docbook-style-xsl
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  kf5-karchive-devel >= %{version}
26 BuildRequires:  kf5-ki18n-devel >= %{version}
27 BuildRequires:  libxml2-devel
28 BuildRequires:  libxml2-progs
29 BuildRequires:  libxslt-devel
30 BuildRequires:  ninja
31 BuildRequires:  perl-URI
32 BuildRequires:  perl-base
33 BuildRequires:  qt5-linguist >= %{qtver}
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires:       Qt5Core >= %{qtver}
38 Requires:       docbook-style-xsl
39 Requires:       kf5-dirs
40 Requires:       kf5-karchive >= %{version}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         qt5dir          %{_libdir}/qt5
44
45 %description
46 Provides tools to generate documentation in various format from
47 DocBook files.
48
49 %package devel
50 Summary:        Header files for %{kfname} development
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       Qt5Core-devel >= %{qtver}
55 Requires:       cmake >= 3.16
56
57 %description devel
58 Header files for %{kfname} development.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe dla programistów używających %{kfname}.
62
63 %prep
64 %setup -q -n %{kfname}-%{version}
65
66 %build
67 %cmake -B build \
68         -G Ninja \
69         %{!?with_tests:-DBUILD_TESTING=OFF} \
70         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
71
72 %ninja_build -C build
73
74 %if %{with tests}
75 %ninja_build -C build test
76 %endif
77
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %ninja_install -C build
82
83 %find_lang %{kfname}5
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files -f %{kfname}5.lang
92 %defattr(644,root,root,755)
93 %doc README.md
94 %attr(755,root,root) %{_bindir}/checkXML5
95 %attr(755,root,root) %{_bindir}/meinproc5
96 %ghost %{_libdir}/libKF5DocTools.so.5
97 %attr(755,root,root) %{_libdir}/libKF5DocTools.so.*.*
98 %{_docdir}/HTML/*/kdoctools5-common
99 %dir %{_datadir}/kf5/kdoctools
100 %{_datadir}/kf5/kdoctools/customization
101 %{_mandir}/man1/checkXML5.1*
102 %{_mandir}/man1/meinproc5.1*
103 %{_mandir}/man7/kf5options.7*
104 %{_mandir}/man7/qt5options.7*
105 %lang(ca) %{_mandir}/ca/man1/checkXML5.1*
106 %lang(ca) %{_mandir}/ca/man1/meinproc5.1*
107 %lang(ca) %{_mandir}/ca/man7/kf5options.7*
108 %lang(ca) %{_mandir}/ca/man7/qt5options.7*
109 %lang(de) %{_mandir}/de/man1/checkXML5.1*
110 %lang(de) %{_mandir}/de/man1/meinproc5.1*
111 %lang(de) %{_mandir}/de/man7/kf5options.7*
112 %lang(de) %{_mandir}/de/man7/qt5options.7*
113 %lang(es) %{_mandir}/es/man1/checkXML5.1*
114 %lang(es) %{_mandir}/es/man1/meinproc5.1*
115 %lang(es) %{_mandir}/es/man7/kf5options.7*
116 %lang(es) %{_mandir}/es/man7/qt5options.7*
117 %lang(it) %{_mandir}/id/man1/checkXML5.1*
118 %lang(it) %{_mandir}/it/man1/checkXML5.1*
119 %lang(it) %{_mandir}/it/man1/meinproc5.1*
120 %lang(it) %{_mandir}/it/man7/kf5options.7*
121 %lang(it) %{_mandir}/it/man7/qt5options.7*
122 %lang(nl) %{_mandir}/nl/man1/checkXML5.1*
123 %lang(nl) %{_mandir}/nl/man1/meinproc5.1*
124 %lang(nl) %{_mandir}/nl/man7/kf5options.7*
125 %lang(nl) %{_mandir}/nl/man7/qt5options.7*
126 %lang(pt) %{_mandir}/pt/man1/checkXML5.1*
127 %lang(pt) %{_mandir}/pt/man1/meinproc5.1*
128 %lang(pt) %{_mandir}/pt/man7/kf5options.7*
129 %lang(pt) %{_mandir}/pt/man7/qt5options.7*
130 %lang(pt_BR) %{_mandir}/pt_BR/man1/checkXML5.1*
131 %lang(pt_BR) %{_mandir}/pt_BR/man1/meinproc5.1*
132 %lang(pt_BR) %{_mandir}/pt_BR/man7/kf5options.7*
133 %lang(pt_BR) %{_mandir}/pt_BR/man7/qt5options.7*
134 %lang(ru) %{_mandir}/ru/man1/checkXML5.1*
135 %lang(ru) %{_mandir}/ru/man7/qt5options.7*
136 %lang(sv) %{_mandir}/sv/man1/checkXML5.1*
137 %lang(sv) %{_mandir}/sv/man1/meinproc5.1*
138 %lang(sv) %{_mandir}/sv/man7/kf5options.7*
139 %lang(sv) %{_mandir}/sv/man7/qt5options.7*
140 %lang(uk) %{_mandir}/uk/man1/checkXML5.1*
141 %lang(uk) %{_mandir}/uk/man1/meinproc5.1*
142 %lang(uk) %{_mandir}/uk/man7/kf5options.7*
143 %lang(uk) %{_mandir}/uk/man7/qt5options.7*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %{_includedir}/KF5/KDocTools
148 %{_libdir}/cmake/KF5DocTools
149 %{_libdir}/libKF5DocTools.so
This page took 0.303186 seconds and 3 git commands to generate.