]> git.pld-linux.org Git - packages/kf5-kauth.git/blob - kf5-kauth.spec
94e144c5fe123d919b3f26f8ca4aafd8a1f505a2
[packages/kf5-kauth.git] / kf5-kauth.spec
1 # TODO:
2 # - proper place for *.pri,
3 # - set ECM_MKSPECS_INSTALL_DIR in kde5-extra-cmake-modules
4 # - _IMPORT_PREFIX also must be set somewhere
5 # - runtime Requires if any
6 # - these dirs are not own by any package
7 #  /usr/include/KF5
8 #  /usr/lib/libexec
9 #  /usr/lib/plugins
10 #  /usr/share/kf5
11 %define         _state          stable
12 %define         orgname         kauth
13
14 Summary:        Execute actions as privileged user
15 Name:           kf5-%{orgname}
16 Version:        5.0.0
17 Release:        0.1
18 License:        GPL v2+/LGPL v2.1+
19 Group:          X11/Libraries
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
21 # Source0-md5:  eeb5e576c9d0d098cfb9def812f04089
22 URL:            http://www.kde.org/
23 BuildRequires:  Qt5Core-devel >= 5.2.0
24 BuildRequires:  Qt5DBus-devel
25 BuildRequires:  Qt5Gui-devel >= 5.3.1
26 BuildRequires:  Qt5Test-devel
27 BuildRequires:  Qt5Widgets-devel
28 BuildRequires:  cmake >= 2.8.12
29 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
30 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
31 BuildRequires:  polkit-qt-1-devel
32 BuildRequires:  qt5-linguist
33 BuildRequires:  rpmbuild(macros) >= 1.164
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         qt5dir          %{_libdir}/qt5
39
40 %description
41 KAuth provides a convenient, system-integrated way to offload actions
42 that need to be performed as a privileged user (root, for example) to
43 small (hopefully secure) helper utilities.
44
45 %package devel
46 Summary:        Header files for %{orgname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{orgname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{orgname}.
56
57 %prep
58 %setup -q -n %{orgname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -DBIN_INSTALL_DIR=%{_bindir} \
65         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
66         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
67         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
68         -DQML_INSTALL_DIR=%{qt5dir}/qml \
69         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
70         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
71         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
72         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
73         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
74         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
75         -D_IMPORT_PREFIX=%{_prefix} \
76         ../
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build/ install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %find_lang %{orgname}5_qt --with-qm
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files -f %{orgname}5_qt.lang
94 %defattr(644,root,root,755)
95 %doc README.md
96 /etc/dbus-1/system.d/org.kde.kf5auth.conf
97 %attr(755,root,root) %ghost %{_libdir}/libKF5Auth.so.5
98 %attr(755,root,root) %{_libdir}/libKF5Auth.so.5.0.0
99 %dir %{qt5dir}/plugins/kauth
100 %dir %{qt5dir}/plugins/kauth/backend
101 %attr(755,root,root) %{qt5dir}/plugins/kauth/backend/kauth_backend_plugin.so
102 %dir %{qt5dir}/plugins/kauth/helper
103 %attr(755,root,root) %{qt5dir}/plugins/kauth/helper/kauth_helper_plugin.so
104 %dir %{_libdir}/kauth
105 %attr(755,root,root) %{_libdir}/kauth/kauth-policy-gen
106 %{_datadir}/kf5/kauth/dbus_policy.stub
107 %{_datadir}/kf5/kauth/dbus_service.stub
108
109 %files devel
110 %defattr(644,root,root,755)
111 %{_includedir}/KF5/KAuth
112 %{_includedir}/KF5/kauth_version.h
113 %{_libdir}/cmake/KF5Auth
114 %attr(755,root,root) %{_libdir}/libKF5Auth.so
115 %{qt5dir}/mkspecs/modules/qt_KAuth.pri
This page took 0.038273 seconds and 2 git commands to generate.