]> git.pld-linux.org Git - packages/kf5-kapidox.git/blob - kf5-kapidox.spec
- updated to 5.87.0
[packages/kf5-kapidox.git] / kf5-kapidox.spec
1 # TODO:
2 # - runtime Requires if any
3 # - python3 version
4 # - .pyo etc
5 %define         kdeframever     5.87
6 %define         qtver           5.9.0
7 %define         kfname          kapidox
8 Summary:        Kapidox
9 Name:           kf5-%{kfname}
10 Version:        5.87.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  6f9e963ca640637d66087f87796f166f
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= 5.2.0
18 BuildRequires:  Qt5DBus-devel >= 5.2.0
19 BuildRequires:  Qt5Gui-devel >= 5.3.1
20 BuildRequires:  Qt5Test-devel
21 BuildRequires:  Qt5Widgets-devel >= 5.2.0
22 BuildRequires:  Qt5X11Extras-devel >= 5.2.0
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  ninja
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  sphinx-pdg
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       graphviz
32 Requires:       kf5-dirs
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         qt5dir          %{_libdir}/qt5
37
38 %description
39 This framework contains scripts and data for building API
40 documentation (dox) in a standard format and style.
41
42 The Doxygen tool is used to do the actual documentation extraction and
43 formatting, but this framework provides a wrapper script to make
44 generating the documentation more convenient (including reading
45 settings from the target framework or other module) and a standard
46 template for the generated documentation.
47
48 %prep
49 %setup -q -n %{kfname}-%{version}
50
51 %build
52 %py3_build
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %py3_install
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{_bindir}/depdiagram-generate
64 %attr(755,root,root) %{_bindir}/depdiagram-generate-all
65 %attr(755,root,root) %{_bindir}/depdiagram-prepare
66 %attr(755,root,root) %{_bindir}/kapidox_generate
67 %{py3_sitescriptdir}/kapidox/
68 %{py3_sitescriptdir}/kapidox-*.egg-info
69 %{_mandir}/man1/depdiagram-generate-all.1*
70 %{_mandir}/man1/depdiagram-generate.1*
71 %{_mandir}/man1/depdiagram-prepare.1*
This page took 0.031593 seconds and 4 git commands to generate.