]> git.pld-linux.org Git - packages/kf5-kapidox.git/blob - kf5-kapidox.spec
- fix shebangs
[packages/kf5-kapidox.git] / kf5-kapidox.spec
1 # TODO:
2 # - runtime Requires if any
3 # - python3 version
4 # - .pyo etc
5 %define         kdeframever     5.62
6 %define         qtver           5.9.0
7 %define         kfname          kapidox
8 Summary:        Kapidox
9 Name:           kf5-%{kfname}
10 Version:        5.62.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  389fbadf7e25573556891de7f9c052f1
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= 5.2.0
18 BuildRequires:  Qt5DBus-devel >= 5.2.0
19 BuildRequires:  Qt5Gui-devel >= 5.3.1
20 BuildRequires:  Qt5Test-devel
21 BuildRequires:  Qt5Widgets-devel >= 5.2.0
22 BuildRequires:  Qt5X11Extras-devel >= 5.2.0
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  ninja
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  sphinx-pdg
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       graphviz
32 Requires:       kf5-dirs
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         qt5dir          %{_libdir}/qt5
36
37 %description
38 This framework contains scripts and data for building API
39 documentation (dox) in a standard format and style.
40
41 The Doxygen tool is used to do the actual documentation extraction and
42 formatting, but this framework provides a wrapper script to make
43 generating the documentation more convenient (including reading
44 settings from the target framework or other module) and a standard
45 template for the generated documentation.
46
47 %prep
48 %setup -q -n %{kfname}-%{version}
49
50 %build
51 install -d build
52 cd build
53 %cmake -G Ninja \
54         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
55         ..
56 %ninja_build
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %ninja_install -C build
61
62 %{__sed} -E -i -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
63       $RPM_BUILD_ROOT%{_bindir}/depdiagram-generate \
64       $RPM_BUILD_ROOT%{_bindir}/depdiagram-prepare \
65       $RPM_BUILD_ROOT%{_bindir}/kapidox_generate
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_bindir}/depdiagram-generate
73 %attr(755,root,root) %{_bindir}/depdiagram-generate-all
74 %attr(755,root,root) %{_bindir}/depdiagram-prepare
75 %attr(755,root,root) %{_bindir}/kapidox_generate
76 #%%attr(755,root,root) %{_bindir}/kgenapidox
77 #%%attr(755,root,root) %{_bindir}/kgenframeworksapidox
78 %{py_sitedir}/kapidox
79 %{py_sitedir}/kapidox-*.egg-info
80 %{_mandir}/man1/depdiagram-generate-all.1*
81 %{_mandir}/man1/depdiagram-generate.1*
82 %{_mandir}/man1/depdiagram-prepare.1*
83 #%%{_mandir}/man1/kgenapidox.1*
84 #%%{_mandir}/man1/kgenframeworksapidox.1*
This page took 0.065048 seconds and 4 git commands to generate.