]> git.pld-linux.org Git - packages/kf5-kapidox.git/blob - kf5-kapidox.spec
- updated to 5.101.0
[packages/kf5-kapidox.git] / kf5-kapidox.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # - runtime Requires if any
6 # - python3 version
7 # - .pyo etc
8 %define         kdeframever     5.101
9 %define         qtver           5.15.2
10 %define         kfname          kapidox
11 Summary:        Kapidox
12 Name:           kf5-%{kfname}
13 Version:        5.101.0
14 Release:        1
15 License:        LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  8694c6bc1157af7c412077bad9ef59bc
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= 5.2.0
21 BuildRequires:  Qt5DBus-devel >= 5.2.0
22 BuildRequires:  Qt5Gui-devel >= 5.3.1
23 BuildRequires:  Qt5Test-devel
24 BuildRequires:  Qt5Widgets-devel >= 5.2.0
25 BuildRequires:  Qt5X11Extras-devel >= 5.2.0
26 BuildRequires:  cmake >= 2.8.12
27 BuildRequires:  kf5-extra-cmake-modules >= %{version}
28 BuildRequires:  ninja
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  sphinx-pdg
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires:       graphviz
35 Requires:       kf5-dirs
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         qt5dir          %{_libdir}/qt5
40
41 %description
42 This framework contains scripts and data for building API
43 documentation (dox) in a standard format and style.
44
45 The Doxygen tool is used to do the actual documentation extraction and
46 formatting, but this framework provides a wrapper script to make
47 generating the documentation more convenient (including reading
48 settings from the target framework or other module) and a standard
49 template for the generated documentation.
50
51 %prep
52 %setup -q -n %{kfname}-%{version}
53
54 %build
55 %py3_build
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %py3_install
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %attr(755,root,root) %{_bindir}/depdiagram_generate_all
67 %attr(755,root,root) %{_bindir}/kapidox-depdiagram-generate
68 %attr(755,root,root) %{_bindir}/kapidox-depdiagram-prepare
69 %attr(755,root,root) %{_bindir}/kapidox-generate
70 %{py3_sitescriptdir}/kapidox/
71 %{py3_sitescriptdir}/kapidox-*.egg-info
This page took 0.085737 seconds and 4 git commands to generate.