]> git.pld-linux.org Git - packages/kf5-kapidox.git/blob - kf5-kapidox.spec
- up to 5.13.0
[packages/kf5-kapidox.git] / kf5-kapidox.spec
1 # TODO:
2 # - runtime Requires if any
3 # - python3 version
4 # - .pyo etc
5 %define         kdeframever     5.13
6 %define         qtver           5.3.2
7 %define         kfname          kapidox
8 Summary:        Kapidox
9 Name:           kf5-%{kfname}
10 Version:        5.13.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  145d1c604e3db2a61a7174430ac25144
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= 5.2.0
18 BuildRequires:  Qt5DBus-devel >= 5.2.0
19 BuildRequires:  Qt5Gui-devel >= 5.3.1
20 BuildRequires:  Qt5Test-devel
21 BuildRequires:  Qt5Widgets-devel >= 5.2.0
22 BuildRequires:  Qt5X11Extras-devel >= 5.2.0
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  sphinx-pdg
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       graphviz
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 This framework contains scripts and data for building API
38 documentation (dox) in a standard format and style.
39
40 The Doxygen tool is used to do the actual documentation extraction and
41 formatting, but this framework provides a wrapper script to make
42 generating the documentation more convenient (including reading
43 settings from the target framework or other module) and a standard
44 template for the generated documentation.
45
46 %prep
47 %setup -q -n %{kfname}-%{version}
48
49 %build
50 install -d build
51 cd build
52 %cmake \
53         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
54         ..
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} -C build/ install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %attr(755,root,root) %{_bindir}/depdiagram-generate
69 %attr(755,root,root) %{_bindir}/depdiagram-generate-all
70 %attr(755,root,root) %{_bindir}/depdiagram-prepare
71 %attr(755,root,root) %{_bindir}/kgenapidox
72 %attr(755,root,root) %{_bindir}/kgenframeworksapidox
73 %{py_sitescriptdir}/kapidox
74 %{py_sitescriptdir}/kapidox-*.egg-info
75 %{_mandir}/man1/depdiagram-generate-all.1*
76 %{_mandir}/man1/depdiagram-generate.1*
77 %{_mandir}/man1/depdiagram-prepare.1*
78 %{_mandir}/man1/kgenapidox.1*
79 %{_mandir}/man1/kgenframeworksapidox.1*
80
This page took 0.063472 seconds and 4 git commands to generate.