]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kf5-extra-cmake-modules.spec
b2d2634bae4356b5d0e6cef6fbc40749c5a9e151
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         orgname         extra-cmake-modules
6 %define         kdeframever     5.71
7 Summary:        Extra Cmake Modules for KF5
8 Summary(pl.UTF-8):      Dodatkowe moduły Cmake'a dla KF5
9 Name:           kf5-%{orgname}
10 Version:        5.71.0
11 Release:        1
12 License:        BSD
13 Group:          Development/Building
14 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
15 # Source0-md5:  39590c81474016b01ce1bc29fb808c3e
16 Patch0:         %{orgname}-tests.patch
17 URL:            http://www.kde.org/
18 BuildRequires:  cmake >= 3.5
19 BuildRequires:  qt5-assistant >= 5.9.0
20 BuildRequires:  qt5-linguist
21 BuildRequires:  rpmbuild(macros) >= 1.698
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  sphinx-pdg >= 1.2
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 %if %{with tests}
27 BuildRequires:  Qt5Core-devel >= 5.9.0
28 BuildRequires:  Qt5Gui-devel >= 5.9.0
29 BuildRequires:  Qt5Network-devel >= 5.9.0
30 BuildRequires:  Qt5Qml-devel >= 5.9.0
31 BuildRequires:  Qt5Quick-devel >= 5.9.0
32 BuildRequires:  libstdc++-devel >= 6:5
33 BuildRequires:  qt5-build >= 5.9.0
34 %endif
35 Obsoletes:      kf5-extra-cmake-modules-doc
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The Extra CMake Modules package, or ECM, adds to the modules provided
40 by CMake, including both ones used by find_package() to find common
41 software and ones that can be used directly in CMakeLists.txt files to
42 perform common tasks.
43
44 In addition, it provides common build settings used in software
45 produced by the KDE community.
46
47 While the driving force of this module is to reduce duplication in
48 CMake scripts across KDE software, it is intended to be useful for any
49 software that uses the CMake build system.
50
51 %description -l pl.UTF-8
52 Pakiet Extra CMake Modules (ECM) dostarcza dodatkowe moduły do tych
53 dostarczanych przez CMake'a, zawierające te używane przez
54 find_package() do szukania popularnego oprogramowania, a także takie,
55 których można używać bezpośrednio w CMakeLists.txt do wykonywania
56 wspólnych zadań.
57
58 Ponadto pakiet dostarcza wspólne ustawienia budowana używane w
59 oprogramowaniu tworzonym przez społeczność KDE.
60
61 O ile główną motywacją tego modułu jest zmniejszenie duplikacji w
62 skryptach CMake'a w oprogramowaniu KDE, ma także być przydatny dla
63 dowolnych programów wykorzystujących system budowania CMake.
64
65 %prep
66 %setup -q -n %{orgname}-%{version}
67 %patch0 -p1
68
69 # causes make install failure after running tests
70 %{__sed} -i -e '/ECMToolchainAndroidTest/d' tests/CMakeLists.txt
71
72 %build
73 install -d build
74 cd build
75 %cmake .. \
76         %{!?with_tests:-DBUILD_TESTING=OFF}
77
78 %{__make}
79
80 %if %{with tests}
81 # GenerateSipBindings wants clang and has libclang checks incompatible with libclang >= 4
82 # ECMPoQmToolsTest fails to build it's own moc file
83 ctest -E '(GenerateSipBindings|ECMPoQmToolsTest)'
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} -C build -j1 install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %{__mv} $RPM_BUILD_ROOT%{_docdir}/ECM ECM-doc
93 install -d $RPM_BUILD_ROOT%{_datadir}/qlogging-categories5
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc COPYING-CMAKE-SCRIPTS README.rst ECM-doc/*
101 %{_datadir}/ECM
102 %{_datadir}/qlogging-categories5
103 %{_mandir}/man7/ecm*.7*
This page took 0.054712 seconds and 2 git commands to generate.