]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kf5-extra-cmake-modules.spec
- restored noarch condition
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
1 # TODO where to put files and docs of KF5
2 %define         _state          stable
3 %define         orgname         extra-cmake-modules
4
5 Summary:        Extra Cmake Modules for KF5
6 Name:           kf5-extra-cmake-modules
7 Version:        1.0.0
8 Release:        0.2
9 License:        See COPYING-CMAKE-SCRIPTS
10 Group:          X11/Libraries
11 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/5.0.0/%{orgname}-%{version}.tar.xz
12 # Source0-md5:  a7b9e8756fdc2b3a8518ad9f9d21dfd5
13 URL:            http://www.kde.org/
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  rpmbuild(macros) >= 1.164
16 BuildRequires:  sphinx-pdg
17 BuildRequires:  tar >= 1:1.22
18 BuildRequires:  xz
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         qt5dir          %{_libdir}/qt5
22
23 %description
24 The Extra CMake Modules package, or ECM, adds to the modules provided
25 by CMake, including both ones used by ``find_package()`` to find
26 common software and ones that can be used directly in
27 ``CMakeLists.txt`` files to perform common tasks.
28
29 In addition, it provides common build settings used in software
30 produced by the KDE community.
31
32 While the driving force of this module is to reduce duplication in
33 CMake scripts across KDE software, it is intended to be useful for any
34 software that uses the CMake build system.
35
36 %package doc
37 Summary:        Documentation for ECM
38 Group:          Documentation
39 %if "%{_rpmversion}" >= "5"
40 BuildArch:     noarch
41 %endif
42
43 %description doc
44 Documentation for ECM.
45
46 %prep
47 %setup -q -n %{orgname}-%{version}
48
49 %build
50 install -d build
51 cd build
52 %cmake \
53         -DBIN_INSTALL_DIR=%{_bindir} \
54         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
55         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
56         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
57         -DQML_INSTALL_DIR=%{qt5dir}/qml \
58         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
59         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
60         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
61         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
62         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
63         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
64         -D_IMPORT_PREFIX=%{_prefix} \
65         ../
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} -C build/ install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc COPYING-CMAKE-SCRIPTS README.rst
80 %{_datadir}/ECM
81 %{_mandir}/man7/ecm*
82
83 %files doc
84 %defattr(644,root,root,755)
85 %{_docdir}/ECM
This page took 0.037124 seconds and 3 git commands to generate.