]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kf5-extra-cmake-modules.spec
- more cmake substituition
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
1 # TODO where to put files and docs of KF5
2 %define         _state          stable
3 %define         orgname         extra-cmake-modules
4
5 Summary:        Extra Cmake Modules for KF5
6 Name:           kf5-extra-cmake-modules
7 Version:        1.0.0
8 Release:        0.2
9 License:        See COPYING-CMAKE-SCRIPTS
10 Group:          X11/Libraries
11 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/5.0.0/%{orgname}-%{version}.tar.xz
12 # Source0-md5:  a7b9e8756fdc2b3a8518ad9f9d21dfd5
13 URL:            http://www.kde.org/
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  rpmbuild(macros) >= 1.164
16 BuildRequires:  sphinx-pdg
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         qt5dir          %{_libdir}/qt5
20
21 %description
22 The Extra CMake Modules package, or ECM, adds to the modules provided
23 by CMake, including both ones used by ``find_package()`` to find
24 common software and ones that can be used directly in
25 ``CMakeLists.txt`` files to perform common tasks.
26
27 In addition, it provides common build settings used in software
28 produced by the KDE community.
29
30 While the driving force of this module is to reduce duplication in
31 CMake scripts across KDE software, it is intended to be useful for any
32 software that uses the CMake build system.
33
34 %package doc
35 Summary:        Documentation for ECM
36 Group:          Documentation
37 BuildArch:      noarch
38
39 %description doc
40 Documentation for ECM.
41
42 %prep
43 %setup -q -n %{orgname}-%{version}
44
45 %build
46 install -d build
47 cd build
48 %cmake \
49         -DBIN_INSTALL_DIR=%{_bindir} \
50         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
51         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
52         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
53         -DQML_INSTALL_DIR=%{qt5dir}/qml \
54         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
55         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
56         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
57         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
58         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
59         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
60         -D_IMPORT_PREFIX=%{_prefix} \
61         ../
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} -C build/ install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc COPYING-CMAKE-SCRIPTS README.rst
76 %{_datadir}/ECM
77 %{_mandir}/man7/ecm*
78
79 %files doc
80 %defattr(644,root,root,755)
81 %{_docdir}/ECM
This page took 0.045817 seconds and 3 git commands to generate.