]> git.pld-linux.org Git - SPECS.git/blob - kerneloops.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / kerneloops.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        Tool to automatically collect and submit kernel crash signatures
6 Name:           kerneloops
7 Version:        0.12
8 Release:        2
9 License:        GPL v2
10 Group:          Base/Kernel
11 Source0:        http://www.kerneloops.org/download/%{name}-%{version}.tar.gz
12 # Source0-md5:  97e611e5b09831cb6ee31c31bf2bc286
13 Source1:        %{name}.init
14 Source2:        %{name}.sysconfig
15 URL:            http://www.kerneloops.org
16 BuildRequires:  curl-devel
17 BuildRequires:  dbus-glib-devel
18 BuildRequires:  desktop-file-utils
19 BuildRequires:  gettext-tools
20 BuildRequires:  gtk+2-devel
21 BuildRequires:  libnotify-devel
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 %if %{with tests}
24 %ifnarch %{ix86} %{x8664} ppc ppc64
25 BuildRequires:  valgrind
26 %endif
27 %endif
28 Requires:       rc-scripts
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This package contains the tools to collect kernel crash signatures,
33 and to submit them to the kerneloops.org website where the kernel
34 crash signatures get collected and grouped for presentation to the
35 Linux kernel developers.
36
37 %prep
38 %setup -q
39
40 %build
41 %{__make} \
42         CC="%{__cc}" \
43         CFLAGS="%{rpmcflags} -DDBUS_API_SUBJECT_TO_CHANGE"
44
45 %{?with_tests:%{__make} tests}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
56 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
57
58 %find_lang %{name}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 /sbin/chkconfig --add %{name}
65 %service %{name} restart
66
67 %preun
68 if [ "$1" = "0" ]; then
69         %service %{name} stop
70         /sbin/chkconfig --del %{name}
71 fi
72
73 %files -f %{name}.lang
74 %defattr(644,root,root,755)
75 %doc Changelog
76 %attr(755,root,root) %{_sbindir}/%{name}
77 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kerneloops.conf
78 %attr(754,root,root) /etc/rc.d/init.d/%{name}
79 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
80 /etc/dbus-1/system.d/kerneloops.dbus
81 %{_sysconfdir}/xdg/autostart/kerneloops-applet.desktop
82 %{_datadir}/kerneloops
83 %attr(755,root,root) %{_bindir}/kerneloops-applet
84 %{_mandir}/man8/kerneloops.8*
This page took 2.484096 seconds and 3 git commands to generate.