]> git.pld-linux.org Git - SPECS.git/blob - kernel-net-3c990.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / kernel-net-3c990.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel             # without distribution kernel
4 #
5 %define         _orig_name      3c990
6
7 Summary:        Linux driver for the 3Com 3C990 Network Interface Cards
8 Summary(pl.UTF-8):      Sterownik dla Linuksa do kart sieciowych 3Com 3C990
9 Name:           kernel-net-%{_orig_name}
10 Version:        1.0.0a
11 %define _rel    10
12 Release:        %{_rel}@%{_kernel_ver_str}
13 License:        GPL
14 Group:          Base/Kernel
15 Source0:        http://support.3com.com/infodeli/tools/nic/linux/%{_orig_name}-%{version}.tar.gz
16 # Source0-md5:  e7597b2747a18f0cfe7bc81e83a2bc68
17 Patch0:         %{_orig_name}-redefine.patch
18 %{?with_dist_kernel:BuildRequires:      kernel-headers }
19 BuildRequires:  %{kgcc_package}
20 BuildRequires:  rpmbuild(macros) >= 1.118
21 %{?with_dist_kernel:%requires_releq_kernel_up}
22 Requires(post,postun):  /sbin/depmod
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This driver (3c990.c) has been written to work with the 3c990 product
27 line of network cards, manufactured by 3Com Corp.
28
29 This driver is not intended for any other product line, including the
30 3c59x or 3c90x product lines (although drivers with both of these
31 names, and for both of these product lines, are available).
32
33 %description -l pl.UTF-8
34 Sterownik dla Linuksa do kart sieciowych 3Com 3c990.
35
36 Nie obsługuje kart serii 3c59x i 3c90x, istnieją inne sterowniki do
37 tych linii produktów.
38
39 %package -n kernel-smp-net-%{_orig_name}
40 Summary:        Linux SMP driver for the 3Com 3C990 Network Interface Cards
41 Summary(pl.UTF-8):      Sterownik dla Linuksa SMP dla kart sieciowych 3Com 3C990
42 Release:        %{_rel}@%{_kernel_ver_str}
43 Group:          Base/Kernel
44 %{?with_dist_kernel:%requires_releq_kernel_smp}
45 Requires(post,postun):  /sbin/depmod
46
47 %description -n kernel-smp-net-%{_orig_name}
48 This driver (3c990.c) has been written to work with the 3c990 product
49 line of network cards, manufactured by 3Com Corp on SMP systems.
50
51 This driver is not intended for any other product line, including the
52 3c59x or 3c90x product lines (although drivers with both of these
53 names, and for both of these product lines, are available).
54
55 %description -n kernel-smp-net-%{_orig_name} -l pl.UTF-8
56 Sterownik dla Linuksa SMP do kart sieciowych 3Com 3c990.
57
58 Nie obsługuje kart serii 3c59x i 3c90x, istnieją inne sterowniki do
59 tych linii produktów.
60
61 %prep
62 %setup -q -n %{_orig_name}-%{version} -c
63 %patch0 -p0
64
65 %build
66 rm -f %{_orig_name}.o
67 %{kgcc} -o %{_orig_name}.o -c %{rpmcflags} -c -DMODULE -D__KERNEL__ -O2 -DSMP=1 -D__SMP__ -DCONFIG_X86_LOCAL_APIC -Wall -Wstrict-prototypes -I%{_kernelsrcdir}/include %{_orig_name}.c
68 mv -f %{_orig_name}.o %{_orig_name}-smp.o
69 %{kgcc} -o %{_orig_name}.o -c %{rpmcflags} -c -DMODULE -D__KERNEL__ -O2 -Wall -Wstrict-prototypes -I%{_kernelsrcdir}/include %{_orig_name}.c
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
74
75 install %{_orig_name}-smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/%{_orig_name}.o
76 install %{_orig_name}.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/%{_orig_name}.o
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 %depmod %{_kernel_ver}
83
84 %postun
85 %depmod %{_kernel_ver}
86
87 %post   -n kernel-smp-net-%{_orig_name}
88 %depmod %{_kernel_ver}smp
89
90 %postun -n kernel-smp-net-%{_orig_name}
91 %depmod %{_kernel_ver}smp
92
93 %files
94 %defattr(644,root,root,755)
95 %doc README
96 /lib/modules/%{_kernel_ver}/misc/*
97
98 %files -n kernel-smp-net-%{_orig_name}
99 %defattr(644,root,root,755)
100 %doc README
101 /lib/modules/%{_kernel_ver}smp/misc/*
This page took 0.504584 seconds and 3 git commands to generate.