]> git.pld-linux.org Git - packages/kde4-print-manager.git/blob - kde4-print-manager.spec
- fix building with cups 2.2+
[packages/kde4-print-manager.git] / kde4-print-manager.spec
1 #
2 %define         _state          stable
3 %define         orgname         print-manager
4 %define         qtver           4.8.0
5 %define         kdeworkspacever 4.11.0
6
7 Summary:        K Desktop Environment - print manager
8 Name:           kde4-print-manager
9 Version:        4.14.3
10 Release:        3
11 License:        GPL
12 Group:          X11/Applications
13 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
14 # Source0-md5:  234e9152d0b0f17b65cbc62407e03094
15 Patch0:         cups-2.2.patch
16 URL:            http://www.kde.org/
17 BuildRequires:  automoc4
18 BuildRequires:  cups-devel
19 BuildRequires:  kde4-kdebase-devel >= %{version}
20 BuildRequires:  qt4-build
21 Requires:       kde4-kdebase-workspace >= %{kdeworkspacever}
22 Obsoletes:      kde4-kdeutils-print-manager
23 Obsoletes:      kde4-printer-manager
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Printer Applet is a system tray utility that shows current print jobs,
28 shows printer warnings and errors.
29
30 %description -l pl.UTF-8
31 Printer Applet to narzedzie zasobnika systemowego, ktore pokazuje
32 aktualne zadania drukarki, ostrzezenia i bledy.
33
34 %prep
35 %setup -q -n %{orgname}-%{version}
36 %patch0 -p1
37
38 %build
39 install -d build
40 cd build
41 %cmake \
42         -DINSTALL_PRINTER_APPLET=TRUE \
43         ..
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} -C build/ install \
50         DESTDIR=$RPM_BUILD_ROOT \
51         kde_htmldir=%{_kdedocdir}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %attr(755,root,root) %{_bindir}/kde-add-printer
59 %attr(755,root,root) %{_bindir}/kde-print-queue
60 %dir %{_libdir}/kde4/imports/org/kde/printmanager
61 %{_libdir}/kde4/imports/org/kde/printmanager/qmldir
62 %attr(755,root,root) %{_libdir}/kde4/imports/org/kde/printmanager/libprintmanager.so
63 %attr(755,root,root) %{_libdir}/kde4/kcm_printer_manager.so
64 %attr(755,root,root) %{_libdir}/kde4/kded_printmanager.so
65 %attr(755,root,root) %{_libdir}/kde4/libexec/configure-printer
66 #%attr(755,root,root) %{_libdir}/kde4/plugins/designer/printmanagerwidget.so
67 %attr(755,root,root) %{_libdir}/libkcupslib.so
68 %{_datadir}/apps/plasma/plasmoids/org.kde.printmanager
69 %{_datadir}/apps/printmanager
70 %{_datadir}/dbus-1/services/org.kde.ConfigurePrinter.service
71 %{_datadir}/kde4/services/kcm_printer_manager.desktop
72 %{_datadir}/kde4/services/kded/printmanager.desktop
73 %{_datadir}/kde4/services/plasma-applet-printmanager.desktop
This page took 0.09053 seconds and 4 git commands to generate.