]> git.pld-linux.org Git - packages/kde4-libkcddb.git/blob - kde4-libkcddb.spec
use libmusicbrainz5 engine, release 2.
[packages/kde4-libkcddb.git] / kde4-libkcddb.spec
1 %define         _state          stable
2 %define         orgname         libkcddb
3 %define         qtver           4.8.1
4
5 Summary:        CDDB accessing library
6 Summary(pl.UTF-8):      Biblioteka dostępu do baz CDDB
7 Name:           kde4-%{orgname}
8 Version:        4.9.1
9 Release:        2
10 License:        GPL v2+
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  ebdef6e8697921fa66b405807c074bf4
14 BuildRequires:  cmake >= 2.8.0
15 BuildRequires:  kde4-kdelibs-devel >= %{version}
16 BuildRequires:  libmusicbrainz5-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  qt4-build >= %{qtver}
20 BuildRequires:  qt4-qmake >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.600
22 Requires:       kde4-kdelibs >= %{version}
23 Obsoletes:      kde4-kdemultimedia-libkcddb < 4.8.99-1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Library for accessing CDDB (cd track information databases) services.
28
29 %description -l pl.UTF-8
30 Biblioteka dostępu do serwisów CDDB (baz danych z informacjami o
31 utworach).
32
33 %package devel
34 Summary:        Header files for libkcddb library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libkcddb
36 Group:          X11/Development/Libraries
37 Requires:       %{name} >= %{version}-%{release}
38 Requires:       kde4-kdelibs-devel >= %{version}
39
40 %description devel
41 Header files for libkcddb library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki libkcddb.
45
46 %prep
47 %setup -q -n %{orgname}-%{version}
48
49 %build
50 install -d build
51 cd build
52 %cmake \
53         ../
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} -C build install \
61         DESTDIR=$RPM_BUILD_ROOT \
62         kde_htmldir=%{_kdedocdir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post   -p /sbin/ldconfig
68 %postun -p /sbin/ldconfig
69
70 %files
71 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_libdir}/libkcddb.so.4.*.*
73 %attr(755,root,root) %ghost %{_libdir}/libkcddb.so.?
74 %attr(755,root,root) %{_libdir}/kde4/kcm_cddb.so
75 %{_datadir}/apps/kconf_update/kcmcddb-emailsettings.upd
76 %{_datadir}/config.kcfg/libkcddb.kcfg
77 %{_datadir}/kde4/services/libkcddb.desktop
78 %{_docdir}/kde/HTML/en/kcontrol/cddbretrieval
79
80 %files devel
81 %defattr(644,root,root,755)
82 %{_includedir}/libkcddb
83 %attr(755,root,root) %{_libdir}/libkcddb.so
84 %dir %{_libdir}/cmake/libkcddb
85 %{_libdir}/cmake/libkcddb/LibkcddbConfig.cmake
86 %{_libdir}/cmake/libkcddb/LibkcddbTargets-pld.cmake
87 %{_libdir}/cmake/libkcddb/LibkcddbTargets.cmake
This page took 0.050957 seconds and 3 git commands to generate.