]> git.pld-linux.org Git - packages/kde4-kopete.git/blob - kde4-kopete.spec
- release 13
[packages/kde4-kopete.git] / kde4-kopete.spec
1 #
2 # Conditional build:
3 %bcond_with     npapi           # NPAPI browser plugin (skypebuttons)
4 %bcond_with     libjingle       # libjingle support in Jabber
5
6 %define         orgname         kopete
7 %define         qt_ver          4.8.3
8
9 Summary:        Multi-protocol plugin-based instant messenger
10 Summary(pl.UTF-8):      Komunikator obsługujący wiele protokołów
11 Name:           kde4-kopete
12 Version:        4.14.3
13 Release:        13
14 License:        GPL v2+ with OpenSSL exception (kopete), LGPL v2+ (libkopete)
15 Group:          X11/Applications
16 Source0:        https://download.kde.org/Attic/%{version}/src/%{orgname}-%{version}.tar.xz
17 # Source0-md5:  d05e478101292ebb08da2af00d1329ab
18 Patch0:         %{name}-FindLibgadu.patch
19 Patch1:         %{name}-libsrtp2.patch
20 Patch2:         mediastreamer.patch
21 Patch3:         gcc6.patch
22 Patch4:         macros.patch
23 Patch5:         %{name}-qt.patch
24 Patch6:         %{name}-no-libnsl.patch
25 URL:            https://kde.org/
26 BuildRequires:  Qt3Support-devel >= %{qt_ver}
27 BuildRequires:  QtCore-devel >= %{qt_ver}
28 BuildRequires:  QtGui-devel >= %{qt_ver}
29 BuildRequires:  QtNetwork-devel >= %{qt_ver}
30 BuildRequires:  QtSql-devel >= %{qt_ver}
31 BuildRequires:  QtTest-devel >= %{qt_ver}
32 BuildRequires:  QtXml-devel >= %{qt_ver}
33 %{?with_libjingle:BuildRequires:        alsa-lib-devel}
34 BuildRequires:  automoc4
35 BuildRequires:  boost-devel
36 BuildRequires:  cmake >= 2.8.0
37 %{?with_libjingle:BuildRequires:        expat-devel >= 1.95}
38 BuildRequires:  giflib-devel
39 BuildRequires:  glib2-devel >= 2.0
40 BuildRequires:  jasper-devel
41 %{?with_libjingle:BuildRequires:        jsoncpp-devel}
42 BuildRequires:  kde4-kdebase-devel >= %{version}
43 # for libkleo
44 BuildRequires:  kde4-kdepim-devel >= 4.14.0-2
45 # FIXME: it contains libkleo.so symlink by mistake
46 BuildRequires:  kde4-kdepim-kmail >= 4.14.0-2
47 BuildRequires:  kde4-kdepimlibs-devel >= 4.14.0-2
48 BuildRequires:  libgadu-devel >= 1.8.0
49 BuildRequires:  libidn-devel
50 BuildRequires:  libmsn-devel >= 4.1
51 BuildRequires:  libotr-devel >= 4.0.0
52 %{?with_libjingle:BuildRequires:        libsrtp2-devel >= 2}
53 BuildRequires:  libv4l-devel
54 BuildRequires:  libxml2-devel >= 2.0
55 BuildRequires:  libxslt-devel
56 BuildRequires:  meanwhile-devel
57 BuildRequires:  mediastreamer-devel >= 2.3.0
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  ortp-devel >= 0.16.1-3
60 BuildRequires:  qca-devel >= 2.0.0
61 BuildRequires:  qimageblitz-devel
62 BuildRequires:  qt4-build >= %{qt_ver}
63 BuildRequires:  qt4-qmake >= %{qt_ver}
64 BuildRequires:  pkgconfig
65 BuildRequires:  rpm-pythonprov
66 BuildRequires:  rpmbuild(macros) >= 1.605
67 # disabled in CMakeLists.txt
68 #BuildRequires: speex-devel
69 # for statistics plugin? (only checked, not used)
70 #BuildRequires: sqlite-devel
71 BuildRequires:  xmms-devel
72 BuildRequires:  xorg-lib-libX11-devel
73 BuildRequires:  xorg-lib-libXScrnSaver-devel
74 BuildRequires:  zlib-devel
75 Requires:       Qt3Support >= %{qt_ver}
76 Requires:       QtCore >= %{qt_ver}
77 Requires:       QtGui >= %{qt_ver}
78 Requires:       QtNetwork >= %{qt_ver}
79 Requires:       QtSql >= %{qt_ver}
80 Requires:       QtXml >= %{qt_ver}
81 Requires:       kde4-kdelibs >= %{version}
82 Requires:       kde4-kdepim-libs >= 4.14.0
83 Requires:       kde4-kdepimlibs >= 4.14.0
84 Requires:       libgadu >= 1.8.0
85 Requires:       libmsn >= 4.1
86 Requires:       libotr >= 4.0.0
87 Requires:       mediastreamer >= 2.3.0
88 Requires:       ortp >= 0.16.1-3
89 Obsoletes:      kde4-kdenetwork-kopete < 4.11
90 Obsoletes:      kde4-kdenetwork-kopete-protocol-aim < 4.11
91 Obsoletes:      kde4-kdenetwork-kopete-protocol-bonjour < 4.11
92 Obsoletes:      kde4-kdenetwork-kopete-protocol-gg < 4.11
93 Obsoletes:      kde4-kdenetwork-kopete-protocol-groupwise < 4.11
94 Obsoletes:      kde4-kdenetwork-kopete-protocol-icq < 4.11
95 Obsoletes:      kde4-kdenetwork-kopete-protocol-jabber < 4.11
96 Obsoletes:      kde4-kdenetwork-kopete-protocol-meanwhile < 4.11
97 Obsoletes:      kde4-kdenetwork-kopete-protocol-msn < 4.11
98 Obsoletes:      kde4-kdenetwork-kopete-protocol-skype < 4.11
99 Obsoletes:      kde4-kdenetwork-kopete-protocol-sms < 4.11
100 Obsoletes:      kde4-kdenetwork-kopete-protocol-testbed < 4.11
101 Obsoletes:      kde4-kdenetwork-kopete-protocol-winpopup < 4.11
102 Obsoletes:      kde4-kdenetwork-kopete-protocol-wlm < 4.11
103 Obsoletes:      kde4-kdenetwork-kopete-protocol-yahoo < 4.11
104 Obsoletes:      kde4-kdenetwork-kopete-tool-alias < 4.11
105 Obsoletes:      kde4-kdenetwork-kopete-tool-autoaway < 4.11
106 Obsoletes:      kde4-kdenetwork-kopete-tool-autoreplace < 4.11
107 Obsoletes:      kde4-kdenetwork-kopete-tool-avdeviceconfig < 4.11
108 Obsoletes:      kde4-kdenetwork-kopete-tool-contactnotes < 4.11
109 Obsoletes:      kde4-kdenetwork-kopete-tool-highlight < 4.11
110 Obsoletes:      kde4-kdenetwork-kopete-tool-history < 4.11
111 Obsoletes:      kde4-kdenetwork-kopete-tool-importer < 4.11
112 Obsoletes:      kde4-kdenetwork-kopete-tool-latex < 4.11
113 Obsoletes:      kde4-kdenetwork-kopete-tool-motionaway < 4.11
114 Obsoletes:      kde4-kdenetwork-kopete-tool-nowlistening < 4.11
115 Obsoletes:      kde4-kdenetwork-kopete-tool-spellcheck < 4.11
116 Obsoletes:      kde4-kdenetwork-kopete-tool-texteffect < 4.11
117 Obsoletes:      kde4-kdenetwork-kopete-tool-translator < 4.11
118 Obsoletes:      kde4-kdenetwork-kopete-tool-webpresence < 4.11
119 Obsoletes:      kde4-kdenetwork-libkopete < 4.11
120 Obsoletes:      kde4-kdenetwork-libkopete_oscar < 4.11
121 Obsoletes:      kde4-kdenetwork-libkopete_otr < 4.11
122 Obsoletes:      kde4-kdenetwork-libkopete_videodevice < 4.11
123 Obsoletes:      kdenetwork-libkopete < 10:4
124 Obsoletes:      kdenetwork-libkopete_msn < 10:4
125 Obsoletes:      kdenetwork-libkopete_videodevice < 10:4
126 Obsoletes:      kdenetwork-libkopete_oscar < 10:4
127 Obsoletes:      kdenetwork-kopete < 10:4
128 Obsoletes:      kdenetwork-kopete-protocol-aim < 10:4
129 Obsoletes:      kdenetwork-kopete-protocol-gg < 10:4
130 Obsoletes:      kdenetwork-kopete-protocol-groupwise < 10:4
131 Obsoletes:      kdenetwork-kopete-protocol-icq < 10:4
132 Obsoletes:      kdenetwork-kopete-protocol-irc < 10:4
133 Obsoletes:      kdenetwork-kopete-protocol-jabber < 10:4
134 Obsoletes:      kdenetwork-kopete-protocol-meanwhile < 10:4
135 Obsoletes:      kdenetwork-kopete-protocol-msn < 10:4
136 Obsoletes:      kdenetwork-kopete-protocol-skype < 10:4
137 Obsoletes:      kdenetwork-kopete-protocol-sms < 10:4
138 Obsoletes:      kdenetwork-kopete-protocol-winpopup < 10:4
139 Obsoletes:      kdenetwork-kopete-protocol-yahoo < 10:4
140 Obsoletes:      kdenetwork-kopete-protocol-testbed < 10:4
141 Obsoletes:      kdenetwork-kopete-tool-alias < 10:4
142 Obsoletes:      kdenetwork-kopete-tool-autoaway < 10:4
143 Obsoletes:      kdenetwork-kopete-tool-autoreplace < 10:4
144 Obsoletes:      kdenetwork-kopete-tool-avdeviceconfig < 10:4
145 Obsoletes:      kdenetwork-kopete-tool-conectionstatus < 10:4
146 Obsoletes:      kdenetwork-kopete-tool-contactnotes < 10:4
147 Obsoletes:      kdenetwork-kopete-tool-cryptography < 10:4
148 Obsoletes:      kdenetwork-kopete-tool-highlight < 10:4
149 Obsoletes:      kdenetwork-kopete-tool-history < 10:4
150 Obsoletes:      kdenetwork-kopete-tool-importer < 10:4
151 Obsoletes:      kdenetwork-kopete-tool-latex < 10:4
152 Obsoletes:      kdenetwork-kopete-tool-motionaway < 10:4
153 Obsoletes:      kdenetwork-kopete-tool-nowlistening < 10:4
154 Obsoletes:      kdenetwork-kopete-tool-smpppdcs < 10:4
155 Obsoletes:      kdenetwork-kopete-tool-spellcheck < 10:4
156 Obsoletes:      kdenetwork-kopete-tool-texteffect < 10:4
157 Obsoletes:      kdenetwork-kopete-tool-translator < 10:4
158 Obsoletes:      kdenetwork-kopete-tool-webpresence < 10:4
159 Obsoletes:      kopete < 1
160 Obsoletes:      kopete-designer < 1
161 Obsoletes:      kopete-libkopete < 1
162 Obsoletes:      kopete-libkopete_msn < 1
163 Obsoletes:      kopete-libkopete_videodevice < 1
164 Obsoletes:      kopete-libkopete_oscar < 1
165 Obsoletes:      kopete-plugin-protocols-aim < 1
166 Obsoletes:      kopete-plugin-protocols-gg < 1
167 Obsoletes:      kopete-plugin-protocols-icq < 1
168 Obsoletes:      kopete-plugin-protocols-irc < 1
169 Obsoletes:      kopete-plugin-protocols-jabber < 1
170 Obsoletes:      kopete-plugin-protocols-msn < 1
171 Obsoletes:      kopete-plugin-protocols-oscar < 1
172 Obsoletes:      kopete-plugin-protocols-sms < 1
173 Obsoletes:      kopete-plugin-protocols-winpopup < 1
174 Obsoletes:      kopete-plugin-protocols-yahoo < 1
175 Obsoletes:      kopete-plugin-tools-autoaway < 1
176 Obsoletes:      kopete-plugin-tools-autoreplace < 1
177 Obsoletes:      kopete-plugin-tools-conectionstatus < 1
178 Obsoletes:      kopete-plugin-tools-contactnotes < 1
179 Obsoletes:      kopete-plugin-tools-cryptography < 1
180 Obsoletes:      kopete-plugin-tools-highlight < 1
181 Obsoletes:      kopete-plugin-tools-history < 1
182 Obsoletes:      kopete-plugin-tools-importer < 1
183 Obsoletes:      kopete-plugin-tools-motionaway < 1
184 Obsoletes:      kopete-plugin-tools-nowlistening < 1
185 Obsoletes:      kopete-plugin-tools-spellcheck < 1
186 Obsoletes:      kopete-plugin-tools-texteffect < 1
187 Obsoletes:      kopete-plugin-tools-translator < 1
188 Obsoletes:      kopete-plugin-tools-webpresence < 1
189 Obsoletes:      kopete-protocol-aim < 1
190 Obsoletes:      kopete-protocol-gg < 1
191 Obsoletes:      kopete-protocol-groupwise < 1
192 Obsoletes:      kopete-protocol-icq < 1
193 Obsoletes:      kopete-protocol-irc < 1
194 Obsoletes:      kopete-protocol-jabber < 1
195 Obsoletes:      kopete-protocol-meanwhile < 1
196 Obsoletes:      kopete-protocol-msn < 1
197 Obsoletes:      kopete-protocol-sms < 1
198 Obsoletes:      kopete-protocol-winpopup < 1
199 Obsoletes:      kopete-protocol-yahoo < 1
200 Obsoletes:      kopete-tool-alias < 1
201 Obsoletes:      kopete-tool-autoaway < 1
202 Obsoletes:      kopete-tool-autoreplace < 1
203 Obsoletes:      kopete-tool-avdeviceconfig < 1
204 Obsoletes:      kopete-tool-connectionstatus < 1
205 Obsoletes:      kopete-tool-contactnotes < 1
206 Obsoletes:      kopete-tool-cryptography < 1
207 Obsoletes:      kopete-tool-highlight < 1
208 Obsoletes:      kopete-tool-history < 1
209 Obsoletes:      kopete-tool-importer < 1
210 Obsoletes:      kopete-tool-latex < 1
211 Obsoletes:      kopete-tool-motionaway < 1
212 Obsoletes:      kopete-tool-nowlistening < 1
213 Obsoletes:      kopete-tool-smpppdcs < 1
214 Obsoletes:      kopete-tool-spellcheck < 1
215 Obsoletes:      kopete-tool-texteffect < 1
216 Obsoletes:      kopete-tool-translator < 1
217 Obsoletes:      kopete-tool-webpresence < 1
218 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
219
220 %description
221 Kopete is a flexible and extendable multiple protocol instant
222 messaging system designed as a plugin-based system. All protocols are
223 plugins and allow modular installment, configuration, and usage
224 without the main application knowing anything about the plugin being
225 loaded. The goal of Kopete is to provide users with a standard and
226 easy to use interface between all of their instant messaging systems,
227 but at the same time also providing developers with the ease of
228 writing plugins to support a new protocol. The core Kopete development
229 team provides a handful of plugins that most users can use, in
230 addition to templates for new developers to base a plugin off of.
231
232 %description -l pl.UTF-8
233 Kopete to rozszerzalny i rozbudowywalny komunikator obsługujący wiele
234 protokołów, zaprojektowany w oparciu o wtyczki. Wszystkie protokoły są
235 wtyczkami, co pozwala na modularną instalację, konfigurację i używanie
236 bez potrzeby obsługi ładowanych wtyczek w głównej aplikacji. Celem
237 Kopete jest wyposażenie użytkowników w standardowy i łatwy w użyciu
238 interfejs pomiędzy wszystkimi systemami komunikatorów, a jednocześnie
239 zapewnienie programistom łatwości pisania wtyczek obsługujących nowe
240 protokoły. Załoga programistów Kopete udostępnia podręczny zestaw
241 wtyczek używanych przez większość użytkowników oraz szablony dla
242 nowych programistów, na których można opierać nowe wtyczki.
243
244 %package devel
245 Summary:        kopete header files
246 Summary(pl.UTF-8):      Pliki nagłówkowe kopete
247 License:        LGPL v2+
248 Group:          X11/Development/Libraries
249 Requires:       %{name} = %{version}-%{release}
250 Requires:       kde4-kdelibs-devel >= %{version}
251 Obsoletes:      kopete-devel < 1
252
253 %description devel
254 kopete header files.
255
256 %description devel -l pl.UTF-8
257 Pliki nagłówkowe kopete.
258
259 %description devel -l pt_BR.UTF-8
260 Arquivos de inclusão para compilar aplicações que usem as bibliotecas
261 do kopete.
262
263 %package -n browser-plugin-kde4-kopete-skypebuttons
264 Summary:        Skypebuttons plugin for NPAPI compatible browsers
265 Summary(pl.UTF-8):      Wtyczka skypebuttons dla przeglądarek zgodnych z NPAPI
266 Group:          X11/Applications/Networking
267 Requires:       %{name} = %{version}-%{release}
268
269 %description -n browser-plugin-kde4-kopete-skypebuttons
270 Skypebuttons plugin for NPAPI compatible browsers.
271
272 %description -n browser-plugin-kde4-kopete-skypebuttons -l pl.UTF-8
273 Wtyczka skypebuttons dla przeglądarek zgodnych z NPAPI.
274
275 %prep
276 %setup -q -n %{orgname}-%{version}
277 %patch0 -p1
278 %patch1 -p1
279 %patch2 -p1
280 %patch3 -p1
281 %patch4 -p1
282 %patch5 -p1
283 %patch6 -p1
284
285 %build
286 install -d build
287 cd build
288 %cmake .. \
289         %{!?with_npapi:-DBUILD_skypebuttons=OFF} \
290         -DMOZPLUGIN_INSTALL_DIR=%{_browserpluginsdir} \
291         %{!?with_libjingle:-DWITH_libjingle=OFF}
292
293 %{__make}
294
295 %install
296 rm -rf $RPM_BUILD_ROOT
297
298 %{__make} -C build install \
299         DESTDIR=$RPM_BUILD_ROOT \
300         kde_htmldir=%{_kdedocdir}
301
302 %find_lang kopete --with-kde
303
304 %clean
305 rm -rf $RPM_BUILD_ROOT
306
307 %post
308 /sbin/ldconfig
309 %update_browser_plugins
310
311 %postun
312 /sbin/ldconfig
313 if [ "$1" = 0 ]; then
314         %update_browser_plugins
315 fi
316
317 %files -f kopete.lang
318 %defattr(644,root,root,755)
319 %doc COPYING README TODO
320 %attr(755,root,root) %{_bindir}/kopete
321 %attr(755,root,root) %{_bindir}/kopete_latexconvert.sh
322 %attr(755,root,root) %{_bindir}/winpopup-install
323 %attr(755,root,root) %{_bindir}/winpopup-send
324 %attr(755,root,root) %{_libdir}/libkopete.so.*.*.*
325 %attr(755,root,root) %ghost %{_libdir}/libkopete.so.4
326 %attr(755,root,root) %{_libdir}/libkopete_oscar.so.*.*.*
327 %attr(755,root,root) %ghost %{_libdir}/libkopete_oscar.so.4
328 %attr(755,root,root) %{_libdir}/libkopete_otr_shared.so.*.*.*
329 %attr(755,root,root) %ghost %{_libdir}/libkopete_otr_shared.so.1
330 %attr(755,root,root) %{_libdir}/libkopete_videodevice.so.*.*.*
331 %attr(755,root,root) %ghost %{_libdir}/libkopete_videodevice.so.4
332 %attr(755,root,root) %{_libdir}/libkopeteaddaccountwizard.so.*.*.*
333 %attr(755,root,root) %ghost %{_libdir}/libkopeteaddaccountwizard.so.1
334 %attr(755,root,root) %{_libdir}/libkopetechatwindow_shared.so.*.*.*
335 %attr(755,root,root) %ghost %{_libdir}/libkopetechatwindow_shared.so.1
336 %attr(755,root,root) %{_libdir}/libkopetecontactlist.so.*.*.*
337 %attr(755,root,root) %ghost %{_libdir}/libkopetecontactlist.so.1
338 %attr(755,root,root) %{_libdir}/libkopeteidentity.so.*.*.*
339 %attr(755,root,root) %ghost %{_libdir}/libkopeteidentity.so.1
340 %attr(755,root,root) %{_libdir}/libkopeteprivacy.so.*.*.*
341 %attr(755,root,root) %ghost %{_libdir}/libkopeteprivacy.so.1
342 %attr(755,root,root) %{_libdir}/libkopetestatusmenu.so.*.*.*
343 %attr(755,root,root) %ghost %{_libdir}/libkopetestatusmenu.so.1
344 %attr(755,root,root) %{_libdir}/libkyahoo.so.*.*.*
345 %attr(755,root,root) %ghost %{_libdir}/libkyahoo.so.1
346 %attr(755,root,root) %{_libdir}/liboscar.so.*.*.*
347 %attr(755,root,root) %ghost %{_libdir}/liboscar.so.1
348 %attr(755,root,root) %{_libdir}/libqgroupwise.so
349 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_accountconfig.so
350 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_addbookmarks.so
351 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_appearanceconfig.so
352 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_autoreplace.so
353 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_avdeviceconfig.so
354 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_behaviorconfig.so
355 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_chatwindowconfig.so
356 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_cryptography.so
357 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_highlight.so
358 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_history.so
359 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_history2.so
360 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_latex.so
361 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_nowlistening.so
362 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_otr.so
363 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_pipes.so
364 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_pluginconfig.so
365 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_privacy.so
366 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_statusconfig.so
367 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_texteffect.so
368 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_translator.so
369 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_urlpicpreview.so
370 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_webpresence.so
371 %attr(755,root,root) %{_libdir}/kde4/kopete_addbookmarks.so
372 %attr(755,root,root) %{_libdir}/kde4/kopete_aim.so
373 %attr(755,root,root) %{_libdir}/kde4/kopete_autoreplace.so
374 %attr(755,root,root) %{_libdir}/kde4/kopete_bonjour.so
375 %attr(755,root,root) %{_libdir}/kde4/kopete_chatwindow.so
376 %attr(755,root,root) %{_libdir}/kde4/kopete_contactnotes.so
377 %attr(755,root,root) %{_libdir}/kde4/kopete_cryptography.so
378 %attr(755,root,root) %{_libdir}/kde4/kopete_emailwindow.so
379 %attr(755,root,root) %{_libdir}/kde4/kopete_gadu.so
380 %attr(755,root,root) %{_libdir}/kde4/kopete_groupwise.so
381 %attr(755,root,root) %{_libdir}/kde4/kopete_highlight.so
382 %attr(755,root,root) %{_libdir}/kde4/kopete_history.so
383 %attr(755,root,root) %{_libdir}/kde4/kopete_history2.so
384 %attr(755,root,root) %{_libdir}/kde4/kopete_icq.so
385 %attr(755,root,root) %{_libdir}/kde4/kopete_jabber.so
386 %attr(755,root,root) %{_libdir}/kde4/kopete_latex.so
387 %attr(755,root,root) %{_libdir}/kde4/kopete_meanwhile.so
388 %attr(755,root,root) %{_libdir}/kde4/kopete_nowlistening.so
389 %attr(755,root,root) %{_libdir}/kde4/kopete_otr.so
390 %attr(755,root,root) %{_libdir}/kde4/kopete_pipes.so
391 %attr(755,root,root) %{_libdir}/kde4/kopete_privacy.so
392 %attr(755,root,root) %{_libdir}/kde4/kopete_qq.so
393 %attr(755,root,root) %{_libdir}/kde4/kopete_skype.so
394 %attr(755,root,root) %{_libdir}/kde4/kopete_sms.so
395 %attr(755,root,root) %{_libdir}/kde4/kopete_statistics.so
396 %attr(755,root,root) %{_libdir}/kde4/kopete_testbed.so
397 %attr(755,root,root) %{_libdir}/kde4/kopete_texteffect.so
398 %attr(755,root,root) %{_libdir}/kde4/kopete_translator.so
399 %attr(755,root,root) %{_libdir}/kde4/kopete_urlpicpreview.so
400 %attr(755,root,root) %{_libdir}/kde4/kopete_webpresence.so
401 %attr(755,root,root) %{_libdir}/kde4/kopete_wlm.so
402 %attr(755,root,root) %{_libdir}/kde4/kopete_wp.so
403 %attr(755,root,root) %{_libdir}/kde4/kopete_yahoo.so
404 %attr(755,root,root) %{_libdir}/kde4/libchattexteditpart.so
405 %attr(755,root,root) %{_libdir}/kde4/plugins/accessible/chatwindowaccessiblewidgetfactory.so
406 %attr(755,root,root) %{_datadir}/apps/kconf_update/kopete-*.pl
407 %attr(755,root,root) %{_datadir}/apps/kconf_update/kopete-*.sh
408 %{_datadir}/apps/kconf_update/kopete-*.upd
409 %{_datadir}/apps/kopete
410 %{_datadir}/apps/kopete_contactnotes
411 %{_datadir}/apps/kopete_cryptography
412 %{_datadir}/apps/kopete_groupwise
413 %{_datadir}/apps/kopete_history
414 %{_datadir}/apps/kopete_history2
415 %{_datadir}/apps/kopete_jabber
416 %{_datadir}/apps/kopete_latex
417 %{_datadir}/apps/kopete_otr
418 %{_datadir}/apps/kopete_privacy
419 %{_datadir}/apps/kopete_skype
420 %{_datadir}/apps/kopete_statistics
421 %{_datadir}/apps/kopete_translator
422 %{_datadir}/apps/kopete_wlm
423 %{_datadir}/apps/kopete_yahoo
424 %{_datadir}/apps/kopeterichtexteditpart
425 %{_datadir}/config/kopeterc
426 %{_datadir}/config.kcfg/history2config.kcfg
427 %{_datadir}/config.kcfg/historyconfig.kcfg
428 %{_datadir}/config.kcfg/kopete_otr.kcfg
429 %{_datadir}/config.kcfg/kopeteappearancesettings.kcfg
430 %{_datadir}/config.kcfg/kopetebehaviorsettings.kcfg
431 %{_datadir}/config.kcfg/kopetestatussettings.kcfg
432 %{_datadir}/config.kcfg/latexconfig.kcfg
433 %{_datadir}/config.kcfg/nowlisteningconfig.kcfg
434 %{_datadir}/config.kcfg/translatorconfig.kcfg
435 %{_datadir}/config.kcfg/urlpicpreview.kcfg
436 %{_datadir}/config.kcfg/webpresenceconfig.kcfg
437 %{_datadir}/dbus-1/interfaces/org.kde.Kopete.xml
438 %{_datadir}/dbus-1/interfaces/org.kde.kopete.Client.xml
439 %{_datadir}/dbus-1/interfaces/org.kde.kopete.Statistics.xml
440 %{_datadir}/kde4/services/aim.protocol
441 %{_datadir}/kde4/services/callto.protocol
442 %{_datadir}/kde4/services/skype.protocol
443 %{_datadir}/kde4/services/tel.protocol
444 %{_datadir}/kde4/services/xmpp.protocol
445 %{_datadir}/kde4/services/chatwindow.desktop
446 %{_datadir}/kde4/services/emailwindow.desktop
447 %{_datadir}/kde4/services/kopete_*.desktop
448 %{_datadir}/kde4/services/kconfiguredialog
449 %{_datadir}/kde4/servicetypes/kopeteplugin.desktop
450 %{_datadir}/kde4/servicetypes/kopeteprotocol.desktop
451 %{_datadir}/kde4/servicetypes/kopeteui.desktop
452 %{_datadir}/sounds/Kopete_*.ogg
453 %{_desktopdir}/kde4/kopete.desktop
454 %{_iconsdir}/hicolor/*x*/apps/kopete*.png
455 %{_iconsdir}/hicolor/scalable/apps/kopete*.svgz
456 %{_iconsdir}/oxygen/*x*/actions/account_offline_overlay.png
457 %{_iconsdir}/oxygen/*x*/actions/contact_*_overlay.png
458 %{_iconsdir}/oxygen/*x*/actions/emoticon.png
459 %{_iconsdir}/oxygen/*x*/actions/im-status-message-edit.png
460 %{_iconsdir}/oxygen/*x*/actions/metacontact_unknown.png
461 %{_iconsdir}/oxygen/*x*/actions/status_unknown.png
462 %{_iconsdir}/oxygen/*x*/actions/status_unknown_overlay.png
463 %{_iconsdir}/oxygen/*x*/actions/view-user-offline-kopete.png
464 %{_iconsdir}/oxygen/*x*/actions/voicecall.png
465 %{_iconsdir}/oxygen/*x*/actions/webcamreceive.png
466 %{_iconsdir}/oxygen/*x*/actions/webcamsend.png
467 %{_iconsdir}/oxygen/22x22/status/object-locked-*.png
468 %{_iconsdir}/oxygen/32x32/actions/newmessage.mng
469 %{_iconsdir}/oxygen/48x48/actions/mail-encrypt.png
470 %{_iconsdir}/oxygen/scalable/actions/account_offline_overlay.svgz
471 %{_iconsdir}/oxygen/scalable/actions/im-status-message-edit.svgz
472 %{_iconsdir}/oxygen/scalable/actions/mail-encrypt.svgz
473 %{_iconsdir}/oxygen/scalable/actions/view-user-offline-kopete.svgz
474 %{_iconsdir}/oxygen/scalable/actions/voicecall.svgz
475 %{_iconsdir}/oxygen/scalable/actions/webcamreceive.svgz
476 %{_iconsdir}/oxygen/scalable/actions/webcamsend.svgz
477 %{_iconsdir}/oxygen/scalable/status/object-locked-*.svgz
478
479 %files devel
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{_libdir}/libkopete*.so
482 %attr(755,root,root) %{_libdir}/libkyahoo.so
483 %attr(755,root,root) %{_libdir}/liboscar.so
484 %{_includedir}/kopete
485
486 %if %{with npapi}
487 %files -n browser-plugin-kde4-kopete-skypebuttons
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_browserpluginsdir}/skypebuttons.so
490 %endif
This page took 0.054158 seconds and 3 git commands to generate.