]> git.pld-linux.org Git - SPECS.git/blob - ka6-neochat.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / ka6-neochat.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      24.02.2
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          neochat
8 Summary:        A Qt/QML based Matrix client
9 Name:           ka6-%{kaname}
10 Version:        24.02.2
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  610d37a71b47f703ce7ef3886dd1107d
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt6Core-devel >= 5.15.0
18 BuildRequires:  Qt6Gui-devel
19 BuildRequires:  Qt6Keychain-devel
20 BuildRequires:  Qt6Multimedia-devel
21 BuildRequires:  Qt6Network-devel
22 BuildRequires:  Qt6Qml-devel >= 5.15.10
23 BuildRequires:  Qt6Quick-devel
24 BuildRequires:  Qt6Svg-devel
25 BuildRequires:  Qt6Widgets-devel
26 BuildRequires:  cmake >= 3.20
27 BuildRequires:  cmark-devel
28 BuildRequires:  fontconfig-devel
29 BuildRequires:  freetype-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  kf6-extra-cmake-modules >= 5.105.0
32 BuildRequires:  kf6-kconfig-devel >= 5.109.0
33 BuildRequires:  kf6-kconfigwidgets-devel >= 5.109.0
34 BuildRequires:  kf6-kcoreaddons-devel >= 5.109.0
35 BuildRequires:  kf6-kdbusaddons-devel >= 5.105.0
36 BuildRequires:  kf6-kdoctools >= 5.105.0
37 BuildRequires:  kf6-ki18n-devel >= 5.105.0
38 BuildRequires:  kf6-kio-devel >= 5.105.0
39 BuildRequires:  kf6-kirigami-devel >= 5.105.0
40 BuildRequires:  kf6-kitemmodels-devel >= 5.105.0
41 BuildRequires:  kf6-knotifications-devel >= 5.105.0
42 BuildRequires:  kf6-kwindowsystem-devel >= 5.105.0
43 BuildRequires:  kf6-qqc2-desktop-style-devel >= 5.105.0
44 BuildRequires:  kf6-sonnet-devel >= 5.105.0
45 BuildRequires:  kirigami-addons-devel >= 0.7.2
46 BuildRequires:  kquickimageeditor-devel >= 0.3.0
47 BuildRequires:  libQuotient-qt6-devel >= 0.8.1.2-2
48 BuildRequires:  ninja
49 BuildRequires:  pkgconfig
50 BuildRequires:  qcoro-qt6-devel >= 0.4
51 BuildRequires:  qt6-build >= %{qtver}
52 BuildRequires:  rpmbuild(macros) >= 1.164
53 BuildRequires:  shared-mime-info
54 BuildRequires:  tar >= 1:1.22
55 BuildRequires:  xz
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 NeoChat is a client for [Matrix](https://matrix.org), the
60 decentralized communication protocol for instant messaging. It is a
61 fork of Spectral, using KDE frameworks, most notably
62 [Kirigami](https://invent.kde.org/frameworks/kirigami) to provide a
63 convergent experience across multiple platforms.
64
65 NeoChat also make use of other KDE Frameworks as well as
66 [libQuotient](https://github.com/quotient-im/libQuotient), a Qt-based
67 SDK for the [Matrix Protocol](https://spec.matrix.org/).
68
69 %prep
70 %setup -q -n %{kaname}-%{version}
71
72 %build
73 %cmake \
74         -B build \
75         -G Ninja \
76         %{!?with_tests:-DBUILD_TESTING=OFF} \
77         -DKDE_INSTALL_DOCBUNDLEDIR=%{_kdedocdir} \
78         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
79         -DQT_MAJOR_VERSION=6
80 %ninja_build -C build
81
82 %if %{with tests}
83 ctest --test-dir build
84 %endif
85
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %ninja_install -C build
90
91 # not supported by glibc yet (2.37)
92 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ie,tok}
93
94 %find_lang %{kaname} --all-name --with-kde
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files -f %{kaname}.lang
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_bindir}/neochat
102 %{_desktopdir}/org.kde.neochat.desktop
103 %{_iconsdir}/hicolor/scalable/apps/org.kde.neochat.svg
104 %{_iconsdir}/hicolor/scalable/apps/org.kde.neochat.tray.svg
105 %{_datadir}/knotifications6/neochat.notifyrc
106 %{_datadir}/krunner/dbusplugins/plasma-runner-neochat.desktop
107 %lang(ca) %{_mandir}/ca/man1/neochat.1*
108 %lang(es) %{_mandir}/es/man1/neochat.1*
109 %lang(it) %{_mandir}/it/man1/neochat.1*
110 %{_mandir}/man1/neochat.1*
111 %lang(nl) %{_mandir}/nl/man1/neochat.1*
112 %lang(sv) %{_mandir}/sv/man1/neochat.1*
113 %lang(tr) %{_mandir}/tr/man1/neochat.1*
114 %lang(uk) %{_mandir}/uk/man1/neochat.1*
115 %{_datadir}/metainfo/org.kde.neochat.appdata.xml
116 %{_datadir}/qlogging-categories6/neochat.categories
This page took 0.269597 seconds and 3 git commands to generate.