]> git.pld-linux.org Git - packages/ka5-kteatime.git/blob - ka5-kteatime.spec
40b4fd52c897650145fb904d267669c875e13c00
[packages/ka5-kteatime.git] / ka5-kteatime.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.04.2
5 %define         kframever       5.56.0
6 %define         qtver           5.9.0
7 %define         kaname          kteatime
8 Summary:        kteatime
9 Summary(pl.UTF-8):      kteatime
10 Name:           ka5-%{kaname}
11 Version:        22.04.2
12 Release:        1
13 License:        GPL v2+
14 Group:          X11/Libraries
15 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
16 # Source0-md5:  26cfa798382e818e9707f5ceb00cbc3a
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Core-devel
19 BuildRequires:  Qt5Gui-devel >= 5.11.1
20 BuildRequires:  Qt5Widgets-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
23 BuildRequires:  kf5-kconfig-devel >= %{kframever}
24 BuildRequires:  kf5-kcrash-devel >= %{kframever}
25 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
26 BuildRequires:  kf5-ki18n-devel >= %{kframever}
27 BuildRequires:  kf5-kiconthemes-devel >= %{kframever}
28 BuildRequires:  kf5-knotifications-devel >= %{kframever}
29 BuildRequires:  kf5-knotifyconfig-devel >= %{kframever}
30 BuildRequires:  kf5-ktextwidgets-devel >= %{kframever}
31 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
32 BuildRequires:  ninja
33 BuildRequires:  rpmbuild(macros) >= 1.164
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 KTeaTime is a handy timer for steeping tea. No longer will you have to
38 guess at how long it takes for your tea to be ready. Simply select the
39 type of tea you have, and it will alert you when the tea is ready to
40 drink.
41
42 %description -l pl.UTF-8
43 KTeaTime jest przydatnym stoperem do zaparzania herbaty. Nie musisz
44 więcej zgadywać jak długo trzeba czekać aż herbata będzie gotowa.
45 Po prostu zaznacz typ herbaty którą masz i KTeaTime powiadomi Cię,
46 gdy napój będzie gotowy do picia.
47
48 %prep
49 %setup -q -n %{kaname}-%{version}
50
51 %build
52 install -d build
53 cd build
54 %cmake \
55         -G Ninja \
56         %{!?with_tests:-DBUILD_TESTING=OFF} \
57         -DHTML_INSTALL_DIR=%{_kdedocdir} \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ..
60 %ninja_build
61
62 %if %{with tests}
63 ctest
64 %endif
65
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %ninja_install -C build
70
71 %find_lang %{kaname} --all-name --with-kde
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files -f %{kaname}.lang
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_bindir}/kteatime
79 %{_desktopdir}/org.kde.kteatime.desktop
80 %{_iconsdir}/hicolor/16x16/apps/kteatime.png
81 %{_iconsdir}/hicolor/22x22/apps/kteatime.png
82 %{_iconsdir}/hicolor/32x32/apps/kteatime.png
83 %{_iconsdir}/hicolor/48x48/apps/kteatime.png
84 %{_iconsdir}/hicolor/64x64/apps/kteatime.png
85 %{_iconsdir}/hicolor/scalable/apps/kteatime.svgz
86 %{_datadir}/knotifications5/kteatime.notifyrc
87 %{_datadir}/metainfo/org.kde.kteatime.appdata.xml
This page took 0.106243 seconds and 2 git commands to generate.