]> git.pld-linux.org Git - packages/ka5-kdiamond.git/blob - ka5-kdiamond.spec
rebuild against QT 5.15.9
[packages/ka5-kdiamond.git] / ka5-kdiamond.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.3
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kdiamond
8 Summary:        kdiamond
9 Name:           ka5-%{kaname}
10 Version:        22.12.3
11 Release:        2
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications/Games
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  d6d934dffe58cec19a5c301c50b72bba
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Qml-devel >= 5.11.1
20 BuildRequires:  Qt5Quick-devel >= 5.11.1
21 BuildRequires:  Qt5Widgets-devel
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  gettext-devel
24 BuildRequires:  ka5-libkdegames-devel >= %{kdeappsver}
25 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
26 BuildRequires:  kf5-kconfig-devel >= %{kframever}
27 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
28 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
29 BuildRequires:  kf5-kcrash-devel >= %{kframever}
30 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
31 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
32 BuildRequires:  kf5-ki18n-devel >= %{kframever}
33 BuildRequires:  kf5-knotifications-devel >= %{kframever}
34 BuildRequires:  kf5-knotifyconfig-devel >= %{kframever}
35 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
36 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
37 BuildRequires:  ninja
38 BuildRequires:  qt5-build >= %{qtver}
39 BuildRequires:  rpmbuild(macros) >= 1.164
40 BuildRequires:  shared-mime-info
41 BuildRequires:  tar >= 1:1.22
42 BuildRequires:  xz
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 KDiamond is a single player puzzle game. The object of the game is to
47 build lines of three similar diamonds.
48
49 %description -l pl.UTF-8
50 KDiamond to jednoosobowa gra logiczna. Celem gry jest zbudowanie linii
51 z trzech podobnych diamentów.
52
53 %prep
54 %setup -q -n %{kaname}-%{version}
55
56 %build
57 install -d build
58 cd build
59 %cmake \
60         -G Ninja \
61         %{!?with_tests:-DBUILD_TESTING=OFF} \
62         -DHTML_INSTALL_DIR=%{_kdedocdir} \
63         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
64         ..
65 %ninja_build
66
67 %if %{with tests}
68 ctest
69 %endif
70
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %ninja_install -C build
75
76 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/lt
77 %find_lang %{kaname} --all-name --with-kde
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82
83 %files -f %{kaname}.lang
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_bindir}/kdiamond
86 %{_desktopdir}/org.kde.kdiamond.desktop
87 %{_iconsdir}/hicolor/128x128/apps/kdiamond.png
88 %{_iconsdir}/hicolor/16x16/apps/kdiamond.png
89 %{_iconsdir}/hicolor/22x22/apps/kdiamond.png
90 %{_iconsdir}/hicolor/32x32/apps/kdiamond.png
91 %{_iconsdir}/hicolor/48x48/apps/kdiamond.png
92 %{_iconsdir}/hicolor/64x64/apps/kdiamond.png
93 %{_datadir}/kdiamond
94 %{_datadir}/knotifications5/kdiamond.notifyrc
95 %{_datadir}/sounds/KDiamond-Stone-Drop.ogg
96 %{_datadir}/sounds/KDiamond-Stone-Swap.ogg
97 %{_datadir}/sounds/KDiamond-Stone-Touch.ogg
98 %{_datadir}/metainfo/org.kde.kdiamond.appdata.xml
99 %{_datadir}/knsrcfiles/kdiamond.knsrc
This page took 0.183175 seconds and 3 git commands to generate.