]> git.pld-linux.org Git - packages/ka5-kcolorchooser.git/blob - ka5-kcolorchooser.spec
- updated to 23.08.1
[packages/ka5-kcolorchooser.git] / ka5-kcolorchooser.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.1
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kcolorchooser
8 Summary:        KColorChooser
9 Name:           ka5-%{kaname}
10 Version:        23.08.1
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  effb6ea84f7e0af54987bef7d8eba26f
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 3.20
19 BuildRequires:  gettext-devel
20 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
21 BuildRequires:  kf5-ki18n-devel >= %{kframever}
22 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
23 BuildRequires:  ninja
24 BuildRequires:  qt5-build >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  shared-mime-info
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 KColorChooser is a simple application to select the color from the
33 screen or from a pallete.
34
35 Features:
36
37 Select colors from any location on the screen. Select colors from a
38 range of standard palletes available. Color values shown in
39 Hue-Saturation-Value (HSV), Red-Green-Blue (RGB) and HTML formats.
40
41 %description -l pl.UTF-8
42 KColorChooser jest prostą aplikacją do wybrania koloru z ekranu
43 lub z palety.
44
45 Właściwości:
46
47 Zaznaczenie kolorów z dowolnej lokalizacji na ekranie. Wybieranie
48 kolorów z zestawu standardowych palet. Wartości są pokazywane
49 W Hue-Saturation-Value (HSV), Red-Green-Blue (RGB) i w formacie
50 HTML.
51
52 %prep
53 %setup -q -n %{kaname}-%{version}
54
55 %build
56 %cmake \
57         -B build \
58         -G Ninja \
59         %{!?with_tests:-DBUILD_TESTING=OFF} \
60         -DHTML_INSTALL_DIR=%{_kdedocdir} \
61         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
62 %ninja_build -C build
63
64 %if %{with tests}
65 ctest --test-dir build
66 %endif
67
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 %ninja_install -C build
72
73 %find_lang %{kaname} --all-name --with-kde
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files -f %{kaname}.lang
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_bindir}/kcolorchooser
81 %{_desktopdir}/org.kde.kcolorchooser.desktop
82 %{_iconsdir}/hicolor/16x16/apps/kcolorchooser.png
83 %{_iconsdir}/hicolor/22x22/apps/kcolorchooser.png
84 %{_datadir}/metainfo/org.kde.kcolorchooser.appdata.xml
This page took 0.079912 seconds and 3 git commands to generate.