]> git.pld-linux.org Git - packages/ka5-juk.git/blob - ka5-juk.spec
- updated to 21.04.1
[packages/ka5-juk.git] / ka5-juk.spec
1 %define         kdeappsver      21.04.1
2 %define         kframever       5.56.0
3 %define         qtver           5.9.0
4 %define         kaname          juk
5 Summary:        Juk
6 Name:           ka5-%{kaname}
7 Version:        21.04.1
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          X11/Multimedia
11 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
12 # Source0-md5:  3189e43b7594fec23d1153d018de56c0
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  cmake >= 2.8.12
16 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
17 BuildRequires:  ninja
18 BuildRequires:  qt5-build >= %{qtver}
19 BuildRequires:  qt5-phonon-devel
20 BuildRequires:  rpmbuild(macros) >= 1.164
21 BuildRequires:  shared-mime-info
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 JuK is an audio jukebox application, supporting collections of MP3,
28 Ogg Vorbis, and FLAC audio files. It allows you to edit the "tags" of
29 your audio files, and manage your collection and playlists. It's main
30 focus, in fact, is on music management.
31
32 Features
33
34 • Collection list and multiple user defined playlists
35 • Ability to scan directories to automatically import playlists and
36   music files on start up
37 • Dynamic Search Playlists that are automatically updated as fields in
38   the collection change.
39 • A Tree View mode where playlists are automatically generated for
40   sets of albums, artists and genres.
41 • Playlist history to indicate which files have been played and when.
42 • Inline search for filtering the list of visible items.
43 • The ability to guess tag information from the file name or using
44   MusicBrainz online lookup.
45 • File renamer that can rename files based on the tag content.
46 • ID3v1, ID3v2 and Ogg Vorbis tag reading and editing support (via
47   TagLib).
48
49 %prep
50 %setup -q -n %{kaname}-%{version}
51
52 %build
53 install -d build
54 cd build
55 %cmake \
56         -G Ninja \
57         -DHTML_INSTALL_DIR=%{_kdedocdir} \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ..
60 %ninja_build
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
67 %find_lang %{kaname} --all-name --with-kde
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files -f %{kaname}.lang
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_bindir}/juk
78 %{_datadir}/dbus-1/interfaces/org.kde.juk.collection.xml
79 %{_datadir}/dbus-1/interfaces/org.kde.juk.player.xml
80 %{_datadir}/dbus-1/interfaces/org.kde.juk.search.xml
81 %{_iconsdir}/hicolor/128x128/apps/juk.png
82 %{_iconsdir}/hicolor/16x16/apps/juk.png
83 %{_iconsdir}/hicolor/32x32/apps/juk.png
84 %{_iconsdir}/hicolor/48x48/apps/juk.png
85 %{_iconsdir}/hicolor/64x64/apps/juk.png
86 %{_datadir}/metainfo/org.kde.juk.appdata.xml
87 %{_desktopdir}/org.kde.juk.desktop
88 %{_datadir}/juk
89 %{_datadir}/kservices5/ServiceMenus/jukservicemenu.desktop
90 %{_datadir}/kxmlgui5/juk
91 %{_datadir}/knotifications5/juk.notifyrc
This page took 0.074076 seconds and 3 git commands to generate.