]> git.pld-linux.org Git - packages/ka5-bovo.git/blob - ka5-bovo.spec
- updated to 18.12.1; ninja
[packages/ka5-bovo.git] / ka5-bovo.spec
1 %define         kdeappsver      18.12.1
2 %define         qtver           5.9.0
3 %define         kaname          bovo
4 Summary:        A Gomoku like game
5 Name:           ka5-%{kaname}
6 Version:        18.12.1
7 Release:        1
8 License:        GPL v2+/LGPL v2.1+
9 Group:          X11/Applications/Games
10 Source0:        http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
11 # Source0-md5:  1b4a569802c5d5d24a3adda14b962f40
12 URL:            http://www.kde.org/
13 BuildRequires:  Qt5Concurrent-devel
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= 5.11.1
16 BuildRequires:  Qt5Qml-devel >= 5.11.1
17 BuildRequires:  Qt5Quick-devel >= 5.11.1
18 BuildRequires:  Qt5Svg-devel
19 BuildRequires:  Qt5Widgets-devel
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  gettext-devel
22 BuildRequires:  ka5-libkdegames-devel >= %{kdeappsver}
23 BuildRequires:  kf5-extra-cmake-modules >= 5.53.0
24 BuildRequires:  kf5-kcoreaddons-devel >= 5.30.0
25 BuildRequires:  kf5-kcrash-devel >= 5.30.0
26 BuildRequires:  kf5-kdbusaddons-devel >= 5.30.0
27 BuildRequires:  kf5-kdoctools-devel >= 5.30.0
28 BuildRequires:  kf5-kxmlgui-devel >= 5.30.0
29 BuildRequires:  ninja
30 BuildRequires:  qt5-build >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.164
32 BuildRequires:  shared-mime-info
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Bovo is a Gomoku like game for two players, where the opponents
39 alternate in placing their respective pictogram on the game board.
40 (Also known as: Connect Five, Five in a row, X and O, Naughts and
41 Crosses)
42
43 %prep
44 %setup -q -n %{kaname}-%{version}
45
46 %build
47 install -d build
48 cd build
49 %cmake \
50         -G Ninja \
51         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
52         ..
53 %ninja_build
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 %ninja_install -C build
58
59 %find_lang %{kaname} --all-name --with-kde
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files -f %{kaname}.lang
68 %defattr(644,root,root,755)
69 %attr(755,root,root) %{_bindir}/bovo
70 %{_desktopdir}/org.kde.bovo.desktop
71 %{_datadir}/bovo
72 %{_iconsdir}/hicolor/128x128/apps/bovo.png
73 %{_iconsdir}/hicolor/16x16/apps/bovo.png
74 %{_iconsdir}/hicolor/22x22/apps/bovo.png
75 %{_iconsdir}/hicolor/32x32/apps/bovo.png
76 %{_iconsdir}/hicolor/48x48/apps/bovo.png
77 %{_iconsdir}/hicolor/64x64/apps/bovo.png
78 %dir %{_datadir}/kxmlgui5/bovo
79 %{_datadir}/kxmlgui5/bovo/bovoui.rc
80 %{_datadir}/metainfo/org.kde.bovo.appdata.xml
This page took 0.053839 seconds and 4 git commands to generate.