]> git.pld-linux.org Git - packages/ka5-blinken.git/blob - ka5-blinken.spec
7b296ac8614feb8fdd55ff07c11395db2ebdc846
[packages/ka5-blinken.git] / ka5-blinken.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          blinken
8 Summary:        Blinken
9 Name:           ka5-%{kaname}
10 Version:        23.08.5
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications/Games
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  573161a91aa3a9aebff8485740e2a5cd
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Svg-devel
20 BuildRequires:  Qt5Widgets-devel
21 BuildRequires:  cmake >= 3.20
22 BuildRequires:  gettext-devel
23 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
24 BuildRequires:  kf5-kcrash-devel >= %{kframever}
25 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
26 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
27 BuildRequires:  kf5-kguiaddons-devel >= %{kframever}
28 BuildRequires:  kf5-ki18n-devel >= %{kframever}
29 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
30 BuildRequires:  ninja
31 BuildRequires:  phonon-qt5-devel
32 BuildRequires:  qt5-build >= %{qtver}
33 BuildRequires:  rpmbuild(macros) >= 1.164
34 BuildRequires:  shared-mime-info
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Blinken is based on an electronic game released in 1978, which
41 challenges players to remember sequences of increasing length. On the
42 face of the device, there are 4 different color buttons, each one with
43 their own distinctive sound. These buttons light up randomly, creating
44 the sequence that the player must then recall. If the player is
45 successful in remembering the sequence of lights in the correct order,
46 he advances to the next stage, where an identical sequence with one
47 extra step is presented. If the player makes a mistake, the game is
48 lost, and the player must start again from the beginning. The goal is
49 to get a high score - each step in the sequence is worth one point, so
50 correct entry of a sequence of 8 lights is worth 8 points on the high
51 score table.
52
53 %description -l pl.UTF-8
54 Blinken jest oparty na grze elektronicznej wydanej w 1978 roku.
55 Wyzwaniem dla gracza jest zapamiętywanie coraz dłuższych sekwencji. Na
56 urządzeniu są 4 różne kolorowe przyciski, każdy z odróżnialnym
57 dźwiękiem. Przyciski te zapalają się losowo, tworząc sekwencję, którą
58 gracz musi zapamiętać i odtworzyć. Jeśli mu się to uda, przechodzi do
59 następnego poziomu, gdzie do identycznej sekwencji dodawany jest jeden
60 element. Jeśli gracz się pomyli, przegrywa i musi zacząć od początku.
61 Celem jest uzyskanie rekordu, każdy krok w sekwencji jest warty 1
62 punkt, więc prawidłowe powtórzenie 8 świateł jest warte 8 punktów w
63 tabeli rekordów.
64
65 %prep
66 %setup -q -n %{kaname}-%{version}
67
68 %build
69 %cmake \
70         -B build \
71         -G Ninja \
72         %{!?with_tests:-DBUILD_TESTING=OFF} \
73         -DHTML_INSTALL_DIR=%{_kdedocdir} \
74         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
75 %ninja_build -C build
76
77 %if %{with tests}
78 ctest --test-dir build
79 %endif
80
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %ninja_install -C build
85
86 %find_lang %{kaname} --all-name --with-kde
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files -f %{kaname}.lang
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_bindir}/blinken
97 %{_desktopdir}/org.kde.blinken.desktop
98 %{_datadir}/blinken
99 %{_datadir}/config.kcfg/blinken.kcfg
100 %{_iconsdir}/hicolor/128x128/apps/blinken.png
101 %{_iconsdir}/hicolor/16x16/apps/blinken.png
102 %{_iconsdir}/hicolor/22x22/apps/blinken.png
103 %{_iconsdir}/hicolor/32x32/apps/blinken.png
104 %{_iconsdir}/hicolor/48x48/apps/blinken.png
105 %{_iconsdir}/hicolor/64x64/apps/blinken.png
106 %{_iconsdir}/hicolor/scalable/apps/blinken.svgz
107 %{_datadir}/metainfo/org.kde.blinken.appdata.xml
This page took 0.082769 seconds and 3 git commands to generate.