]> git.pld-linux.org Git - SPECS.git/blob - jquery-notify-bar.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / jquery-notify-bar.spec
1 # TODO
2 # - make -demo package
3 %define         plugin  notify-bar
4 Summary:        jQuery Notify Bar plugin
5 Name:           jquery-%{plugin}
6 Version:        1.2.2
7 Release:        2
8 License:        MIT
9 Group:          Applications/WWW
10 Source0:        http://github.com/dknight/jQuery-Notify-bar/tarball/master?/%{plugin}.tgz
11 # Source0-md5:  e6929d46a44fcad5559970b5fe6d7e3b
12 URL:            http://www.dmitri.me/blog/notify-bar/
13 BuildRequires:  js
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 BuildRequires:  unzip
16 BuildRequires:  yuicompressor
17 Requires:       jquery >= 1.3
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _appdir %{_datadir}/jquery/%{plugin}
22
23 %description
24 Simple plugin (basically it's not a plugin, but widget) to show notify
25 bar (like on Twitter’s webpage).
26
27 %prep
28 %setup -qc
29 mv *-jQuery-Notify-bar-*/* .
30
31 %build
32 install -d build
33
34 # compress .js
35 yuicompressor --charset UTF-8 jquery.notifyBar.js -o build/notifyBar.js
36 js -C -f build/notifyBar.js
37
38 # compress .css
39 yuicompressor --charset UTF-8 jquery.notifyBar.css -o build/notifyBar.css
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
44 cp -a build/* $RPM_BUILD_ROOT%{_appdir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc README.textile
52 %{_appdir}
This page took 0.252334 seconds and 3 git commands to generate.